summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2010-09-25 20:23:16 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2010-09-25 20:23:16 +0000
commit6e6ee1e3bceb58ca6acfb03a9e34b3281585c767 (patch)
tree5e14bebb70427a2101134cee6b63ded15904476f /app-office/karbon
parentFixed configure script when cfitsio is not built with static-libs (diff)
downloadgentoo-2-6e6ee1e3bceb58ca6acfb03a9e34b3281585c767.tar.gz
gentoo-2-6e6ee1e3bceb58ca6acfb03a9e34b3281585c767.tar.bz2
gentoo-2-6e6ee1e3bceb58ca6acfb03a9e34b3281585c767.zip
Version bump
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-office/karbon')
-rw-r--r--app-office/karbon/ChangeLog8
-rw-r--r--app-office/karbon/karbon-2.2.2.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/app-office/karbon/ChangeLog b/app-office/karbon/ChangeLog
index fdb2d6be1783..f1c2cb222fd2 100644
--- a/app-office/karbon/ChangeLog
+++ b/app-office/karbon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/karbon
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/karbon/ChangeLog,v 1.108 2010/03/31 21:50:37 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/karbon/ChangeLog,v 1.109 2010/09/25 20:23:16 dilfridge Exp $
+
+*karbon-2.2.2 (25 Sep 2010)
+
+ 25 Sep 2010; Andreas K. Huettel <dilfridge@gentoo.org>
+ +karbon-2.2.2.ebuild:
+ Version bump
*karbon-2.1.2 (31 Mar 2010)
diff --git a/app-office/karbon/karbon-2.2.2.ebuild b/app-office/karbon/karbon-2.2.2.ebuild
new file mode 100644
index 000000000000..f65f22c6efa2
--- /dev/null
+++ b/app-office/karbon/karbon-2.2.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/karbon/karbon-2.2.2.ebuild,v 1.1 2010/09/25 20:23:16 dilfridge Exp $
+
+EAPI="2"
+KMNAME="koffice"
+KMMODULE="${PN}"
+
+inherit kde4-meta
+
+DESCRIPTION="KOffice vector drawing application."
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+pstoedit wpg"
+
+DEPEND="
+ media-libs/libart_lgpl
+ pstoedit? ( media-gfx/pstoedit )
+ wpg? ( media-libs/libwpg )
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRA="filters/${KMMODULE}"
+KMEXTRACTONLY="
+ libs/
+ plugins/
+ filters/
+"
+KMLOADLIBS="koffice-libs"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with wpg)
+ $(cmake-utils_use_with pstoedit)
+ )
+ kde4-meta_src_configure
+}
+
+src_install() {
+ kde4-meta_src_install
+
+ # this is already installed by koffice-data
+ rm -f "${D}/usr/include/config-opengl.h"
+}