summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-01-14 20:38:15 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-01-14 20:38:15 +0000
commitd4ae090832019ff0e7ed753c3398e613cf9e17f9 (patch)
tree8ff00965637a92db49d9ba47a1f7da7f89a27d55 /app-office/koffice-libs
parentarm stable (diff)
downloadgentoo-2-d4ae090832019ff0e7ed753c3398e613cf9e17f9.tar.gz
gentoo-2-d4ae090832019ff0e7ed753c3398e613cf9e17f9.tar.bz2
gentoo-2-d4ae090832019ff0e7ed753c3398e613cf9e17f9.zip
KOffice version bump
(Portage version: 2.1.9.31/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'app-office/koffice-libs')
-rw-r--r--app-office/koffice-libs/ChangeLog8
-rw-r--r--app-office/koffice-libs/koffice-libs-2.3.0.ebuild79
2 files changed, 86 insertions, 1 deletions
diff --git a/app-office/koffice-libs/ChangeLog b/app-office/koffice-libs/ChangeLog
index c399be67d21d..e20a62e81a0d 100644
--- a/app-office/koffice-libs/ChangeLog
+++ b/app-office/koffice-libs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/koffice-libs
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-libs/ChangeLog,v 1.118 2011/01/12 20:18:36 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-libs/ChangeLog,v 1.119 2011/01/14 20:38:14 dilfridge Exp $
+
+*koffice-libs-2.3.0 (14 Jan 2011)
+
+ 14 Jan 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +koffice-libs-2.3.0.ebuild:
+ Version bump
12 Jan 2011; Andreas K. Huettel <dilfridge@gentoo.org>
koffice-libs-2.2.2.ebuild:
diff --git a/app-office/koffice-libs/koffice-libs-2.3.0.ebuild b/app-office/koffice-libs/koffice-libs-2.3.0.ebuild
new file mode 100644
index 000000000000..70883b617f87
--- /dev/null
+++ b/app-office/koffice-libs/koffice-libs-2.3.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-libs/koffice-libs-2.3.0.ebuild,v 1.1 2011/01/14 20:38:14 dilfridge Exp $
+
+EAPI=3
+
+KMNAME="koffice"
+KMMODULE="libs"
+OPENGL_REQUIRED="optional"
+CPPUNIT_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="Shared KOffice libraries."
+KEYWORDS="~amd64 ~x86"
+IUSE="crypt openexr reports"
+
+RDEPEND="
+ >=app-office/koffice-data-${PV}:${SLOT}
+ dev-libs/libxml2
+ dev-libs/libxslt
+ >=kde-base/kdepimlibs-${KDE_MINIMAL}
+ media-libs/lcms:0
+ crypt? ( app-crypt/qca:2 )
+ openexr? ( media-libs/openexr )
+ opengl? ( media-libs/mesa )
+ !app-office/kchart
+"
+DEPEND="${RDEPEND}"
+# doc? ( app-doc/doxygen )"
+
+KMEXTRA="
+ doc/koffice/
+ doc/thesaurus/
+ filters/generic_wrapper/
+ filters/libkowmf/
+ filters/libmsooxml/
+ filters/xsltfilter/
+ filters/kchart/
+ filters/kformula/
+ interfaces/
+ kchart/
+ kformula/
+ kounavail/
+ plugins/
+ tools/
+"
+
+KMEXTRACTONLY="
+ KoConfig.h.cmake
+ doc/koffice.desktop
+ filters/
+"
+
+KMSAVELIBS="true"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with crypt QCA2)
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with openexr OpenEXR)
+ -DBUILD_kchart=ON
+ -DBUILD_kformula=ON
+ $(cmake-utils_use_build reports koreport)
+ )
+ use crypt && \
+ mycmakeargs+=(-DQCA2_LIBRARIES=/usr/$(get_libdir)/qca2/libqca.so.2)
+
+ kde4-meta_src_configure
+}
+
+src_install() {
+ newdoc kounavail/README README.kounavail || die
+
+ kde4-meta_src_install
+
+ # this is already installed by koffice-data
+ rm -f "${D}/usr/include/config-opengl.h"
+ rm -f "${D}/usr/include/KoConfig.h"
+}