summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2004-06-18 13:31:33 +0000
committerDavid Holm <dholm@gentoo.org>2004-06-18 13:31:33 +0000
commit7f479277f72404b19e80efba6493cfa89622bbfb (patch)
treeb4c7d4dae175683315f7c3c7cc6634449c263354 /app-office/plan
parentVersion bump, closing bug #52816 (Manifest recommit) (diff)
downloadgentoo-2-7f479277f72404b19e80efba6493cfa89622bbfb.tar.gz
gentoo-2-7f479277f72404b19e80efba6493cfa89622bbfb.tar.bz2
gentoo-2-7f479277f72404b19e80efba6493cfa89622bbfb.zip
Version bumped, and added to ~ppc
Diffstat (limited to 'app-office/plan')
-rw-r--r--app-office/plan/ChangeLog7
-rw-r--r--app-office/plan/Manifest6
-rw-r--r--app-office/plan/files/digest-plan-1.8.72
-rw-r--r--app-office/plan/plan-1.8.7.ebuild63
4 files changed, 75 insertions, 3 deletions
diff --git a/app-office/plan/ChangeLog b/app-office/plan/ChangeLog
index bc6f8ff8272c..1756894eadb8 100644
--- a/app-office/plan/ChangeLog
+++ b/app-office/plan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/plan
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/plan/ChangeLog,v 1.3 2004/03/19 04:08:31 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/plan/ChangeLog,v 1.4 2004/06/18 13:31:33 dholm Exp $
+
+*plan-1.8.7 (18 Jun 2004)
+
+ 18 Jun 2004; David Holm <dholm@gentoo.org> +plan-1.8.7.ebuild:
+ Version bumped, and added to ~ppc.
18 Mar 2004; Jason Wever <weeve@gentoo.org> plan-1.8.6.ebuild:
Added ~sparc keyword.
diff --git a/app-office/plan/Manifest b/app-office/plan/Manifest
index 8d1859caac21..cc349dc2eac4 100644
--- a/app-office/plan/Manifest
+++ b/app-office/plan/Manifest
@@ -1,5 +1,7 @@
-MD5 c838bc0cc918e443a78714c31ff2cb27 files/digest-plan-1.8.6 62
-MD5 43079e6d1e3b9dc22ce03a1e94758e02 files/plan-1.8.6-gentoo.tar.bz2 5744
MD5 fd02d37475b03cfd1267d867c62a9352 ChangeLog 616
MD5 7e4f3a18ef9764bf465ba82385e6234e metadata.xml 235
MD5 1881f95f60a34b1a5c0ed666b8b92608 plan-1.8.6.ebuild 1537
+MD5 be1d6a020123733c6f7a925c9c092cf8 plan-1.8.7.ebuild 1554
+MD5 c838bc0cc918e443a78714c31ff2cb27 files/digest-plan-1.8.6 62
+MD5 43079e6d1e3b9dc22ce03a1e94758e02 files/plan-1.8.6-gentoo.tar.bz2 5744
+MD5 9782b3dd9e3676b0f2fd6b076687be03 files/digest-plan-1.8.7 130
diff --git a/app-office/plan/files/digest-plan-1.8.7 b/app-office/plan/files/digest-plan-1.8.7
new file mode 100644
index 000000000000..a608952a1363
--- /dev/null
+++ b/app-office/plan/files/digest-plan-1.8.7
@@ -0,0 +1,2 @@
+MD5 76f7f522bb7e03de73d581b8b647fb3b plan-1.8.7.tar.gz 436792
+MD5 eae51738c55bdc4a8c839e906b4f337e plan-1.8.7-gentoo.tar.bz2 9371
diff --git a/app-office/plan/plan-1.8.7.ebuild b/app-office/plan/plan-1.8.7.ebuild
new file mode 100644
index 000000000000..dbe9b881fcb0
--- /dev/null
+++ b/app-office/plan/plan-1.8.7.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/plan/plan-1.8.7.ebuild,v 1.1 2004/06/18 13:31:33 dholm Exp $
+
+inherit eutils
+
+DESCRIPTION="Motif based schedule planner"
+HOMEPAGE="http://www.bitrot.de/plan.html"
+SRC_URI="ftp://plan.ftp.fu-berlin.de/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc"
+
+DEPEND="virtual/x11
+ x11-libs/openmotif"
+
+S=${WORKDIR}/${P}/src
+
+src_unpack() {
+ unpack ${A}
+ epatch ${WORKDIR}/${P}-errno.patch
+ epatch ${WORKDIR}/${P}-gentoo.patch
+ epatch ${WORKDIR}/${P}-webplan.patch
+}
+
+src_compile() {
+ make linux || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ keepdir /usr/share/plan/netplan.dir
+
+ cd ${S}/..
+ dodoc HISTORY README || die "dodoc failed"
+
+ cd ${S}/../misc
+ doman netplan.1 plan.1 plan.4 || die "doman failed"
+
+ insinto /usr/share/${PN}/misc
+ doins netplan.boot BlackWhite Monochrome plan.fti Plan.xpm plan.xpm \
+ || die "misc files install failed"
+ exeinto /usr/share/${PN}/misc
+ doexe Killpland cvs vsc msschedule2plan plan2vcs || die "misc files install failed"
+
+ cd ${S}/../web
+ insinto /usr/share/${PN}/web
+ doins help.html bottom.html cgi-lib.pl common.pl holiday_webplan rtsban.jpg \
+ || die "webplan install failed"
+ exeinto /usr/share/${PN}/web
+ doexe *.cgi || die "webplan install failed"
+}
+
+pkg_postinst() {
+ einfo
+ einfo " Check /usr/share/${PN}/holiday for examples to set your"
+ einfo " ~/.holiday according to your country."
+ einfo
+ einfo " WebPlan 1.8 can be found in /usr/share/${PN}/web."
+ einfo
+}