summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-06-25 16:42:58 +0000
committerPacho Ramos <pacho@gentoo.org>2013-06-25 16:42:58 +0000
commit263ef7927351bbbdb6923b32835dae2a415c4f9c (patch)
tree918bea6e29c48b05d0960704aec1af907b7bdf57 /app-office/planner
parentset AS to yasm based on CHOST which seems to be the sanest to do, bug #345161 (diff)
downloadgentoo-2-263ef7927351bbbdb6923b32835dae2a415c4f9c.tar.gz
gentoo-2-263ef7927351bbbdb6923b32835dae2a415c4f9c.tar.bz2
gentoo-2-263ef7927351bbbdb6923b32835dae2a415c4f9c.zip
We need to set compile-warnings to a different value as it doesn't use standard macro (#474610 by Juergen Rose).
(Portage version: 2.1.12.10/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'app-office/planner')
-rw-r--r--app-office/planner/ChangeLog6
-rw-r--r--app-office/planner/planner-0.14.6_p20130520.ebuild9
2 files changed, 11 insertions, 4 deletions
diff --git a/app-office/planner/ChangeLog b/app-office/planner/ChangeLog
index 1399f24187fd..09d4cbe2a1b6 100644
--- a/app-office/planner/ChangeLog
+++ b/app-office/planner/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/planner
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/planner/ChangeLog,v 1.71 2013/05/20 11:14:29 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/planner/ChangeLog,v 1.72 2013/06/25 16:42:58 pacho Exp $
+
+ 25 Jun 2013; Pacho Ramos <pacho@gentoo.org> planner-0.14.6_p20130520.ebuild:
+ We need to set compile-warnings to a different value as it doesn't use
+ standard macro (#474610 by Juergen Rose).
20 May 2013; Gilles Dartiguelongue <eva@gentoo.org> planner-0.14.6.ebuild,
planner-0.14.6_p20130520.ebuild:
diff --git a/app-office/planner/planner-0.14.6_p20130520.ebuild b/app-office/planner/planner-0.14.6_p20130520.ebuild
index f0be1ca76e69..2bfe246489d9 100644
--- a/app-office/planner/planner-0.14.6_p20130520.ebuild
+++ b/app-office/planner/planner-0.14.6_p20130520.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/planner/planner-0.14.6_p20130520.ebuild,v 1.2 2013/05/20 11:14:29 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/planner/planner-0.14.6_p20130520.ebuild,v 1.3 2013/06/25 16:42:58 pacho Exp $
EAPI="5"
GCONF_DEBUG="no"
@@ -17,6 +17,7 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
IUSE="eds examples python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
>=dev-libs/glib-2.6:2
@@ -46,18 +47,20 @@ S="${WORKDIR}/${PN}-0.14.6"
src_configure() {
# FIXME: disable eds backend for now, it fails, upstream bug #654005
+ # We need to set compile-warnings to a different value as it doesn't use
+ # standard macro: https://bugzilla.gnome.org/703067
gnome2_src_configure \
$(use_enable python) \
$(use_enable python python-plugin) \
$(use_enable eds) \
--disable-eds-backend \
--with-database=no \
- --disable-update-mimedb
+ --disable-update-mimedb \
+ --enable-compile-warnings=yes
#$(use_enable eds eds-backend)
}
src_install() {
- DOCS="AUTHORS COPYING ChangeLog NEWS README"
gnome2_src_install \
sqldocdir="\$(datadir)/doc/${PF}" \
sampledir="\$(datadir)/doc/${PF}/examples"