summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2010-04-25 19:54:32 +0000
committerVlastimil Babka <caster@gentoo.org>2010-04-25 19:54:32 +0000
commit91446d0bde128ba1384bd057ba17d67138329021 (patch)
treea269438fc832c07db6a5c0cb93fd7558406a5356 /app-office/taskcoach
parentAdd ~sh (diff)
downloadgentoo-2-91446d0bde128ba1384bd057ba17d67138329021.tar.gz
gentoo-2-91446d0bde128ba1384bd057ba17d67138329021.tar.bz2
gentoo-2-91446d0bde128ba1384bd057ba17d67138329021.zip
Version bump. Adds optional libnotify support via USE flag. Restrict python dependency to 2.x and support multiple python ABI's - bug #311687.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-office/taskcoach')
-rw-r--r--app-office/taskcoach/ChangeLog8
-rw-r--r--app-office/taskcoach/taskcoach-1.0.3.ebuild59
2 files changed, 66 insertions, 1 deletions
diff --git a/app-office/taskcoach/ChangeLog b/app-office/taskcoach/ChangeLog
index 6127ce8cce67..0f11293784ba 100644
--- a/app-office/taskcoach/ChangeLog
+++ b/app-office/taskcoach/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/taskcoach
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/ChangeLog,v 1.45 2010/04/11 23:03:08 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/ChangeLog,v 1.46 2010/04/25 19:54:32 caster Exp $
+
+*taskcoach-1.0.3 (25 Apr 2010)
+
+ 25 Apr 2010; Vlastimil Babka <caster@gentoo.org> +taskcoach-1.0.3.ebuild:
+ Version bump. Adds optional libnotify support via USE flag. Restrict
+ python dependency to 2.x and support multiple python ABI's - bug #311687.
*taskcoach-1.0.2 (11 Apr 2010)
diff --git a/app-office/taskcoach/taskcoach-1.0.3.ebuild b/app-office/taskcoach/taskcoach-1.0.3.ebuild
new file mode 100644
index 000000000000..bdb0d98860ee
--- /dev/null
+++ b/app-office/taskcoach/taskcoach-1.0.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/taskcoach-1.0.3.ebuild,v 1.1 2010/04/25 19:54:32 caster Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+PYTHON_MODNAME="buildlib taskcoachlib"
+
+inherit distutils eutils
+
+MY_PN="TaskCoach"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple personal tasks and todo lists manager"
+HOMEPAGE="http://www.taskcoach.org"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+DEPEND=">=dev-python/wxpython-2.8.9.2:2.8"
+RDEPEND="${DEPEND}
+ libnotify? ( dev-python/notify-python )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES.txt"
+
+src_unpack() {
+ default
+
+ einfo "Removing Funambol support, works only on x86 and python 2.5."
+ rm -fv "${S}"/taskcoachlib/bin.in/linux/*.so || die
+}
+
+src_install() {
+ distutils_src_install
+
+ # a bit ugly but...
+ mv "${D}/usr/bin/taskcoach.py" "${D}/usr/bin/taskcoach" || die
+ for file in "${D}"/usr/bin/taskcoach.py-*; do
+ dir=$(dirname ${file})
+ ver=$(basename ${file})
+ ver=${ver#taskcoach.py-}
+ mv "${file}" "${dir}/taskcoach-${ver}" || die
+ done
+
+ doicon "icons.in/${PN}.png" || die
+ make_desktop_entry ${PN} "Task Coach" ${PN} Office || die
+}
+
+pkg_postinst() {
+ elog "With version 1.0, taskcoach could be stabilized if there is enough user interest."
+ elog "If you run a stable stable system and had to keyword taskcoach, please comment/vote"
+ elog "on http://bugs.gentoo.org/show_bug.cgi?id=311841"
+}