summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Turk <satai@gentoo.org>2003-01-02 05:59:28 +0000
committerMatthew Turk <satai@gentoo.org>2003-01-02 05:59:28 +0000
commita539d2d227d63d1c208a279dfb940047671ba02d (patch)
tree4f3f2fffb6cfe21b21a4435bc14a4e11af11fba1 /app-office/texmacs
parentupdated digests (diff)
downloadgentoo-2-a539d2d227d63d1c208a279dfb940047671ba02d.tar.gz
gentoo-2-a539d2d227d63d1c208a279dfb940047671ba02d.tar.bz2
gentoo-2-a539d2d227d63d1c208a279dfb940047671ba02d.zip
Closes 12312. Version bump, fixed opts.
Diffstat (limited to 'app-office/texmacs')
-rw-r--r--app-office/texmacs/ChangeLog9
-rw-r--r--app-office/texmacs/files/digest-texmacs-1.0.12
-rw-r--r--app-office/texmacs/texmacs-1.0.1.ebuild50
3 files changed, 60 insertions, 1 deletions
diff --git a/app-office/texmacs/ChangeLog b/app-office/texmacs/ChangeLog
index 2161bf456721..baae83af5e6c 100644
--- a/app-office/texmacs/ChangeLog
+++ b/app-office/texmacs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-office/texmacs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/ChangeLog,v 1.5 2002/11/07 07:28:41 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/ChangeLog,v 1.6 2003/01/02 05:59:28 satai Exp $
+
+*texmacs-1.0.1 (02 Jan 2002)
+
+ 02 Jan 2002; Matthew Turk <satai@gentoo.org> texmacs-1.0.1.ebuild :
+
+ Included some opts, manually turned off all inlining. Hopefully this'll work
+ nicely. Also bumped version.
*texmacs-1.0.0.19 (23 Oct 2002)
diff --git a/app-office/texmacs/files/digest-texmacs-1.0.1 b/app-office/texmacs/files/digest-texmacs-1.0.1
new file mode 100644
index 000000000000..ba5365260962
--- /dev/null
+++ b/app-office/texmacs/files/digest-texmacs-1.0.1
@@ -0,0 +1,2 @@
+MD5 5fad9e869c50899ce2723248f9666f63 TeXmacs-1.0.1-src.tar.gz 1642354
+MD5 945dfd3f76b20082aeea8131d87a260f TeXmacs-600dpi-fonts.tar.gz 2899193
diff --git a/app-office/texmacs/texmacs-1.0.1.ebuild b/app-office/texmacs/texmacs-1.0.1.ebuild
new file mode 100644
index 000000000000..41395cbba6be
--- /dev/null
+++ b/app-office/texmacs/texmacs-1.0.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.3 2002/02/04 15:46:51 gbevin Exp
+
+inherit flag-o-matic
+
+MY_P=${P/tex/TeX}-src
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="GNU TeXmacs is a free GUI scientific editor, inspired by TeX and GNU Emacs."
+SRC_URI="ftp://ftp.texmacs.org/pub/TeXmacs/targz/${MY_P}.tar.gz
+ ftp://ftp.texmacs.org/pub/TeXmacs/targz/TeXmacs-600dpi-fonts.tar.gz"
+HOMEPAGE="http://www.texmacs.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND=">=app-text/tetex-1.0.7-r7
+ >=dev-util/guile-1.3.4
+ sys-apps/supersed
+ virtual/x11"
+
+RDEPEND="${DEPEND}
+ app-text/ghostscript"
+
+src_compile() {
+
+ strip-flags
+ append-flags -fno-default-inline
+ append-flags -fno-inline
+
+ econf
+ ssed -i "s:\(^CXXOPTIMIZE = \).*:\1${CXXFLAGS}:" src/common.makefile
+
+ cd ${S}
+ make || die
+}
+
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ cd ${WORKDIR}
+ dodir /usr/share/texmf
+ cp -r fonts ${D}/usr/share/texmf/
+
+ cd ${S}
+ dodoc COMPILE COPYING LICENSE
+}