summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-01 13:09:07 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-01 13:09:07 +0000
commitc537972dd1cb91cd6761f22daddb9c2ae802157b (patch)
tree6867683fd43cccc76f4e6de1aa2fb600abad027d /app-office/texmacs
parentrepoman'd (diff)
downloadgentoo-2-c537972dd1cb91cd6761f22daddb9c2ae802157b.tar.gz
gentoo-2-c537972dd1cb91cd6761f22daddb9c2ae802157b.tar.bz2
gentoo-2-c537972dd1cb91cd6761f22daddb9c2ae802157b.zip
repoman'd
Diffstat (limited to 'app-office/texmacs')
-rw-r--r--app-office/texmacs/texmacs-1.0.0.8.ebuild33
-rw-r--r--app-office/texmacs/texmacs-1.0.ebuild36
2 files changed, 35 insertions, 34 deletions
diff --git a/app-office/texmacs/texmacs-1.0.0.8.ebuild b/app-office/texmacs/texmacs-1.0.0.8.ebuild
index e9f952481c05..bc16122c91af 100644
--- a/app-office/texmacs/texmacs-1.0.0.8.ebuild
+++ b/app-office/texmacs/texmacs-1.0.0.8.ebuild
@@ -7,26 +7,27 @@ DESCRIPTION="GNU TeXmacs is a free GUI scientific editor, inspired by TeX and GN
SRC_URI="ftp://ftp.texmacs.org/pub/TeXmacs/targz/TeXmacs-${PV}-src.tar.gz
ftp://ftp.texmacs.org/pub/TeXmacs/targz/TeXmacs-600dpi-fonts.tar.gz"
HOMEPAGE="http://www.texmacs.org/"
-LICENSE=GPL-2
-COMMONDEPEND=">=app-text/tetex-1.0.7-r7
- >=dev-util/guile-1.3.4
- >=x11-base/xfree-4.2.0-r5"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
-DEPEND="$COMMONDEPEND sys-devel/gcc sys-devel/make"
+DEPEND=">=app-text/tetex-1.0.7-r7
+ >=dev-util/guile-1.3.4
+ >=x11-base/xfree-4.2.0-r5"
-RDEPEND="$COMMONDEPEND app-text/ghostscript"
+RDEPEND="${DEPEND}
+ app-text/ghostscript"
src_install() {
- cd ${S}
- make DESTDIR=${D} install || die
-
- cd ${WORKDIR}
- dodir /usr/share/texmf
- cp -r fonts ${D}/usr/share/texmf/
-
- cd ${S}
- dodoc COMPILE COPYING LICENSE
-
+ cd ${S}
+ make DESTDIR=${D} install || die
+
+ cd ${WORKDIR}
+ dodir /usr/share/texmf
+ cp -r fonts ${D}/usr/share/texmf/
+
+ cd ${S}
+ dodoc COMPILE COPYING LICENSE
}
diff --git a/app-office/texmacs/texmacs-1.0.ebuild b/app-office/texmacs/texmacs-1.0.ebuild
index e9f952481c05..9c2a78b6bb41 100644
--- a/app-office/texmacs/texmacs-1.0.ebuild
+++ b/app-office/texmacs/texmacs-1.0.ebuild
@@ -1,32 +1,32 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.3 2002/02/04 15:46:51 gbevin Exp
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/texmacs-1.0.ebuild,v 1.3 2002/08/01 13:09:07 seemant Exp $
S=${WORKDIR}/TeXmacs-${PV}-src
DESCRIPTION="GNU TeXmacs is a free GUI scientific editor, inspired by TeX and GNU Emacs."
SRC_URI="ftp://ftp.texmacs.org/pub/TeXmacs/targz/TeXmacs-${PV}-src.tar.gz
ftp://ftp.texmacs.org/pub/TeXmacs/targz/TeXmacs-600dpi-fonts.tar.gz"
HOMEPAGE="http://www.texmacs.org/"
-LICENSE=GPL-2
-COMMONDEPEND=">=app-text/tetex-1.0.7-r7
- >=dev-util/guile-1.3.4
- >=x11-base/xfree-4.2.0-r5"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
-DEPEND="$COMMONDEPEND sys-devel/gcc sys-devel/make"
+DEPEND=">=app-text/tetex-1.0.7-r7
+ >=dev-util/guile-1.3.4
+ >=x11-base/xfree-4.2.0-r5"
-RDEPEND="$COMMONDEPEND app-text/ghostscript"
+RDEPEND="${DEPEND}
+ app-text/ghostscript"
src_install() {
-
- cd ${S}
- make DESTDIR=${D} install || die
-
- cd ${WORKDIR}
- dodir /usr/share/texmf
- cp -r fonts ${D}/usr/share/texmf/
-
- cd ${S}
- dodoc COMPILE COPYING LICENSE
-
+ cd ${S}
+ make DESTDIR=${D} install || die
+
+ cd ${WORKDIR}
+ dodir /usr/share/texmf
+ cp -r fonts ${D}/usr/share/texmf/
+
+ cd ${S}
+ dodoc COMPILE COPYING LICENSE
}