summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-03-18 13:10:10 +0000
committerJustin Lecher <jlec@gentoo.org>2013-03-18 13:10:10 +0000
commit52f51001c6c3e9328190ebb0e7a47ef1132c7b87 (patch)
tree1d6ec188e7988761578f1fc78d3ff142aa2ca293 /app-office/texmaker
parentVersion bump. (diff)
downloadgentoo-2-52f51001c6c3e9328190ebb0e7a47ef1132c7b87.tar.gz
gentoo-2-52f51001c6c3e9328190ebb0e7a47ef1132c7b87.tar.bz2
gentoo-2-52f51001c6c3e9328190ebb0e7a47ef1132c7b87.zip
app-office/texmaker: Version Bump
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'app-office/texmaker')
-rw-r--r--app-office/texmaker/ChangeLog8
-rw-r--r--app-office/texmaker/files/texmaker-4.0.1-hunspell.patch180
-rw-r--r--app-office/texmaker/texmaker-4.0.1.ebuild73
3 files changed, 260 insertions, 1 deletions
diff --git a/app-office/texmaker/ChangeLog b/app-office/texmaker/ChangeLog
index 782492981f39..a05e1203c6c7 100644
--- a/app-office/texmaker/ChangeLog
+++ b/app-office/texmaker/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/texmaker
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.125 2013/03/17 12:25:30 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.126 2013/03/18 13:10:10 jlec Exp $
+
+*texmaker-4.0.1 (18 Mar 2013)
+
+ 18 Mar 2013; Justin Lecher <jlec@gentoo.org> +texmaker-4.0.1.ebuild,
+ +files/texmaker-4.0.1-hunspell.patch:
+ Version Bump
17 Mar 2013; Justin Lecher <jlec@gentoo.org> texmaker-4.0.ebuild:
Add subslot operator for app-text/poppler, #462020
diff --git a/app-office/texmaker/files/texmaker-4.0.1-hunspell.patch b/app-office/texmaker/files/texmaker-4.0.1-hunspell.patch
new file mode 100644
index 000000000000..b271ea82d2e9
--- /dev/null
+++ b/app-office/texmaker/files/texmaker-4.0.1-hunspell.patch
@@ -0,0 +1,180 @@
+ configdialog.cpp | 2 +-
+ latexeditor.h | 2 +-
+ latexeditorview.h | 2 +-
+ latexhighlighter.h | 2 +-
+ spellerdialog.h | 2 +-
+ texmaker.cpp | 4 ++--
+ texmaker.h | 2 +-
+ texmaker.pro | 40 +++++-----------------------------------
+ 8 files changed, 13 insertions(+), 43 deletions(-)
+
+diff --git a/configdialog.cpp b/configdialog.cpp
+index 8a73c4d..6b94401 100644
+--- a/configdialog.cpp
++++ b/configdialog.cpp
+@@ -216,7 +216,7 @@ void ConfigDialog::browseAspell()
+ QDir spelldir(QCoreApplication::applicationDirPath());
+ #else
+ #ifdef DEBIAN_SPELLDIR
+-QDir spelldir(PREFIX"/share/myspell/dicts");
++QDir spelldir(PREFIX"/share/myspell");
+ #else
+ QDir spelldir(PREFIX"/share/texmaker");
+ #endif
+diff --git a/latexeditor.h b/latexeditor.h
+index 1ad4195..8f43b61 100644
+--- a/latexeditor.h
++++ b/latexeditor.h
+@@ -33,7 +33,7 @@
+
+ #include "latexhighlighter.h"
+ #include "textblockselection.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+
+ typedef int UserBookmarkList[3];
+
+diff --git a/latexeditorview.h b/latexeditorview.h
+index 603d82e..844386c 100644
+--- a/latexeditorview.h
++++ b/latexeditorview.h
+@@ -23,7 +23,7 @@
+ #include "gotolinewidget.h"
+ #include "replacewidget.h"
+ #include "minisplitter.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+
+ class LatexEditorView : public QWidget {
+ Q_OBJECT
+diff --git a/latexhighlighter.h b/latexhighlighter.h
+index e0b91b1..74ec42a 100644
+--- a/latexhighlighter.h
++++ b/latexhighlighter.h
+@@ -20,7 +20,7 @@
+ #include <QColor>
+ #include <QTextBlockUserData>
+ //#include "latexeditor.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+
+ class QTextDocument;
+ class LatexEditor;
+diff --git a/spellerdialog.h b/spellerdialog.h
+index 83248ae..cd16dad 100644
+--- a/spellerdialog.h
++++ b/spellerdialog.h
+@@ -13,7 +13,7 @@
+
+ #include "ui_spellerdialog.h"
+ #include "latexeditor.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+
+ #include <QTextCursor>
+
+diff --git a/texmaker.cpp b/texmaker.cpp
+index a364143..c4f7d50 100644
+--- a/texmaker.cpp
++++ b/texmaker.cpp
+@@ -4328,7 +4328,7 @@ geometry_options=config->value("Quick/GeometryOptions","left=2cm,right=2cm,top=2
+ QString dicDir=QCoreApplication::applicationDirPath() + "/";
+ #else
+ #ifdef DEBIAN_SPELLDIR
+-QString dicDir=PREFIX"/share/myspell/dicts/";
++QString dicDir=PREFIX"/share/myspell/";
+ #else
+ QString dicDir=PREFIX"/share/texmaker/";
+ #endif
+@@ -10786,4 +10786,4 @@ if (singlemode && currentEditorView())
+ UpdateBibliography();
+ }
+ }
+-}
+\ No newline at end of file
++}
+diff --git a/texmaker.h b/texmaker.h
+index 9680c8f..c8f1f24 100644
+--- a/texmaker.h
++++ b/texmaker.h
+@@ -48,7 +48,7 @@
+ #include "usertagslistwidget.h"
+ #include "xmltagslistwidget.h"
+ #include "logeditor.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+ #include "browser.h"
+ #include "pdfviewerwidget.h"
+ #include "pdfviewer.h"
+diff --git a/texmaker.pro b/texmaker.pro
+index 32c3463..e5db444 100644
+--- a/texmaker.pro
++++ b/texmaker.pro
+@@ -70,25 +70,6 @@ HEADERS += texmaker.h \
+ synctex_parser_utils.h \
+ usertagslistwidget.h \
+ addtagdialog.h \
+- hunspell/affentry.hxx \
+- hunspell/affixmgr.hxx \
+- hunspell/atypes.hxx \
+- hunspell/baseaffix.hxx \
+- hunspell/csutil.hxx \
+- hunspell/dictmgr.hxx \
+- hunspell/hashmgr.hxx \
+- hunspell/htypes.hxx \
+- hunspell/hunspell.hxx \
+- hunspell/hunspell.h \
+- hunspell/langnum.hxx \
+- hunspell/license.hunspell \
+- hunspell/phonet.hxx \
+- hunspell/suggestmgr.hxx \
+- hunspell/license.myspell \
+- hunspell/filemgr.hxx \
+- hunspell/hunzip.hxx \
+- hunspell/replist.hxx \
+- hunspell/w_char.hxx \
+ singleapp/qtlocalpeer.h \
+ singleapp/qtlockedfile.h \
+ singleapp/qtsingleapplication.h \
+@@ -175,18 +156,6 @@ SOURCES += main.cpp \
+ synctex_parser_utils.c \
+ usertagslistwidget.cpp \
+ addtagdialog.cpp \
+- hunspell/affentry.cxx \
+- hunspell/affixmgr.cxx \
+- hunspell/csutil.cxx \
+- hunspell/dictmgr.cxx \
+- hunspell/hashmgr.cxx \
+- hunspell/hunspell.cxx \
+- hunspell/phonet.cxx \
+- hunspell/suggestmgr.cxx \
+- hunspell/utf_info.cxx \
+- hunspell/filemgr.cxx \
+- hunspell/replist.cxx \
+- hunspell/hunzip.cxx \
+ singleapp/qtlocalpeer.cpp \
+ singleapp/qtlockedfile.cpp \
+ singleapp/qtsingleapplication.cpp \
+@@ -283,13 +252,11 @@ isEmpty( ICONDIR ) {
+ }
+ ## QT5
+ #INCLUDEPATH +=$${QTDIR}/include/
+-INCLUDEPATH += /usr/include/poppler/qt4
+-LIBS += -L/usr/lib -lpoppler-qt4
+-LIBS += -L/usr/lib -lz
++LIBS += -lz
+ DEFINES += PREFIX=\\\"$${PREFIX}\\\"
+ target.path = $${PREFIX}/bin
+
+-#DEFINES += DEBIAN_SPELLDIR
++DEFINES += DEBIAN_SPELLDIR
+
+
+ INSTALLS = target
+@@ -720,3 +687,6 @@ INSTALLS += utilities
+ ICON = texmaker.icns
+ QMAKE_INFO_PLIST =Info.plist
+ }
++
++CONFIG += link_pkgconfig
++PKGCONFIG = hunspell poppler-qt4
diff --git a/app-office/texmaker/texmaker-4.0.1.ebuild b/app-office/texmaker/texmaker-4.0.1.ebuild
new file mode 100644
index 000000000000..f5a41bc14c2a
--- /dev/null
+++ b/app-office/texmaker/texmaker-4.0.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/texmaker-4.0.1.ebuild,v 1.1 2013/03/18 13:10:10 jlec Exp $
+
+EAPI=5
+
+inherit qt4-r2 versionator
+
+# The upstream version numbering is bad, so we have to remove a dot in the
+# minor version number
+MAJOR="$(get_major_version)"
+MINOR_1="$(($(get_version_component_range 2)/10))"
+MINOR_2="$(($(get_version_component_range 2)%10))"
+if [ ${MINOR_2} -eq "0" ] ; then
+ MY_P="${PN}-${MAJOR}.${MINOR_1}"
+else
+ MY_P="${PN}-${MAJOR}.${MINOR_1}.${MINOR_2}"
+fi
+
+MY_P="${P}"
+
+DESCRIPTION="A nice LaTeX-IDE"
+HOMEPAGE="http://www.xm1math.net/texmaker/"
+SRC_URI="http://www.xm1math.net/texmaker/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+COMMON_DEPEND="
+ app-text/hunspell
+ app-text/poppler:=[qt4]
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXext
+ dev-qt/qtgui:4
+ dev-qt/qtcore:4
+ dev-qt/qtwebkit:4
+"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ app-text/psutils
+ app-text/ghostscript-gpl
+ media-libs/netpbm"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-hunspell.patch
+ )
+src_configure() {
+ eqmake4 \
+ ${PN}.pro \
+ PREFIX="${EPREFIX}"/usr \
+ DESKTOPDIR=/usr/share/applications \
+ ICONDIR=/usr/share/pixmaps
+}
+
+src_install() {
+ emake INSTALL_ROOT="${ED}" install
+
+ doicon utilities/texmaker*.png utilities/texmaker.svg
+
+ dodoc utilities/AUTHORS utilities/CHANGELOG.txt
+}
+
+pkg_postinst() {
+ elog "A user manual with many screenshots is available at:"
+ elog "${EPREFIX}/usr/share/${PN}/usermanual_en.html"
+}