summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-04 10:35:31 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-04 10:35:31 +0000
commit1d922dc11a15cd7d8197e991e715194c1cf96031 (patch)
treed24bf3b59840ac678d9e85fe3acc30127ac18e17 /app-office
parent*** empty log message *** (diff)
downloadgentoo-2-1d922dc11a15cd7d8197e991e715194c1cf96031.tar.gz
gentoo-2-1d922dc11a15cd7d8197e991e715194c1cf96031.tar.bz2
gentoo-2-1d922dc11a15cd7d8197e991e715194c1cf96031.zip
*** empty log message ***
Diffstat (limited to 'app-office')
-rw-r--r--app-office/abiword/abiword-0.7.14.ebuild46
-rw-r--r--app-office/abiword/files/digest-abiword-0.7.145
-rw-r--r--app-office/dia/dia-0.88.1.ebuild46
-rw-r--r--app-office/dia/files/digest-dia-0.88.11
-rw-r--r--app-office/gnofin/files/digest-gnofin-0.8.41
-rw-r--r--app-office/gnofin/gnofin-0.8.4.ebuild32
-rw-r--r--app-office/gnumeric/files/digest-gnumeric-0.651
-rw-r--r--app-office/gnumeric/gnumeric-0.65.ebuild51
8 files changed, 183 insertions, 0 deletions
diff --git a/app-office/abiword/abiword-0.7.14.ebuild b/app-office/abiword/abiword-0.7.14.ebuild
new file mode 100644
index 000000000000..a343d450ed10
--- /dev/null
+++ b/app-office/abiword/abiword-0.7.14.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-0.7.14.ebuild,v 1.1 2001/06/04 10:34:15 achim Exp $
+
+A="abi-${PV}.tar.gz abidistfiles-${PV}.tar.gz expat-${PV}.tar.gz
+ unixfonts-${PV}.tar.gz wv-${PV}.tar.gz"
+S=${WORKDIR}/abi-${PV}
+DESCRIPTION="Framework for creating database applications"
+SRC_URI="http://www.abisource.com/downloads/Version-${PV}/abi-${PV}.tar.gz
+ http://www.abisource.com/downloads/Version-${PV}/abidistfiles-${PV}.tar.gz
+ http://www.abisource.com/downloads/Version-${PV}/expat-${PV}.tar.gz
+ http://www.abisource.com/downloads/Version-${PV}/expat-${PV}.tar.gz
+ http://www.abisource.com/downloads/Version-${PV}/psiconv-${PV}.tar.gz
+ http://www.abisource.com/downloads/Version-${PV}/unixfonts-${PV}.tar.gz
+ http://www.abisource.com/downloads/Version-${PV}/wv-${PV}.tar.gz"
+
+
+HOMEPAGE="http://www.gnome.org/gnome-office/abiword.shtml/"
+
+DEPEND="virtual/glibc
+ >=sys-devel/gcc-2.95.2
+ =media-libs/freetype-1.3.1-r2
+ >=media-libs/libpng-1.0.7
+ >=x11-libs/gtk+-1.2.8
+ virtual/x11"
+
+
+src_compile() {
+ try make prefix=/opt/gnome/ UNIX_CAN_BUILD_STATIC=0
+}
+
+src_install() {
+ try make prefix=${D}/opt/gnome UNIX_CAN_BUILD_STATIC=0 install
+ cp ${D}/opt/gnome/AbiSuite/bin/AbiWord AbiWord.orig
+ sed -e "s:${D}::" AbiWord.orig > ${D}/opt/gnome/AbiSuite/bin/AbiWord
+ cd ${D}/opt/gnome/bin
+ rm -f abiword
+ rm -f AbiWord
+ ln -s ../AbiSuite/bin/AbiWord AbiWord
+ ln -s ../AbiSuite/bin/AbiWord abiword
+}
+
+
+
+
diff --git a/app-office/abiword/files/digest-abiword-0.7.14 b/app-office/abiword/files/digest-abiword-0.7.14
new file mode 100644
index 000000000000..ba15c3e10fdc
--- /dev/null
+++ b/app-office/abiword/files/digest-abiword-0.7.14
@@ -0,0 +1,5 @@
+MD5 60902c1142c6a2cc136cef2fcc2ff925 abi-0.7.14.tar.gz
+MD5 c6585585cd9b3a4832f97bd71fcb81df abidistfiles-0.7.14.tar.gz
+MD5 1007c612a4a5ff992e7e9a138d1bd8df expat-0.7.14.tar.gz
+MD5 f8644723b7077a95736d6df24598aef4 unixfonts-0.7.14.tar.gz
+MD5 3a4b9b91a6620cbbc788e077b06cfb65 wv-0.7.14.tar.gz
diff --git a/app-office/dia/dia-0.88.1.ebuild b/app-office/dia/dia-0.88.1.ebuild
new file mode 100644
index 000000000000..1b1349b7ae7b
--- /dev/null
+++ b/app-office/dia/dia-0.88.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-office/dia/dia-0.88.1.ebuild,v 1.1 2001/06/04 10:34:15 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Diagram Creation Program"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}"
+HOMEPAGE="http://www.gnome.org/gnome-office/dia.shtml"
+
+DEPEND=">=gnome-base/gnome-print-0.24
+ >=app-arch/rpm-3.0.5
+ bonobo? ( gnome-base/bonobo )
+ python? ( dev-lang/python-2.0 )"
+
+
+src_compile() {
+
+ local myconf
+ if [ "`use bonobo`" ]
+ then
+ myconf="--enable-bonobo"
+ fi
+# if [ "`use python`" ]
+# then
+# myconf="$myconf --with-python"
+# fi
+ try ./configure --host=${CHOST} --prefix=/opt/gnome \
+ --sysconfdir=/etc/opt/gnome \
+ --enable-gnome --enable-gnome-print ${myconf}
+ try make
+
+}
+
+src_install () {
+
+ try make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome install
+ dodoc AUTHORS COPYING ChangeLog README NEWS TODO KNOWN_BUGS
+
+}
+
+
+
+
+
diff --git a/app-office/dia/files/digest-dia-0.88.1 b/app-office/dia/files/digest-dia-0.88.1
new file mode 100644
index 000000000000..77311d467dc7
--- /dev/null
+++ b/app-office/dia/files/digest-dia-0.88.1
@@ -0,0 +1 @@
+MD5 66a8017a9a93efe08c658f0a29838724 dia-0.88.1.tar.gz
diff --git a/app-office/gnofin/files/digest-gnofin-0.8.4 b/app-office/gnofin/files/digest-gnofin-0.8.4
new file mode 100644
index 000000000000..ef296ed7caeb
--- /dev/null
+++ b/app-office/gnofin/files/digest-gnofin-0.8.4
@@ -0,0 +1 @@
+MD5 eb552f99fcf605b699519671ca4102f1 gnofin-0.8.4.tar.gz
diff --git a/app-office/gnofin/gnofin-0.8.4.ebuild b/app-office/gnofin/gnofin-0.8.4.ebuild
new file mode 100644
index 000000000000..bfbc4113e8c0
--- /dev/null
+++ b/app-office/gnofin/gnofin-0.8.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnofin/gnofin-0.8.4.ebuild,v 1.1 2001/06/04 10:34:15 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="a personal finance application for GNOME"
+SRC_URI="ftp://gnofin.sourceforge.net/pub/gnofin/stable/source/${A}
+ http://download.sourceforge.net/gnofin/${A}
+ http://jagger.ME.Berkley.EDU/~dfisher/gnofin/stable/source/${A}"
+
+HOMEPAGE="http://gnofin.sourceforge.net"
+
+DEPEND=">=gnome-base/gnome-libs-1.2.4
+ >=gnome-base/libxml-1.8.10"
+
+src_compile() {
+ try ./configure --host=${CHOST} --prefix=/opt/gnome \
+ try make
+}
+
+src_install() {
+ try make prefix=${D}/opt/gnome install
+ dodoc AUTHORS COPYING* ChangeLog NEWS
+ dodoc README*
+}
+
+
+
+
+
diff --git a/app-office/gnumeric/files/digest-gnumeric-0.65 b/app-office/gnumeric/files/digest-gnumeric-0.65
new file mode 100644
index 000000000000..b079e55622a1
--- /dev/null
+++ b/app-office/gnumeric/files/digest-gnumeric-0.65
@@ -0,0 +1 @@
+MD5 d31a2258b3f8ded219677a54f4fbe23f gnumeric-0.65.tar.gz
diff --git a/app-office/gnumeric/gnumeric-0.65.ebuild b/app-office/gnumeric/gnumeric-0.65.ebuild
new file mode 100644
index 000000000000..9df77e53551d
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-0.65.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-0.65.ebuild,v 1.1 2001/06/04 10:34:15 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="gnumeric"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/gnumeric/"${A}
+HOMEPAGE="http://www.gnome.org/gnome-office/gnumeric.shtml"
+
+DEPEND=">=sys-devel/perl-5
+ >=dev-lang/python-2.0
+ >=gnome-base/gal-0.3.0
+ >=gnome-libs/gb-0.0.17
+ >=gnome-libs/libole2-0.1.7
+ bonobo? ( >=gnome-base/bonobo-0.28
+ >=gnome-libs/libgda-0.2.0 ) "
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp configure configure.orig
+ sed -e 's:"%d,:"%d",:' configure.orig > configure
+}
+
+src_compile() {
+ cd ${S}
+ local myconf
+ if [ "`use bonobo`" ]
+ then
+ myconf="--with-bonobo"
+ fi
+ LDFLAGS="-L/opt/gnome/lib -lunicode" try ./configure --host=${CHOST} --prefix=/opt/gnome \
+ ${myconf} --with-gb
+ cd ${S}
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make prefix=${D}/opt/gnome PREFIX=${D}/usr install
+ dodoc AUTHORS COPYING *ChangeLog HACKING NEWS README TODO
+
+}
+
+
+
+
+
+