summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2006-09-15 18:38:14 +0000
committerCarsten Lohrke <carlo@gentoo.org>2006-09-15 18:38:14 +0000
commit1fbff5d80a92ed3d9cd815a3cedf7c6265770e95 (patch)
tree2d789e8eb63dc674e5060740fe98dbeb7adae8be /app-office
parentVersion bump. (diff)
downloadgentoo-2-1fbff5d80a92ed3d9cd815a3cedf7c6265770e95.tar.gz
gentoo-2-1fbff5d80a92ed3d9cd815a3cedf7c6265770e95.tar.bz2
gentoo-2-1fbff5d80a92ed3d9cd815a3cedf7c6265770e95.zip
Version bump.
(Portage version: 2.1.1)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/koffice-libs/ChangeLog8
-rw-r--r--app-office/koffice-libs/files/digest-koffice-libs-1.6_beta13
-rw-r--r--app-office/koffice-libs/koffice-libs-1.6_beta1.ebuild64
3 files changed, 74 insertions, 1 deletions
diff --git a/app-office/koffice-libs/ChangeLog b/app-office/koffice-libs/ChangeLog
index bef87c19fb25..6dd4654df7af 100644
--- a/app-office/koffice-libs/ChangeLog
+++ b/app-office/koffice-libs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/koffice-libs
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-libs/ChangeLog,v 1.50 2006/09/07 14:07:30 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-libs/ChangeLog,v 1.51 2006/09/15 18:38:14 carlo Exp $
+
+*koffice-libs-1.6_beta1 (15 Sep 2006)
+
+ 15 Sep 2006; Carsten Lohrke <carlo@gentoo.org>
+ +koffice-libs-1.6_beta1.ebuild:
+ Version bump.
07 Sep 2006; Gustavo Zacarias <gustavoz@gentoo.org>
koffice-libs-1.5.1.ebuild:
diff --git a/app-office/koffice-libs/files/digest-koffice-libs-1.6_beta1 b/app-office/koffice-libs/files/digest-koffice-libs-1.6_beta1
new file mode 100644
index 000000000000..a68717744650
--- /dev/null
+++ b/app-office/koffice-libs/files/digest-koffice-libs-1.6_beta1
@@ -0,0 +1,3 @@
+MD5 c7aeaf362210ff2e52d610bdbe2c91fd koffice-1.5.91.tar.bz2 54138646
+RMD160 8b412a4d6199cec32fd4a43660abb1352d675dd4 koffice-1.5.91.tar.bz2 54138646
+SHA256 2e1cbd20c8201a9d2d4c14fa4184b112d90a8f8bb089915f4d748eb9f8cef7aa koffice-1.5.91.tar.bz2 54138646
diff --git a/app-office/koffice-libs/koffice-libs-1.6_beta1.ebuild b/app-office/koffice-libs/koffice-libs-1.6_beta1.ebuild
new file mode 100644
index 000000000000..fc7b5f752485
--- /dev/null
+++ b/app-office/koffice-libs/koffice-libs-1.6_beta1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-libs/koffice-libs-1.6_beta1.ebuild,v 1.1 2006/09/15 18:38:14 carlo Exp $
+
+MAXKOFFICEVER=${PV}
+KMNAME=koffice
+KMMODULE=lib
+inherit kde-meta eutils
+
+DESCRIPTION="Shared KOffice libraries."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-data)
+ virtual/python
+ dev-lang/ruby"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ dev-util/pkgconfig"
+
+KMEXTRA="interfaces/
+ plugins/
+ tools/
+ filters/olefilters/
+ filters/xsltfilter/
+ filters/generic_wrapper/
+ kounavail/
+ doc/api/
+ doc/koffice/
+ doc/thesaurus/"
+
+KMEXTRACTONLY="
+ kchart/kdchart/"
+
+need-kde 3.4
+
+src_unpack() {
+ kde-meta_src_unpack unpack
+
+ # Force the compilation of libkopainter.
+ sed -i 's:$(KOPAINTERDIR):kopainter:' $S/lib/Makefile.am
+
+ kde-meta_src_unpack makefiles
+}
+
+src_compile() {
+ local myconf="--enable-scripting --with-pythonfir=${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages"
+ kde-meta_src_compile
+ if use doc; then
+ make apidox || die
+ fi
+}
+
+src_install() {
+ kde-meta_src_install
+ if use doc; then
+ make DESTDIR=${D} install-apidox || die
+ fi
+}