summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2005-05-31 20:05:06 +0000
committerAndreas Proschofsky <suka@gentoo.org>2005-05-31 20:05:06 +0000
commit2275391cad8fca1ac944577e1abcbf4d1164df54 (patch)
treebe7de4948a0dd5017518f77567d6f82d4a70ffd2 /app-office
parentCompile fix wrt #94660 (diff)
downloadgentoo-2-2275391cad8fca1ac944577e1abcbf4d1164df54.tar.gz
gentoo-2-2275391cad8fca1ac944577e1abcbf4d1164df54.tar.bz2
gentoo-2-2275391cad8fca1ac944577e1abcbf4d1164df54.zip
bug fix for slide naming
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/openoffice-ximian/ChangeLog6
-rw-r--r--app-office/openoffice-ximian/files/1.1.4/sd-slide-naming.diff27
-rw-r--r--app-office/openoffice-ximian/openoffice-ximian-1.3.11.ebuild9
3 files changed, 38 insertions, 4 deletions
diff --git a/app-office/openoffice-ximian/ChangeLog b/app-office/openoffice-ximian/ChangeLog
index 5e19d5036b32..621a557e324f 100644
--- a/app-office/openoffice-ximian/ChangeLog
+++ b/app-office/openoffice-ximian/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/openoffice-ximian
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/ChangeLog,v 1.131 2005/05/19 16:34:01 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/ChangeLog,v 1.132 2005/05/31 20:05:06 suka Exp $
+
+ 31 May 2005; Andreas Proschofsky <suka@gentoo.org>
+ +files/1.1.4/sd-slide-naming.diff, openoffice-ximian-1.3.11.ebuild:
+ Another bug fix for slide naming, in sync with upstream ooo-build 1.3.13
19 May 2005; Andreas Proschofsky <suka@gentoo.org>
+files/1.1.4/fpicker-kde-filter-name.diff,
diff --git a/app-office/openoffice-ximian/files/1.1.4/sd-slide-naming.diff b/app-office/openoffice-ximian/files/1.1.4/sd-slide-naming.diff
new file mode 100644
index 000000000000..faebd995d441
--- /dev/null
+++ b/app-office/openoffice-ximian/files/1.1.4/sd-slide-naming.diff
@@ -0,0 +1,27 @@
+Index: sd/source/core/sdpage.cxx
+===================================================================
+RCS file: /cvs/graphics/sd/source/core/sdpage.cxx,v
+retrieving revision 1.49
+retrieving revision 1.49.110.1
+diff -u -p -u -r1.49 -r1.49.110.1
+--- sd/source/core/sdpage.cxx 17 Feb 2005 09:40:54 -0000 1.49
++++ sd/source/core/sdpage.cxx 24 May 2005 15:55:04 -0000 1.49.110.1
+@@ -3188,7 +3188,17 @@ const String& SdPage::GetName()
+
+ aCreatedPageName = String(SdResId(STR_PAGE));
+ aCreatedPageName += sal_Unicode( ' ' );
+- aCreatedPageName += ((SdDrawDocument*) GetModel())->CreatePageNumValue(nNum);
++ if( GetModel()->GetPageNumType() == SVX_NUMBER_NONE )
++ {
++ // if the document has number none as a formating
++ // for page numbers we still default to arabic numbering
++ // to keep the default page names unique
++ aCreatedPageName += String::CreateFromInt32( (sal_Int32)nNum );
++ }
++ else
++ {
++ aCreatedPageName += ((SdDrawDocument*) GetModel())->CreatePageNumValue(nNum);
++ }
+ }
+ else
+ {
diff --git a/app-office/openoffice-ximian/openoffice-ximian-1.3.11.ebuild b/app-office/openoffice-ximian/openoffice-ximian-1.3.11.ebuild
index 6d4107ada3f8..433c8d8103dc 100644
--- a/app-office/openoffice-ximian/openoffice-ximian-1.3.11.ebuild
+++ b/app-office/openoffice-ximian/openoffice-ximian-1.3.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/openoffice-ximian-1.3.11.ebuild,v 1.2 2005/05/19 16:34:01 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-ximian/openoffice-ximian-1.3.11.ebuild,v 1.3 2005/05/31 20:05:06 suka Exp $
# Notes:
#
@@ -265,14 +265,17 @@ src_unpack() {
#Another java problem
epatch ${FILESDIR}/${OO_VER}/javafix.patch
- # fix for bug #82385
+ #fix for bug #82385
epatch ${FILESDIR}/${OO_VER}/getcompver.awk.patch
- # Workaround for bug #73940, may break debug use flag on ppc
+ #Workaround for bug #73940, may break debug use flag on ppc
if use ppc; then
epatch ${FILESDIR}/${OO_VER}/STLport-vector.patch
fi
+ #Bug fix for slide naming
+ epatch ${FILESDIR}/${OO_VER}/sd-slide-naming.diff
+
#Fix for nptl
if use nptl; then
epatch ${FILESDIR}/${OO_VER}/nptl.patch