summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2014-04-15 14:50:59 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2014-04-15 14:50:59 +0000
commit74754f4b2c7f1f233e6c8bf6c167688b6e58a70d (patch)
tree6b9b8388455f86f96037e41bb1ab23450e909473 /app-office
parentFix php[sqlite] dependency, bug #503906 (diff)
downloadgentoo-2-74754f4b2c7f1f233e6c8bf6c167688b6e58a70d.tar.gz
gentoo-2-74754f4b2c7f1f233e6c8bf6c167688b6e58a70d.tar.bz2
gentoo-2-74754f4b2c7f1f233e6c8bf6c167688b6e58a70d.zip
Reverse the patch, I added the wrong one in previous commit. bug#507720.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/ChangeLog6
-rw-r--r--app-office/libreoffice/files/libreoffice-4.2.3.3-kde4-timer-mutex.patch53
2 files changed, 18 insertions, 41 deletions
diff --git a/app-office/libreoffice/ChangeLog b/app-office/libreoffice/ChangeLog
index f112d99807de..fc79f881da71 100644
--- a/app-office/libreoffice/ChangeLog
+++ b/app-office/libreoffice/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/libreoffice
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.551 2014/04/15 08:41:21 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.552 2014/04/15 14:50:59 scarabeus Exp $
+
+ 15 Apr 2014; Tomáš Chvátal <scarabeus@gentoo.org>
+ files/libreoffice-4.2.3.3-kde4-timer-mutex.patch:
+ Reverse the patch, I added the wrong one in previous commit. bug#507720.
15 Apr 2014; Tomáš Chvátal <scarabeus@gentoo.org>
+files/libreoffice-4.2.3.3-kde4-timer-mutex.patch, libreoffice-4.2.3.3.ebuild:
diff --git a/app-office/libreoffice/files/libreoffice-4.2.3.3-kde4-timer-mutex.patch b/app-office/libreoffice/files/libreoffice-4.2.3.3-kde4-timer-mutex.patch
index c0f35a734059..1b2b0efc7472 100644
--- a/app-office/libreoffice/files/libreoffice-4.2.3.3-kde4-timer-mutex.patch
+++ b/app-office/libreoffice/files/libreoffice-4.2.3.3-kde4-timer-mutex.patch
@@ -1,46 +1,19 @@
-From 7dba6e0a71d090f06a6a1a39e87572674593b48a Mon Sep 17 00:00:00 2001
-From: Jan-Marek Glogowski <glogow@fbihome.de>
-Date: Mon, 10 Mar 2014 14:44:05 +0000
-Subject: fdo#73115: Always run timeouts as events
-
-Right-click popup menus run click events throught the LO main loop.
-In case of KDE4 the LO main loop is run by a timer in the main thread,
-with Qt::DirectConnection execution.
-
-If the timeout actually starts a nested event loop for a new dialog,
-the timer is blocked, the nested mainloop detects it was started
-from the timeout and drops the blocked timout from polling, which
-blocks any further LibreOffice event loop processing.
-
-This changes the timers to Qt::QueuedConnection, so they always
-generate an event and are processed by the Qt event loop.
-
-Change-Id: Ie626b22be3d8f9b8934bcc5e9e0e67a365549cfc
-(cherry picked from commit aeda478a02523cec146f6af69710f0391061db56)
-Reviewed-on: https://gerrit.libreoffice.org/8514
-Reviewed-by: Caolán McNamara <caolanm@redhat.com>
-Tested-by: Caolán McNamara <caolanm@redhat.com>
----
-diff --git a/vcl/unx/kde4/KDEXLib.cxx b/vcl/unx/kde4/KDEXLib.cxx
-index b4be6d6..4a9b70b 100644
---- a/vcl/unx/kde4/KDEXLib.cxx
-+++ b/vcl/unx/kde4/KDEXLib.cxx
-@@ -67,9 +67,13 @@ KDEXLib::KDEXLib() :
+--- a/vcl/unx/kde4/KDEXLib.cxx 2014-04-08 13:46:25.000000000 +0200
++++ b/vcl/unx/kde4/KDEXLib.cxx 2014-04-14 07:17:30.000000000 +0200
+@@ -67,13 +67,9 @@
eventLoopType( LibreOfficeEventLoop ),
m_bYieldFrozen( false )
{
-- // the timers created here means they belong to the main thread
-- connect( &timeoutTimer, SIGNAL( timeout()), this, SLOT( timeoutActivated()));
-- connect( &userEventTimer, SIGNAL( timeout()), this, SLOT( userEventActivated()));
-+ // the timers created here means they belong to the main thread.
-+ // As the timeoutTimer runs the LO event queue, which may block on a dialog,
-+ // the timer has to use a Qt::QueuedConnection, otherwise the nested event
-+ // loop will detect the blocking timer and drop it from the polling
-+ // freezing LO X11 processing.
-+ connect( &timeoutTimer, SIGNAL( timeout()), this, SLOT( timeoutActivated()), Qt::QueuedConnection );
-+ connect( &userEventTimer, SIGNAL( timeout()), this, SLOT( userEventActivated()), Qt::QueuedConnection );
+- // the timers created here means they belong to the main thread.
+- // As the timeoutTimer runs the LO event queue, which may block on a dialog,
+- // the timer has to use a Qt::QueuedConnection, otherwise the nested event
+- // loop will detect the blocking timer and drop it from the polling
+- // freezing LO X11 processing.
+- connect( &timeoutTimer, SIGNAL( timeout()), this, SLOT( timeoutActivated()), Qt::QueuedConnection );
+- connect( &userEventTimer, SIGNAL( timeout()), this, SLOT( userEventActivated()), Qt::QueuedConnection );
++ // the timers created here means they belong to the main thread
++ connect( &timeoutTimer, SIGNAL( timeout()), this, SLOT( timeoutActivated()));
++ connect( &userEventTimer, SIGNAL( timeout()), this, SLOT( userEventActivated()));
// QTimer::start() can be called only in its (here main) thread, so this will
// forward between threads if needed
---
-cgit v0.9.0.2-2-gbebe