summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-09-20 08:19:36 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-09-20 08:19:36 +0000
commit7ebc0d71036c64baa90b964ab92d179823881b9d (patch)
tree3799cd5bfccab564cf03aaf71599a0e29fa512e7 /app-office
parentMatch useflags current options. (diff)
downloadgentoo-2-7ebc0d71036c64baa90b964ab92d179823881b9d.tar.gz
gentoo-2-7ebc0d71036c64baa90b964ab92d179823881b9d.tar.bz2
gentoo-2-7ebc0d71036c64baa90b964ab92d179823881b9d.zip
Update pyuno patch wrt bug#435222.
(Portage version: 2.2.0_alpha129/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/ChangeLog6
-rw-r--r--app-office/libreoffice/files/libreoffice-3.7-system-pyuno.patch44
-rw-r--r--app-office/libreoffice/libreoffice-9999-r2.ebuild4
3 files changed, 51 insertions, 3 deletions
diff --git a/app-office/libreoffice/ChangeLog b/app-office/libreoffice/ChangeLog
index cc572a2c660f..518ccf7374ba 100644
--- a/app-office/libreoffice/ChangeLog
+++ b/app-office/libreoffice/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/libreoffice
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.370 2012/09/20 07:36:56 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.371 2012/09/20 08:19:36 scarabeus Exp $
+
+ 20 Sep 2012; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/libreoffice-3.7-system-pyuno.patch, libreoffice-9999-r2.ebuild:
+ Update pyuno patch wrt bug#435222.
20 Sep 2012; Tomáš Chvátal <scarabeus@gentoo.org> libreoffice-9999-r2.ebuild,
metadata.xml:
diff --git a/app-office/libreoffice/files/libreoffice-3.7-system-pyuno.patch b/app-office/libreoffice/files/libreoffice-3.7-system-pyuno.patch
new file mode 100644
index 000000000000..fe93728c289c
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-3.7-system-pyuno.patch
@@ -0,0 +1,44 @@
+diff --git a/desktop/scripts/soffice.sh b/desktop/scripts/soffice.sh
+index a259bf6..672fa23 100755
+--- a/desktop/scripts/soffice.sh
++++ b/desktop/scripts/soffice.sh
+@@ -129,6 +129,9 @@ if echo "$checks" | grep -q "cc" ; then
+ exit 1;
+ fi
+
++PYTHONPATH=$sd_prog${PYTHONPATH+:$PYTHONPATH}
++export PYTHONPATH
++
+ case "`uname -s`" in
+ NetBSD|OpenBSD|FreeBSD|DragonFly)
+ # this is a temporary hack until we can live with the default search paths
+diff --git a/pyuno/source/module/uno.py b/pyuno/source/module/uno.py
+index 4ff2606..6a05eed 100644
+--- a/pyuno/source/module/uno.py
++++ b/pyuno/source/module/uno.py
+@@ -16,8 +16,12 @@
+ # except in compliance with the License. You may obtain a copy of
+ # the License at http://www.apache.org/licenses/LICENSE-2.0 .
+ #
++import os
+ import sys
+
++sys.path.append('%eprefix%/usr/%libdir%/libreoffice/program')
++if getattr(os.environ, 'URE_BOOTSTRAP', None) is None:
++ os.environ['URE_BOOTSTRAP'] = "vnd.sun.star.pathname:%eprefix%/usr/%libdir%/libreoffice/program/fundamentalrc"
+ import pyuno
+
+ try:
+diff --git a/scripting/source/pyprov/officehelper.py b/scripting/source/pyprov/officehelper.py
+index 99d3b03..704edab 100755
+--- a/scripting/source/pyprov/officehelper.py
++++ b/scripting/source/pyprov/officehelper.py
+@@ -44,7 +44,7 @@ def bootstrap():
+ if "UNO_PATH" in os.environ:
+ sOffice = os.environ["UNO_PATH"]
+ else:
+- sOffice = "" # lets hope for the best
++ sOffice = "%eprefix%/usr/%libdir%/libreoffice/program"
+ sOffice = os.path.join(sOffice, "soffice")
+ if platform.startswith("win"):
+ sOffice += ".exe"
diff --git a/app-office/libreoffice/libreoffice-9999-r2.ebuild b/app-office/libreoffice/libreoffice-9999-r2.ebuild
index 67f55332eafa..f9484ea9a5a7 100644
--- a/app-office/libreoffice/libreoffice-9999-r2.ebuild
+++ b/app-office/libreoffice/libreoffice-9999-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-9999-r2.ebuild,v 1.110 2012/09/20 07:36:56 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-9999-r2.ebuild,v 1.111 2012/09/20 08:19:36 scarabeus Exp $
EAPI=4
@@ -224,7 +224,7 @@ DEPEND="${COMMON_DEPEND}
PATCHES=(
# not upstreamable stuff
- "${FILESDIR}/${PN}-3.6-system-pyuno.patch"
+ "${FILESDIR}/${PN}-3.7-system-pyuno.patch"
)
REQUIRED_USE="