summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPrakash Shetty <crux@gentoo.org>2001-07-04 11:12:48 +0000
committerPrakash Shetty <crux@gentoo.org>2001-07-04 11:12:48 +0000
commit82ec34043ff53849ffb435fdaf0926a50f6c1825 (patch)
tree71a4fde1e018e30df31310c7773bfec8a7b6fa5d /app-office
parentxemacs ebuild made by Joerg Krause <joerg@paula.kantapper.de> (diff)
downloadgentoo-2-82ec34043ff53849ffb435fdaf0926a50f6c1825.tar.gz
gentoo-2-82ec34043ff53849ffb435fdaf0926a50f6c1825.tar.bz2
gentoo-2-82ec34043ff53849ffb435fdaf0926a50f6c1825.zip
Gnumeric ebuild for 0.67 by Joerg Krause <joerg@paula.kantapper.de>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnumeric/files/digest-gnumeric-0.671
-rw-r--r--app-office/gnumeric/gnumeric-0.67.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/app-office/gnumeric/files/digest-gnumeric-0.67 b/app-office/gnumeric/files/digest-gnumeric-0.67
new file mode 100644
index 000000000000..3d42eac4689e
--- /dev/null
+++ b/app-office/gnumeric/files/digest-gnumeric-0.67
@@ -0,0 +1 @@
+MD5 cad1e3adbefe5f2da480c79cb054a8cf gnumeric-0.67.tar.gz
diff --git a/app-office/gnumeric/gnumeric-0.67.ebuild b/app-office/gnumeric/gnumeric-0.67.ebuild
new file mode 100644
index 000000000000..01684a2d9e42
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-0.67.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# /home/cvsroot/gentoo-x86/gnome-office/gnumeric/gnumeric-0.66.ebuild,v 1.1 2001/06/28 09:47:57 hallski Exp
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="gnumeric"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/gnumeric/"${A}
+HOMEPAGE="http://www.gnome.org/gnome-office/gnumeric.shtml"
+
+DEPEND=">=gnome-base/gnome-print-0.29
+ >=gnome-base/gal-0.8.0
+ >=gnome-base/libxml-1.8.14
+ >=gnome-libs/libole2-0.2.3
+ >=dev-util/xml-i18n-tools-0.8.4
+ perl? ( >=sys-devel/perl-5 )
+ python? ( >=dev-lang/python-2.0 )
+ gb? ( >=gnome-libs/gb-0.0.19 )
+ libgda? ( >=gnome-libs/libgda-0.2.9 )
+ nls? ( sys-devel/gettext )
+ bonobo? ( >=gnome-base/bonobo-1.0 )"
+
+RDEPEND=">=gnome-base/gnome-print-0.29
+ >=gnome-base/gal-0.8.0
+ gb? ( >=gnome-libs/gb-0.0.19 )
+ libgda? ( >=gnome-libs/libgda-0.2.9 )
+ bonobo? ( >=gnome-base/bonobo-1.0 ) "
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp configure configure.orig
+ sed -e 's:"%d,:"%d",:' configure.orig > configure
+}
+
+src_compile() {
+ local myconf
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+ if [ -z "`use bonobo`" ] ; then
+ myconf="$myconf --without-bonobo"
+ fi
+ if [ "`use gb`" ]; then
+ #does not work atm
+ myconf="$myconf --without-gb"
+ else
+ myconf="$myconf --without-gb"
+ fi
+ if [ "`use perl`" ]; then
+ myconf="$myconf --with-perl"
+ else
+ myconf="$myconf --without-perl"
+ fi
+ if [ "`use python`" ]; then
+ myconf="$myconf --with-python"
+ else
+ myconf="$myconf --without-python"
+ fi
+ if [ "`use libgda`" ]; then
+ myconf="$myconf --with-gda"
+ else
+ myconf="$myconf --without-gda"
+ fi
+ try ./configure --host=${CHOST} --prefix=/opt/gnome --sysconfdir=/etc/opt/gnome ${myconf}
+ cd ${S}
+ try pmake
+}
+
+src_install() {
+ try make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome PREFIX=${D}/usr install
+ dodoc AUTHORS COPYING *ChangeLog HACKING NEWS README TODO
+
+}
+
+
+
+
+
+