summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2013-11-01 17:04:48 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2013-11-01 17:04:48 +0000
commit90a2a81cb2726749385998d5136c9534c085c83f (patch)
treedf7ac666db2cb6fffdf5b53d5a0953f4a2639280 /app-office
parentgnome-extra/zeitgeist-datasources: Add chromium support back (diff)
downloadgentoo-2-90a2a81cb2726749385998d5136c9534c085c83f.tar.gz
gentoo-2-90a2a81cb2726749385998d5136c9534c085c83f.tar.bz2
gentoo-2-90a2a81cb2726749385998d5136c9534c085c83f.zip
Move build scripts to https://gitorious.org/gentoo-stuff/lo-bin-build
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 84AD142F)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/ChangeLog6
-rw-r--r--app-office/libreoffice/files/generate_libreoffice_package.sh164
2 files changed, 5 insertions, 165 deletions
diff --git a/app-office/libreoffice/ChangeLog b/app-office/libreoffice/ChangeLog
index 5fe62d551945..37eadbf7f5c5 100644
--- a/app-office/libreoffice/ChangeLog
+++ b/app-office/libreoffice/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/libreoffice
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.518 2013/11/01 10:04:06 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.519 2013/11/01 17:04:48 dilfridge Exp $
+
+ 01 Nov 2013; Andreas K. Huettel <dilfridge@gentoo.org>
+ -files/generate_libreoffice_package.sh:
+ Move build scripts to https://gitorious.org/gentoo-stuff/lo-bin-build
01 Nov 2013; Tomáš Chvátal <scarabeus@gentoo.org> libreoffice-9999-r2.ebuild:
One more new dependency.
diff --git a/app-office/libreoffice/files/generate_libreoffice_package.sh b/app-office/libreoffice/files/generate_libreoffice_package.sh
deleted file mode 100644
index bce4fccd78d4..000000000000
--- a/app-office/libreoffice/files/generate_libreoffice_package.sh
+++ /dev/null
@@ -1,164 +0,0 @@
-#!/bin/bash
-
-# important: you need to use the most general CFLAGS to build the packages:
-# * for x86 : CFLAGS="-march=i586 -mtune=generic -O2 -pipe -g"
-# * for amd64: CFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -g"
-
-# What you can set:
-VERSION="4.1.3.2"
-BINVERSION="4.1.3.2"
-OPTS="-v"
-USEFILE="/etc/portage/package.use/libreo"
-MYPKGDIR="$( portageq pkgdir )"
-MYTMPDIR=/root/tmp
-MYDISTDIR=/root/distfiles
-
-################################################
-
-# bug 473974
-export LC_MESSAGES=C
-
-die() {
- echo "${1}"
- exit 1
-}
-
-if [ "$( uname -m )" = "x86_64" ] ; then
- MYFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -g"
- ARCH="amd64"
-elif [ "$( uname -m )" = "i686" ] ; then
- MYFLAGS="-march=i586 -mtune=generic -O2 -pipe -g"
- ARCH="x86"
-else
- die "Arch $( uname -m ) not supported"
-fi
-
-for i in \
- "/bin/echo" \
- "/bin/mkdir" \
- "/bin/mv" \
- "/bin/rm" \
- "/bin/sed" \
- "/bin/tar" \
- "/usr/bin/emerge" \
- "/usr/bin/portageq" \
- "/usr/bin/quickpkg"
-do
- if [ ! -e "${i}" ] ; then
- die "Missing some basic utility in your system"
- fi
-done
-
-# first the default subset of useflags
-IUSES_BASE="bash-completion branding cups dbus gstreamer gtk opengl vba webdav -aqua -binfilter -bluetooth -debug -gtk3 -jemalloc -mysql -odk -postgres -telepathy"
-
-ENABLE_EXTENSIONS="presenter-console presenter-minimizer"
-DISABLE_EXTENSIONS="nlpsolver pdfimport scripting-beanshell scripting-javascript wiki-publisher"
-
-for lo_xt in ${ENABLE_EXTENSIONS}; do
- IUSES_BASE+=" libreoffice_extensions_${lo_xt}"
-done
-for lo_xt in ${DISABLE_EXTENSIONS}; do
- IUSES_BASE+=" -libreoffice_extensions_${lo_xt}"
-done
-unset lo_xt
-
-# now for the options
-IUSES_J="java libreoffice_extensions_nlpsolver"
-IUSES_NJ="-java"
-IUSES_G="gnome eds"
-IUSES_NG="-gnome -eds"
-IUSES_K="kde"
-IUSES_NK="-kde"
-
-if [ -f /etc/portage/package.use ] ; then
- die "Please save your package.use and re-create it as a directory"
-fi
-
-mkdir -p /etc/portage/package.use/ || die
-
-mkdir -p "${MYPKGDIR}"
-if [ -z "${MYPKGDIR}" -o ! -d "${MYPKGDIR}" ] ; then
- die "Anything goes wrong"
-fi
-
-# compile the flavor
-echo "Base"
-echo "app-office/libreoffice ${IUSES_BASE} ${IUSES_NJ} ${IUSES_NG} ${IUSES_NK}" > ${USEFILE}
-FEATURES="${FEATURES} splitdebug" CFLAGS="${MYFLAGS}" CXXFLAGS="${MYFLAGS}" emerge ${OPTS} =libreoffice-${VERSION} || die "emerge failed"
-quickpkg libreoffice --include-config=y
-mv ${MYPKGDIR}/app-office/libreoffice-${VERSION}.tbz2 ${MYTMPDIR}/libreoffice-base-${BINVERSION}.tbz2 || die "Moving package failed"
-
-echo "Base - java"
-echo "app-office/libreoffice ${IUSES_BASE} ${IUSES_J} ${IUSES_NG} ${IUSES_NK}" > ${USEFILE}
-FEATURES="${FEATURES} splitdebug" CFLAGS="${MYFLAGS}" CXXFLAGS="${MYFLAGS}" emerge ${OPTS} =libreoffice-${VERSION} || die "emerge failed"
-quickpkg libreoffice --include-config=y
-mv ${MYPKGDIR}/app-office/libreoffice-${VERSION}.tbz2 ${MYTMPDIR}/libreoffice-base-java-${BINVERSION}.tbz2 || die "Moving package failed"
-
-# kde flavor
-echo "KDE"
-echo "app-office/libreoffice ${IUSES_BASE} ${IUSES_NJ} ${IUSES_NG} ${IUSES_K}" > ${USEFILE}
-FEATURES="${FEATURES} splitdebug" CFLAGS="${MYFLAGS}" CXXFLAGS="${MYFLAGS}" emerge ${OPTS} =libreoffice-${VERSION} || die "emerge failed"
-quickpkg libreoffice --include-config=y
-mv ${MYPKGDIR}/app-office/libreoffice-${VERSION}.tbz2 ${MYTMPDIR}/libreoffice-kde-${BINVERSION}.tbz2 || die "Moving package failed"
-
-echo "KDE - java"
-echo "app-office/libreoffice ${IUSES_BASE} ${IUSES_J} ${IUSES_NG} ${IUSES_K}" > ${USEFILE}
-FEATURES="${FEATURES} splitdebug" CFLAGS="${MYFLAGS}" CXXFLAGS="${MYFLAGS}" emerge ${OPTS} =libreoffice-${VERSION} || die "emerge failed"
-quickpkg libreoffice --include-config=y
-mv ${MYPKGDIR}/app-office/libreoffice-${VERSION}.tbz2 ${MYTMPDIR}/libreoffice-kde-java-${BINVERSION}.tbz2 || die "Moving package failed"
-
-# gnome flavor
-echo "Gnome"
-echo "app-office/libreoffice ${IUSES_BASE} ${IUSES_NJ} ${IUSES_G} ${IUSES_NK}" > ${USEFILE}
-FEATURES="${FEATURES} splitdebug" CFLAGS="${MYFLAGS}" CXXFLAGS="${MYFLAGS}" emerge ${OPTS} =libreoffice-${VERSION} || die "emerge failed"
-quickpkg libreoffice --include-config=y
-mv ${MYPKGDIR}/app-office/libreoffice-${VERSION}.tbz2 ${MYTMPDIR}/libreoffice-gnome-${BINVERSION}.tbz2 || die "Moving package failed"
-
-echo "Gnome -java"
-echo "app-office/libreoffice ${IUSES_BASE} ${IUSES_J} ${IUSES_G} ${IUSES_NK}" > ${USEFILE}
-FEATURES="${FEATURES} splitdebug" CFLAGS="${MYFLAGS}" CXXFLAGS="${MYFLAGS}" emerge ${OPTS} =libreoffice-${VERSION} || die "emerge failed"
-quickpkg libreoffice --include-config=y
-mv ${MYPKGDIR}/app-office/libreoffice-${VERSION}.tbz2 ${MYTMPDIR}/libreoffice-gnome-java-${BINVERSION}.tbz2 || die "Moving package failed"
-
-cd ${MYTMPDIR}
-
-for name in ./libreoffice-*-${BINVERSION}.tbz2 ; do
-
- BN=`basename $name .tbz2`
-
- rm -rf tmp.lo
- mkdir -vp tmp.lo/p1 tmp.lo/p2
- cd tmp.lo/p1
-
- echo "Unpacking complete archive $BN.tbz2"
- tar xfvjp ../../$BN.tbz2
-
- echo "Moving debug info"
- mkdir -vp ../p2/usr/lib
- mv -v usr/lib/debug ../p2/usr/lib/
-
- echo "Re-packing program"
- tar cfvJ ../../$ARCH-bin-$BN.tar.xz --owner root --group root ./*
-
- echo "Re-packing debug info"
- cd ../p2
- tar cfvJ ../../$ARCH-debug-$BN.tar.xz --owner root --group root ./*
-
- echo "Removing unpacked files"
- cd ../..
- rm -rf tmp.lo
-
- echo "Removing original package file"
- rm -f $BN.tbz2
-
- echo "Moving results to distfiles storage"
- mv -v $ARCH-bin-$BN.tar.xz $MYDISTDIR
- mv -v $ARCH-debug-$BN.tar.xz $MYDISTDIR
-
- echo "Done with $BN.tbz2"
-
-done
-
-rm -f ${USEFILE} || die "Removing ${USEFILE} failed"
-