summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-09-17 16:19:06 +0000
committerJustin Lecher <jlec@gentoo.org>2013-09-17 16:19:06 +0000
commitb2ef877ba2bf8b4021095bdc9495911075fbe0e8 (patch)
tree061f25b55d3256c1dab3e6f4a4ff943f0b7824c2 /app-office
parentNew ebuild for dev-java/annogen; a tool which helps you work with JSR175 anno... (diff)
downloadgentoo-2-b2ef877ba2bf8b4021095bdc9495911075fbe0e8.tar.gz
gentoo-2-b2ef877ba2bf8b4021095bdc9495911075fbe0e8.tar.bz2
gentoo-2-b2ef877ba2bf8b4021095bdc9495911075fbe0e8.zip
app-office/texmaker: Version Bump, #483442
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/texmaker/ChangeLog7
-rw-r--r--app-office/texmaker/texmaker-4.0.4.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/app-office/texmaker/ChangeLog b/app-office/texmaker/ChangeLog
index 17316411b73f..1dd9983041e6 100644
--- a/app-office/texmaker/ChangeLog
+++ b/app-office/texmaker/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/texmaker
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.134 2013/07/29 12:54:54 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.135 2013/09/17 16:19:06 jlec Exp $
+
+*texmaker-4.0.4 (17 Sep 2013)
+
+ 17 Sep 2013; Justin Lecher <jlec@gentoo.org> +texmaker-4.0.4.ebuild:
+ Version Bump, #483442
*texmaker-4.0.3 (29 Jul 2013)
diff --git a/app-office/texmaker/texmaker-4.0.4.ebuild b/app-office/texmaker/texmaker-4.0.4.ebuild
new file mode 100644
index 000000000000..15eb6fbbe638
--- /dev/null
+++ b/app-office/texmaker/texmaker-4.0.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/texmaker-4.0.4.ebuild,v 1.1 2013/09/17 16:19:06 jlec Exp $
+
+EAPI=5
+
+inherit qt4-r2 versionator
+
+# The upstream version numbering is bad, so we have to remove a dot in the
+# minor version number
+MAJOR="$(get_major_version)"
+MINOR_1="$(($(get_version_component_range 2)/10))"
+MINOR_2="$(($(get_version_component_range 2)%10))"
+if [ ${MINOR_2} -eq "0" ] ; then
+ MY_P="${PN}-${MAJOR}.${MINOR_1}"
+else
+ MY_P="${PN}-${MAJOR}.${MINOR_1}.${MINOR_2}"
+fi
+
+MY_P="${P}"
+
+DESCRIPTION="A nice LaTeX-IDE"
+HOMEPAGE="http://www.xm1math.net/texmaker/"
+SRC_URI="http://www.xm1math.net/texmaker/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+COMMON_DEPEND="
+ app-text/hunspell
+ app-text/poppler:=[qt4]
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXext
+ dev-qt/qtgui:4
+ dev-qt/qtcore:4
+ dev-qt/qtwebkit:4
+"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ app-text/psutils
+ app-text/ghostscript-gpl
+ media-libs/netpbm"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-4.0.3-hunspell.patch )
+
+DOCS=( utilities/AUTHORS utilities/CHANGELOG.txt )
+HTML_DOCS=( doc/. )
+
+src_configure() {
+ eqmake4 \
+ ${PN}.pro \
+ PREFIX="${EPREFIX}/usr" \
+ DESKTOPDIR="${EPREFIX}/usr/share/applications" \
+ ICONDIR="${EPREFIX}/usr/share/pixmaps"
+}
+
+pkg_postinst() {
+ elog "A user manual with many screenshots is available at:"
+ elog "${EPREFIX}/usr/share/${PN}/usermanual_en.html"
+}