summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-05-26 12:22:54 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-05-26 12:22:54 +0000
commitb778c108eef9dbc903970258585b1525411caf84 (patch)
tree84a066fa0819a74657190a3933d011531420d845 /app-office
parentversion bump (#301458) (diff)
downloadgentoo-2-b778c108eef9dbc903970258585b1525411caf84.tar.gz
gentoo-2-b778c108eef9dbc903970258585b1525411caf84.tar.bz2
gentoo-2-b778c108eef9dbc903970258585b1525411caf84.zip
Respect user flags
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/magicpoint/ChangeLog6
-rw-r--r--app-office/magicpoint/magicpoint-1.13a.ebuild8
2 files changed, 10 insertions, 4 deletions
diff --git a/app-office/magicpoint/ChangeLog b/app-office/magicpoint/ChangeLog
index 1dc22fd6478c..54b88e44d9ed 100644
--- a/app-office/magicpoint/ChangeLog
+++ b/app-office/magicpoint/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/magicpoint
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/magicpoint/ChangeLog,v 1.41 2010/05/26 10:24:27 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/magicpoint/ChangeLog,v 1.42 2010/05/26 12:22:54 xarthisius Exp $
+
+ 26 May 2010; Kacper Kowalik <xarthisius@gentoo.org>
+ magicpoint-1.13a.ebuild:
+ Respect user flags
26 May 2010; Samuli Suominen <ssuominen@gentoo.org>
magicpoint-1.13a.ebuild:
diff --git a/app-office/magicpoint/magicpoint-1.13a.ebuild b/app-office/magicpoint/magicpoint-1.13a.ebuild
index ebc820f18ea9..043657b6214a 100644
--- a/app-office/magicpoint/magicpoint-1.13a.ebuild
+++ b/app-office/magicpoint/magicpoint-1.13a.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/magicpoint/magicpoint-1.13a.ebuild,v 1.3 2010/05/26 10:24:27 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/magicpoint/magicpoint-1.13a.ebuild,v 1.4 2010/05/26 12:22:54 xarthisius Exp $
-inherit autotools elisp-common eutils fixheadtails
+inherit autotools elisp-common eutils fixheadtails toolchain-funcs
DESCRIPTION="An X11 based presentation tool"
SRC_URI="ftp://sh.wide.ad.jp/WIDE/free-ware/mgp/${P}.tar.gz
@@ -69,7 +69,9 @@ src_compile() {
# no parallel build possibly, anywhere
emake -j1 Makefiles || die "emake Makefiles failed"
emake -j1 clean || die "emake clean failed"
- emake -j1 BINDIR=/usr/bin LIBDIR=/etc/X11 || die "emake failed"
+ tc-export CC
+ emake -j1 CC="${CC}" CDEBUGFLAGS="${CFLAGS}" LOCAL_LDFLAGS="${LDFLAGS}" \
+ BINDIR=/usr/bin LIBDIR=/etc/X11 || die "emake failed"
if use emacs; then
cd contrib/
elisp-compile *.el || die "elisp-compile failed"