summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-05-11 12:27:28 +0000
committerJustin Lecher <jlec@gentoo.org>2013-05-11 12:27:28 +0000
commitbae313444889f2948380cfee31d6417326e4ed8c (patch)
treefec0322faff11e3c71fc3142ec4ac4443d7fb00f /app-office
parentVersion bump thanks to Johan Bergström <bugs@bergstroem.nu>. Bug 465602 (diff)
downloadgentoo-2-bae313444889f2948380cfee31d6417326e4ed8c.tar.gz
gentoo-2-bae313444889f2948380cfee31d6417326e4ed8c.tar.bz2
gentoo-2-bae313444889f2948380cfee31d6417326e4ed8c.zip
app-office/texmaker: Version BUmp, #469362
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/texmaker/ChangeLog7
-rw-r--r--app-office/texmaker/texmaker-4.0.2.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/app-office/texmaker/ChangeLog b/app-office/texmaker/ChangeLog
index 336dd602d720..2921ea5f9c81 100644
--- a/app-office/texmaker/ChangeLog
+++ b/app-office/texmaker/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/texmaker
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.132 2013/05/07 17:50:58 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.133 2013/05/11 12:27:28 jlec Exp $
+
+*texmaker-4.0.2 (11 May 2013)
+
+ 11 May 2013; Justin Lecher <jlec@gentoo.org> +texmaker-4.0.2.ebuild:
+ Version BUmp, #469362
07 May 2013; Justin Lecher <jlec@gentoo.org> -texmaker-3.5.2-r1.ebuild,
-texmaker-4.0.ebuild:
diff --git a/app-office/texmaker/texmaker-4.0.2.ebuild b/app-office/texmaker/texmaker-4.0.2.ebuild
new file mode 100644
index 000000000000..87bd4c3d574a
--- /dev/null
+++ b/app-office/texmaker/texmaker-4.0.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/texmaker-4.0.2.ebuild,v 1.1 2013/05/11 12:27:28 jlec Exp $
+
+EAPI=5
+
+inherit qt4-r2 versionator
+
+# The upstream version numbering is bad, so we have to remove a dot in the
+# minor version number
+MAJOR="$(get_major_version)"
+MINOR_1="$(($(get_version_component_range 2)/10))"
+MINOR_2="$(($(get_version_component_range 2)%10))"
+if [ ${MINOR_2} -eq "0" ] ; then
+ MY_P="${PN}-${MAJOR}.${MINOR_1}"
+else
+ MY_P="${PN}-${MAJOR}.${MINOR_1}.${MINOR_2}"
+fi
+
+MY_P="${P}"
+
+DESCRIPTION="A nice LaTeX-IDE"
+HOMEPAGE="http://www.xm1math.net/texmaker/"
+SRC_URI="http://www.xm1math.net/texmaker/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+COMMON_DEPEND="
+ app-text/hunspell
+ app-text/poppler:=[qt4]
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXext
+ dev-qt/qtgui:4
+ dev-qt/qtcore:4
+ dev-qt/qtwebkit:4
+"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ app-text/psutils
+ app-text/ghostscript-gpl
+ media-libs/netpbm"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-4.0.1-hunspell.patch )
+
+DOCS=( utilities/AUTHORS utilities/CHANGELOG.txt thanks.txt )
+
+src_configure() {
+ eqmake4 \
+ ${PN}.pro \
+ PREFIX="${EPREFIX}/usr" \
+ DESKTOPDIR="${EPREFIX}/usr/share/applications" \
+ ICONDIR="${EPREFIX}/usr/share/pixmaps"
+}
+
+pkg_postinst() {
+ elog "A user manual with many screenshots is available at:"
+ elog "${EPREFIX}/usr/share/${PN}/usermanual_en.html"
+}