summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-04 09:26:00 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-04 09:26:00 +0000
commite3a4d9bd248d4279b4af812e916b98d31266cf1c (patch)
treeba5f83669cbf5ae02f414bb9f4f725c39b9bcae3 /app-office
parentupdate to use use flags for arts, gnome, esd (diff)
downloadgentoo-2-e3a4d9bd248d4279b4af812e916b98d31266cf1c.tar.gz
gentoo-2-e3a4d9bd248d4279b4af812e916b98d31266cf1c.tar.bz2
gentoo-2-e3a4d9bd248d4279b4af812e916b98d31266cf1c.zip
Compilable in console now
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnumeric/ChangeLog9
-rw-r--r--app-office/gnumeric/files/digest-gnumeric-1.0.5-r11
-rw-r--r--app-office/gnumeric/gnumeric-1.0.5-r1.ebuild116
3 files changed, 125 insertions, 1 deletions
diff --git a/app-office/gnumeric/ChangeLog b/app-office/gnumeric/ChangeLog
index ff7da26d4817..8350902f3c2c 100644
--- a/app-office/gnumeric/ChangeLog
+++ b/app-office/gnumeric/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-office/gnumeric
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.5 2002/03/17 22:21:43 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/ChangeLog,v 1.6 2002/04/04 09:26:00 seemant Exp $
+
+*gnumeric-1.0.5-r1 (4 Apr 2002)
+
+ 4 Apr 2002; Seemant Kulleen <seemant@gentoo.org> gnumeric-1.0.5-r1.ebuild :
+
+ Added Mandrake's fix to allow gnumeric to be compiled without the DISPLAY
+ being set. Clever -- it uses Xvfb.
*gnumeric-1.0.5 (11 March 2002)
diff --git a/app-office/gnumeric/files/digest-gnumeric-1.0.5-r1 b/app-office/gnumeric/files/digest-gnumeric-1.0.5-r1
new file mode 100644
index 000000000000..ee07515fad93
--- /dev/null
+++ b/app-office/gnumeric/files/digest-gnumeric-1.0.5-r1
@@ -0,0 +1 @@
+MD5 ecce21517b0045e3dd34c2bee70b6577 gnumeric-1.0.5.tar.bz2 10043517
diff --git a/app-office/gnumeric/gnumeric-1.0.5-r1.ebuild b/app-office/gnumeric/gnumeric-1.0.5-r1.ebuild
new file mode 100644
index 000000000000..f00ab425133a
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.0.5-r1.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Martin Schlemmer <azarah@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-1.0.5-r1.ebuild,v 1.1 2002/04/04 09:26:00 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gnumeric, the GNOME Spreadsheet"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/gnumeric/${P}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/gnome-office/gnumeric.shtml"
+
+#Eye Of Gnome (media-gfx/eog) is for image support.
+RDEPEND=">=x11-libs/gtk+-1.2.10-r3
+ >=gnome-base/gnome-libs-1.4.1.2-r1
+ >=gnome-base/oaf-0.6.7
+ >=gnome-base/ORBit-0.5.12-r1
+ >=gnome-base/libglade-0.17
+ >=gnome-base/gnome-print-0.31
+ >=gnome-extra/gal-0.18
+ >=dev-libs/libole2-0.2.4
+ >=media-gfx/eog-0.6
+ =dev-libs/libxml-1.8*
+ =media-libs/freetype-1.3*
+ bonobo? ( >=gnome-base/bonobo-1.0.17 )
+ perl? ( >=sys-devel/perl-5.6 )
+ python? ( >=dev-lang/python-2.0 )
+ gb? ( ~gnome-extra/gb-0.0.17 )
+ libgda? ( >=gnome-extra/libgda-0.2.91 )
+ evo? ( >=net-mail/evolution-0.13 )"
+
+#will only work once everybody has decided that they should support
+#the latest versions of programs, or if we live in a perfect world,
+#and subsequent versions do not break compatibility.
+# guile? ( >=dev-util/guile-1.5 )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext
+ >=dev-util/intltool-0.11 )"
+
+
+src_unpack() {
+ unpack ${A}
+
+ #patch 'gnumeric-doc.make' to look for files in the correct place.
+ cd ${S}/doc
+ patch -p0 <${FILESDIR}/${P}-docbuild.patch || die
+ cd ${S}
+}
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+ if [ "`use gb`" ]; then
+ myconf="${myconf} --with-gb"
+ else
+ myconf="${myconf} --without-gb"
+ fi
+ #broken as we cannot use guile-1.5 (break gnucash)
+ if [ "`use guile`" ]; then
+ myconf="${myconf} --without-guile"
+ else
+ myconf="${myconf} --without-guile"
+ fi
+ if [ "`use perl`" ]; then
+ myconf="${myconf} --with-perl"
+ else
+ myconf="${myconf} --without-perl"
+ fi
+ if [ "`use python`" ]; then
+ myconf="${myconf} --with-python"
+ else
+ myconf="${myconf} --without-python"
+ fi
+ if [ "`use libgda`" ]; then
+ myconf="${myconf} --with-gda"
+ else
+ myconf="${myconf} --without-gda"
+ fi
+ if [ "`use evo`" ]; then
+ myconf="${myconf} --with-evolution"
+ fi
+
+ use bonobo \
+ && myconf="${myconf} --with-bonobo" \
+ || myconf="${myconf} --without-bonobo"
+
+ CFLAGS="$CFLAGS `gdk-pixbuf-config --cflags`"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ ${myconf} || die
+
+ #'gnumeric --dump-func-defs' needs to write to ${HOME}/.gnome/, or
+ #else the build fails.
+ addwrite "${HOME}/.gnome"
+
+ # Mandrake's fix for letting it compile without the DISPLAY being set
+ XDISPLAY=$(i=0;while [ -f /tmp/.X${i}-lock ] ; do i=$((${i}+1));done; echo ${i})
+ /usr/X11R6/bin/Xvfb :${XDISPLAY} >& /dev/null &
+ DISPLAY=:${XDISPLAY} emake || DISPLAY=:${XDISPLAY} make || die
+
+ kill $(cat /tmp/.X${XDISPLAY}-lock)
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ install || die
+
+ dodoc AUTHORS COPYING *ChangeLog HACKING NEWS README TODO
+}
+