summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-08-14 19:44:33 +0000
committerAchim Gottinger <achim@gentoo.org>2000-08-14 19:44:33 +0000
commitfe66d0826c9eb3fbe4d911d40cb3f0aa7bd1f924 (patch)
treefcc72981bc57a6fc45f9f9ab1e489fcb95ff8b60 /app-office
parentdigest fix, sed update (diff)
downloadgentoo-2-fe66d0826c9eb3fbe4d911d40cb3f0aa7bd1f924.tar.gz
gentoo-2-fe66d0826c9eb3fbe4d911d40cb3f0aa7bd1f924.tar.bz2
gentoo-2-fe66d0826c9eb3fbe4d911d40cb3f0aa7bd1f924.zip
*** empty log message ***
Diffstat (limited to 'app-office')
-rw-r--r--app-office/abiword/abiword-0.7.10.ebuild38
-rw-r--r--app-office/gnumeric/gnumeric-0.56.ebuild30
2 files changed, 68 insertions, 0 deletions
diff --git a/app-office/abiword/abiword-0.7.10.ebuild b/app-office/abiword/abiword-0.7.10.ebuild
new file mode 100644
index 000000000000..be6b26c29eec
--- /dev/null
+++ b/app-office/abiword/abiword-0.7.10.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-0.7.10.ebuild,v 1.1 2000/08/14 19:44:33 achim Exp $
+
+P=abiword-0.7.10
+A="abi-0.7.10.tar.gz abidistfiles-0.7.10.tar.gz expat-0.7.10.tar.gz
+ unixfonts-0.7.10.tar.gz wv-0.7.10.tar.gz"
+S=${WORKDIR}/abi-0.7.10
+CATEGORY="gnome-office"
+DESCRIPTION="Framework for creating database applications"
+SRC_URI="http://download.abisource.com/releases/0.7.10/src/lf/abi-0.7.10.tar.gz
+ http://download.abisource.com/releases/0.7.10/src/lf/abidistfiles-0.7.10.tar.gz
+ http://download.abisource.com/releases/0.7.10/src/lf/expat-0.7.10.tar.gz
+ http://download.abisource.com/releases/0.7.10/src/lf/unixfonts-0.7.10.tar.gz
+ http://download.abisource.com/releases/0.7.10/src/lf/wv-0.7.10.tar.gz"
+
+
+HOMEPAGE="http://www.gnome.org/gnome-office/abiword.shtml/"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ cd ${S}
+ make prefix=/opt/gnome/ UNIX_CAN_BUILD_STATIC=0
+}
+
+src_install() {
+ cd ${S}
+ make prefix=${D}/opt/gnome UNIX_CAN_BUILD_STATIC=0 install
+}
+
+
+
+
diff --git a/app-office/gnumeric/gnumeric-0.56.ebuild b/app-office/gnumeric/gnumeric-0.56.ebuild
new file mode 100644
index 000000000000..8b2dd8847d1c
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-0.56.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-0.56.ebuild,v 1.1 2000/08/14 19:44:33 achim Exp $
+
+P=gnumeric-0.56
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+CATEGORY="gnome-office"
+DESCRIPTION="gnumeric"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/gnumeric/"${A}
+HOMEPAGE="http://www.gnome.org/gnome-office/gnumeric.shtml"
+
+src_compile() {
+ cd ${S}
+ ./configure --host=${CHOST} --prefix=/opt/gnome \
+ --with-catgets --without-bonobo
+ make
+}
+
+src_install() {
+ cd ${S}
+ make prefix=${D}/opt/gnome install
+ dodoc AUTHORS COPYING *ChangeLog HACKING NEWS README TODO
+
+}
+
+
+
+