summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2004-06-23 03:52:14 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2004-06-23 03:52:14 +0000
commit3a5d6f40c6d7b223cb19ff483ebe8bb7318fc76a (patch)
treea88c2f2e04e8f5e102e7d24ddc0fe5d60706e767 /app-pda/gnupod/gnupod-0.94.ebuild
parentstable on ppc64, bug #54149 (diff)
downloadgentoo-2-3a5d6f40c6d7b223cb19ff483ebe8bb7318fc76a.tar.gz
gentoo-2-3a5d6f40c6d7b223cb19ff483ebe8bb7318fc76a.tar.bz2
gentoo-2-3a5d6f40c6d7b223cb19ff483ebe8bb7318fc76a.zip
Version bumped. Bugs #46868.
Diffstat (limited to 'app-pda/gnupod/gnupod-0.94.ebuild')
-rw-r--r--app-pda/gnupod/gnupod-0.94.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-pda/gnupod/gnupod-0.94.ebuild b/app-pda/gnupod/gnupod-0.94.ebuild
new file mode 100644
index 000000000000..7acbe9bd5293
--- /dev/null
+++ b/app-pda/gnupod/gnupod-0.94.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/gnupod/gnupod-0.94.ebuild,v 1.1 2004/06/23 03:52:14 matsuu Exp $
+
+inherit perl-module
+
+DESCRIPTION="A collection of Perl-scripts for iPod"
+HOMEPAGE="http://www.gnu.org/software/gnupod/"
+SRC_URI="http://blinkenlights.ch/gnupod-dist/stable/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+
+# perl-5.8.0 contains Getopt-Long and Digest-MD5.
+DEPEND="dev-lang/perl
+ dev-perl/MP3-Info
+ dev-perl/XML-Parser
+ dev-perl/Unicode-String
+ || ( >=dev-lang/perl-5.8.0
+ ( dev-perl/Getopt-Long
+ dev-perl/Digest-MD5
+ )
+ )"
+
+src_compile() {
+ econf || die
+}
+
+src_install() {
+ perlinfo
+ sed -i -e "s:\$INC\[0\]/\$modi:${D}${SITE_ARCH}/\$modi:g" \
+ tools/gnupod_install.pl || die
+
+ dodir /usr/bin
+ dodir ${SITE_ARCH}/GNUpod
+ dodir /usr/share/info
+ einstall || die
+
+ dodoc AUTHORS BUGS CHANGES README* TODO doc/gnutunesdb.example
+ dohtml doc/gnupod.html
+}