summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Jaroszyński <peper@gentoo.org>2008-01-27 17:36:59 +0000
committerPiotr Jaroszyński <peper@gentoo.org>2008-01-27 17:36:59 +0000
commitf4fdcf71c8340055eea69ad33add7d2c394668da (patch)
tree3402a11fa4e29fb9743e2c70341a41092e1a4e67 /app-pda/libsyncml
parentversion bump; update metadata; cleanup (diff)
downloadgentoo-2-f4fdcf71c8340055eea69ad33add7d2c394668da.tar.gz
gentoo-2-f4fdcf71c8340055eea69ad33add7d2c394668da.tar.bz2
gentoo-2-f4fdcf71c8340055eea69ad33add7d2c394668da.zip
Add 0.4.6.
(Portage version: 2.1.4)
Diffstat (limited to 'app-pda/libsyncml')
-rw-r--r--app-pda/libsyncml/ChangeLog10
-rw-r--r--app-pda/libsyncml/files/digest-libsyncml-0.4.63
-rw-r--r--app-pda/libsyncml/libsyncml-0.4.6.ebuild63
3 files changed, 74 insertions, 2 deletions
diff --git a/app-pda/libsyncml/ChangeLog b/app-pda/libsyncml/ChangeLog
index 231686650d0c..8cad03dcc027 100644
--- a/app-pda/libsyncml/ChangeLog
+++ b/app-pda/libsyncml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-pda/libsyncml
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/ChangeLog,v 1.8 2007/12/29 14:40:31 peper Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/ChangeLog,v 1.9 2008/01/27 17:36:58 peper Exp $
+
+*libsyncml-0.4.6 (27 Jan 2008)
+
+ 27 Jan 2008; Piotr Jaroszyński <peper@gentoo.org>
+ +libsyncml-0.4.6.ebuild:
+ Add 0.4.6.
*libsyncml-0.4.5 (29 Dec 2007)
diff --git a/app-pda/libsyncml/files/digest-libsyncml-0.4.6 b/app-pda/libsyncml/files/digest-libsyncml-0.4.6
new file mode 100644
index 000000000000..effd537c6607
--- /dev/null
+++ b/app-pda/libsyncml/files/digest-libsyncml-0.4.6
@@ -0,0 +1,3 @@
+MD5 d524b18c1eafe5805f83e29c01a91b66 libsyncml-0.4.6.tar.bz2 167876
+RMD160 51b04d8a725f28d661ebdb7f5b27d6f3d217f38d libsyncml-0.4.6.tar.bz2 167876
+SHA256 818740eb5df3cf7913ab7e7979874ccf403831744c89efa4ebaf74c7e2c090bc libsyncml-0.4.6.tar.bz2 167876
diff --git a/app-pda/libsyncml/libsyncml-0.4.6.ebuild b/app-pda/libsyncml/libsyncml-0.4.6.ebuild
new file mode 100644
index 000000000000..1ea8161fa13a
--- /dev/null
+++ b/app-pda/libsyncml/libsyncml-0.4.6.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libsyncml/libsyncml-0.4.6.ebuild,v 1.1 2008/01/27 17:36:58 peper Exp $
+
+EAPI="1"
+
+inherit eutils cmake-utils
+
+DESCRIPTION="Implementation of the SyncML protocol"
+HOMEPAGE="http://libsyncml.opensync.org/"
+SRC_URI="http://libsyncml.opensync.org/download/releases/${PV}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE="bluetooth +debug doc http +obex"
+
+RDEPEND=">=dev-libs/glib-2.0
+ >=dev-libs/libwbxml-0.9.2
+ dev-libs/libxml2
+ http? ( >=net-libs/libsoup-2.2.91 )
+ obex? ( >=dev-libs/openobex-1.1 )
+ bluetooth? ( net-wireless/bluez-libs )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+# Some of the tests are broken
+RESTRICT="test"
+
+pkg_setup() {
+ if ! use obex && ! use http; then
+ eerror "${CATEGORY}/${P} without support for obex nor http is unusable."
+ eerror "Please enable \"obex\" or/and \"http\" USE flags."
+ die "Please enable \"obex\" or/and \"http\" USE flags."
+ fi
+
+ if use bluetooth; then
+ if use obex && ! built_with_use dev-libs/openobex bluetooth; then
+ eerror "You are trying to build ${CATEGORY}/${P} with the \"bluetooth\""
+ eerror "and \"obex\" USE flags, but dev-libs/openobex was built without"
+ eerror "the \"bluetooth\" USE flag."
+ eerror "Please rebuild dev-libs/openobex with \"bluetooth\" USE flag."
+ die "Please rebuild dev-libs/openobex with \"bluetooth\" USE flag."
+ elif ! use obex; then
+ eerror "You are trying to build ${CATEGORY}/${P} with the \"bluetooth\""
+ eerror "USE flag, but you didn't enable the \"obex\" flag, which is"
+ eerror "needed for bluetooth support."
+ eerror "Please enable \"obex\" USE flag."
+ die "Please enable \"obex\" USE flag."
+ fi
+ fi
+}
+
+src_compile() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable http HTTP)
+ $(cmake-utils_use_enable obex OBEX)
+ $(cmake-utils_use_enable bluetooth BLUETOOTH)
+ $(cmake-utils_use_enable debug TRACE)"
+
+ cmake-utils_src_compile
+}