summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2005-07-08 10:10:49 +0000
committerAlastair Tse <liquidx@gentoo.org>2005-07-08 10:10:49 +0000
commitbf2caabbb8c84fc09298c6ddf9951b306a57898b (patch)
tree339f4d1adad477e1d093043766e2068dde29f8e7 /app-pda/pilot-link/pilot-link-0.11.8-r1.ebuild
parentStable on ppc64 (diff)
downloadgentoo-2-bf2caabbb8c84fc09298c6ddf9951b306a57898b.tar.gz
gentoo-2-bf2caabbb8c84fc09298c6ddf9951b306a57898b.tar.bz2
gentoo-2-bf2caabbb8c84fc09298c6ddf9951b306a57898b.zip
another attempt at fixing java support for amd64. patches thanks to Philipp Weinfurter (#87774)
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-pda/pilot-link/pilot-link-0.11.8-r1.ebuild')
-rw-r--r--app-pda/pilot-link/pilot-link-0.11.8-r1.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/app-pda/pilot-link/pilot-link-0.11.8-r1.ebuild b/app-pda/pilot-link/pilot-link-0.11.8-r1.ebuild
index 10b67dfdc4dc..5a1dde4969d6 100644
--- a/app-pda/pilot-link/pilot-link-0.11.8-r1.ebuild
+++ b/app-pda/pilot-link/pilot-link-0.11.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.11.8-r1.ebuild,v 1.9 2005/05/20 21:45:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.11.8-r1.ebuild,v 1.10 2005/07/08 10:10:49 liquidx Exp $
inherit perl-module eutils
@@ -26,12 +26,13 @@ src_unpack() {
unpack ${A}
cd "${S}"
+ epatch ${FILESDIR}/${P}-java_fPIC_fix.patch
+
if use java; then
if use ppc; then
epatch ${FILESDIR}/${P}-java_install_ppc.patch
elif use amd64; then
epatch ${FILESDIR}/${P}-java_install_amd64.patch
- epatch ${FILESDIR}/${P}-java_compile_amd64.patch
else
epatch ${FILESDIR}/${P}-java_install_all.patch
fi
@@ -69,8 +70,6 @@ src_compile() {
|| myconf="${myconf} --with-readline=no"
econf ${myconf} || die
- cd ${S}
- epatch ${FILESDIR}/${P}-fPIC.patch
# java fails w/emake
make || die