summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-12-21 19:03:09 +0000
committerChris White <chriswhite@gentoo.org>2005-12-21 19:03:09 +0000
commitf31fbb6f5cbd7f8e85450ff37ca7c0c727b395a1 (patch)
treee334b04e17c16825bc773bf352ced23bf6c3a45d /app-pda/syncekonnector/syncekonnector-0.2.1-r1.ebuild
parentStable on amd64. See bug #108082. (diff)
downloadgentoo-2-f31fbb6f5cbd7f8e85450ff37ca7c0c727b395a1.tar.gz
gentoo-2-f31fbb6f5cbd7f8e85450ff37ca7c0c727b395a1.tar.bz2
gentoo-2-f31fbb6f5cbd7f8e85450ff37ca7c0c727b395a1.zip
Fixes some api compile errors in bug #114311.
(Portage version: 2.0.53)
Diffstat (limited to 'app-pda/syncekonnector/syncekonnector-0.2.1-r1.ebuild')
-rw-r--r--app-pda/syncekonnector/syncekonnector-0.2.1-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-pda/syncekonnector/syncekonnector-0.2.1-r1.ebuild b/app-pda/syncekonnector/syncekonnector-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..145025b1dce3
--- /dev/null
+++ b/app-pda/syncekonnector/syncekonnector-0.2.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/syncekonnector/syncekonnector-0.2.1-r1.ebuild,v 1.1 2005/12/21 19:03:09 chriswhite Exp $
+
+inherit eutils kde autotools
+
+DESCRIPTION="Synchronize Windows CE devices with Linux. KDE Konnector."
+HOMEPAGE="http://synce.sourceforge.net/synce/kde/"
+SRC_URI="mirror://sourceforge/synce/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=app-pda/synce-libsynce-0.9
+ >=app-pda/synce-rra-0.9
+ >=app-pda/orange-0.2
+ >=app-arch/unshield-0.4
+ app-pda/dynamite
+ !app-pda/rapip"
+
+need-kde 3.5
+
+src_unpack() {
+ kde_src_unpack
+ cp "${FILESDIR}/${P}-configure.in.in" "${S}/src/configure.in.in"
+
+ # :/
+ mkdir -p ${S}/src/libkdepim
+ # >:/
+ cp ${FILESDIR}/kpimprefs.h ${S}/src/libkdepim
+ # lalala please fix this upstream~
+ epatch ${FILESDIR}/${P}-kde3.5.patch
+}
+
+src_compile() {
+ make -f Makefile.cvs
+ kde_src_compile
+}