summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Varner <fuzzyray@gentoo.org>2014-03-19 19:41:46 +0000
committerPaul Varner <fuzzyray@gentoo.org>2014-03-19 19:41:46 +0000
commit40ac51f4a51cddcf21c3af43ae80cbac6bbc3299 (patch)
tree30dee40fc55099d6cd7edb3cd322330e6956fed1 /app-portage
parentVersion bump. (diff)
downloadgentoo-2-40ac51f4a51cddcf21c3af43ae80cbac6bbc3299.tar.gz
gentoo-2-40ac51f4a51cddcf21c3af43ae80cbac6bbc3299.tar.bz2
gentoo-2-40ac51f4a51cddcf21c3af43ae80cbac6bbc3299.zip
Version bump for bug fixes and enhancements. See
http://git.overlays.gentoo.org/gitweb/?p=proj/ufed.git;a=summary for full list of changes. (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xDCB4A7FF)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/ufed/ChangeLog11
-rw-r--r--app-portage/ufed/ufed-0.91.ebuild39
2 files changed, 48 insertions, 2 deletions
diff --git a/app-portage/ufed/ChangeLog b/app-portage/ufed/ChangeLog
index fe6bdd656995..c15749a5d8da 100644
--- a/app-portage/ufed/ChangeLog
+++ b/app-portage/ufed/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-portage/ufed
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/ufed/ChangeLog,v 1.100 2013/09/11 17:51:19 fuzzyray Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/ufed/ChangeLog,v 1.101 2014/03/19 19:41:46 fuzzyray Exp $
+
+*ufed-0.91 (19 Mar 2014)
+
+ 19 Mar 2014; Paul Varner <fuzzyray@gentoo.org> +ufed-0.91.ebuild:
+ Version bump for bug fixes and enhancements. See
+ http://git.overlays.gentoo.org/gitweb/?p=proj/ufed.git;a=summary
+ for full list of changes.
*ufed-0.90_rc2-r1 (11 Sep 2013)
diff --git a/app-portage/ufed/ufed-0.91.ebuild b/app-portage/ufed/ufed-0.91.ebuild
new file mode 100644
index 000000000000..cac8bf5315e5
--- /dev/null
+++ b/app-portage/ufed/ufed-0.91.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/ufed/ufed-0.91.ebuild,v 1.1 2014/03/19 19:41:46 fuzzyray Exp $
+
+EAPI=5
+
+inherit base eutils multilib autotools
+
+DESCRIPTION="Gentoo Linux USE flags editor"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~fuzzyray/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+COMMON_DEPEND="sys-libs/ncurses"
+RDEPEND="${COMMON_DEPEND}
+ dev-lang/perl"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+# Populate the patches array for patches applied for -rX releases
+# It is an array of patch file names of the form:
+# "${FILESDIR}"/${P}-make.globals-path.patch
+PATCHES=()
+
+src_prepare() {
+ base_src_prepare
+ # Change the version number to reflect the ebuild version
+ sed -i "s:,\[git\],:,\[${PVR}\],:" configure.ac
+ eautoreconf
+}
+
+src_configure() {
+ econf --libexecdir="${EPREFIX}"/usr/$(get_libdir)/ufed
+}