summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPieter van den Abeele <pvdabeel@gentoo.org>2005-01-02 12:37:40 +0000
committerPieter van den Abeele <pvdabeel@gentoo.org>2005-01-02 12:37:40 +0000
commit54854f8480c1f94f4dccef7737481fc95aa1c81a (patch)
tree31f0182c4ec66ac42a91c3d3220cb6458c7bcae0 /app-portage
parentAdded to ~ppc (Manifest recommit) (diff)
downloadgentoo-2-54854f8480c1f94f4dccef7737481fc95aa1c81a.tar.gz
gentoo-2-54854f8480c1f94f4dccef7737481fc95aa1c81a.tar.bz2
gentoo-2-54854f8480c1f94f4dccef7737481fc95aa1c81a.zip
New version - compatible with new baselayout /etc/conf.d/hostname
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/basc/Manifest4
-rw-r--r--app-portage/basc/basc-1.5.3.ebuild90
-rw-r--r--app-portage/basc/files/digest-basc-1.5.31
3 files changed, 94 insertions, 1 deletions
diff --git a/app-portage/basc/Manifest b/app-portage/basc/Manifest
index 811320fe402d..ddb0bf049f92 100644
--- a/app-portage/basc/Manifest
+++ b/app-portage/basc/Manifest
@@ -1,4 +1,6 @@
MD5 b9a117c039c5714611b7e4f34e7e34d0 ChangeLog 1895
-MD5 3c8e1225812577632847153488b201d7 basc-1.5.2.ebuild 2269
MD5 36441a3af28aa17a592a5c409239a278 metadata.xml 616
+MD5 3c8e1225812577632847153488b201d7 basc-1.5.2.ebuild 2269
+MD5 f465517fdcabdfbef02358ffecb94b42 basc-1.5.3.ebuild 2278
+MD5 74753ac6d1c6ab7f0dbf6c43d17045b4 files/digest-basc-1.5.3 61
MD5 fad108ecff3fcfbf2987a555420c92cc files/digest-basc-1.5.2 61
diff --git a/app-portage/basc/basc-1.5.3.ebuild b/app-portage/basc/basc-1.5.3.ebuild
new file mode 100644
index 000000000000..297f12bf5558
--- /dev/null
+++ b/app-portage/basc/basc-1.5.3.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/basc/basc-1.5.3.ebuild,v 1.1 2005/01/02 12:37:40 pvdabeel Exp $
+
+# ebuild contributed by Alexander Mieland and Daniel Herzog
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Buildtime And Statistics Client for http://www.gentoo-stats.org"
+HOMEPAGE="http://www.gentoo-stats.org"
+SRC_URI="http://www.gentoo-stats.org/download/${P}.tar.gz"
+
+KEYWORDS="x86 sparc mips ~hppa ppc amd64 ~ppc64"
+SLOT="0"
+LICENSE="GPL-2"
+
+IUSE=""
+
+RDEPEND="app-portage/gentoolkit
+ dev-lang/perl
+ dev-perl/DateManip
+ net-misc/wget
+ sys-devel/gcc
+ sys-apps/sed
+ sys-apps/grep
+ app-arch/gzip
+ sys-apps/diffutils
+ >=sys-apps/uhinv-0.4"
+
+pkg_setup() {
+ enewgroup stats
+ enewuser stats -1 /bin/false /tmp stats
+}
+
+src_compile() {
+ sed -i "s:/usr/local:/usr:g" client/basc client/hgenlop
+ useq x86 && $(tc-getCC) ${CFLAGS} -o client/smt-detect client/smt-detect.c >/dev/null 2>&1
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe client/basc client/hgenlop client/urandom.sh
+
+ useq x86 && doexe client/smt-detect
+
+ dodoc README ChangeLog TEAM
+ dodir /etc/basc
+ touch ${D}/etc/basc/basc.conf
+
+ fowners root:stats /etc/basc
+ fperms ug+w /etc/basc
+
+ fowners root:stats /etc/basc/basc.conf
+ fperms ug+w /etc/basc/basc.conf
+}
+
+pkg_postinst() {
+ local GU=`/usr/bin/hgenlop -nt gcc`
+ echo "GU=\"${GU}\"" >> /etc/basc/basc.conf
+
+ draw_line
+ einfo
+ einfo "The Gentoo Buildtime and Statistics client can be started by"
+ einfo "typing:"
+ einfo ""
+ einfo " \"basc\""
+ einfo ""
+ einfo "Note:"
+ einfo ""
+ einfo "You have to be in the stats group to use the client!"
+ einfo "A user can be added to the stats group by executing:"
+ einfo ""
+ einfo " \"usermod -G \$(groups <ME> | sed -e 's/ /,/g'),stats <ME>\""
+ einfo ""
+ einfo "Replace <ME> with your username on the system."
+ einfo "After a login, you are ready to use the client."
+ einfo ""
+ einfo "If you want to automatically launch the client every 24h,"
+ einfo "you must set up a cronjob for the stats user or a user in"
+ einfo "the stats group."
+ einfo ""
+ einfo "For example:"
+ einfo ""
+ einfo " \"0 0 * * * /usr/bin/basc -q -y >/dev/null 2>&1\""
+ einfo ""
+ einfo "will start the client every day at 00:00am"
+ einfo
+ draw_line
+ ebeep
+}
diff --git a/app-portage/basc/files/digest-basc-1.5.3 b/app-portage/basc/files/digest-basc-1.5.3
new file mode 100644
index 000000000000..2b8f40a0563c
--- /dev/null
+++ b/app-portage/basc/files/digest-basc-1.5.3
@@ -0,0 +1 @@
+MD5 d841ed3c30e4527f3c5549d11ea764da basc-1.5.3.tar.gz 17439