summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2012-10-09 20:36:06 +0000
committerIan Stakenvicius <axs@gentoo.org>2012-10-09 20:36:06 +0000
commit894faeb16ed49090e949e275a07682f930060e06 (patch)
tree9b6f199bfb82141354f9549358014a2f39ae9592 /app-portage
parentReflect the app-emulation/qemu-kvm -> app-emulation/qemu move (diff)
downloadgentoo-2-894faeb16ed49090e949e275a07682f930060e06.tar.gz
gentoo-2-894faeb16ed49090e949e275a07682f930060e06.tar.bz2
gentoo-2-894faeb16ed49090e949e275a07682f930060e06.zip
version bump
(Portage version: 2.1.11.25/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/ChangeLog7
-rw-r--r--app-portage/eix/eix-0.27.2.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/app-portage/eix/ChangeLog b/app-portage/eix/ChangeLog
index 1fa978e57b8a..bb2d29e80498 100644
--- a/app-portage/eix/ChangeLog
+++ b/app-portage/eix/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-portage/eix
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.432 2012/09/19 19:43:19 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.433 2012/10/09 20:36:06 axs Exp $
+
+*eix-0.27.2 (09 Oct 2012)
+
+ 09 Oct 2012; Ian Stakenvicius <axs@gentoo.org> +eix-0.27.2.ebuild:
+ version bump
19 Sep 2012; Jeremy Olexa <darkside@gentoo.org> metadata.xml:
update metadata
diff --git a/app-portage/eix/eix-0.27.2.ebuild b/app-portage/eix/eix-0.27.2.ebuild
new file mode 100644
index 000000000000..c1c59eb07b40
--- /dev/null
+++ b/app-portage/eix/eix-0.27.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/eix-0.27.2.ebuild,v 1.1 2012/10/09 20:36:06 axs Exp $
+
+EAPI=5
+
+PLOCALES="de ru"
+inherit bash-completion-r1 eutils multilib l10n
+
+DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
+HOMEPAGE="http://eix.berlios.de"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE="clang debug +dep doc nls optimization security strong-optimization sqlite tools zsh-completion"
+
+RDEPEND="app-shells/push
+ sqlite? ( >=dev-db/sqlite-3 )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ clang? ( sys-devel/clang )
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ if has_version "<${CATEGORY}/${PN}-0.25.3"; then
+ local eixcache="${EROOT}"/var/cache/${PN}
+ [[ -f ${eixcache} ]] && rm -f "${eixcache}"
+ fi
+}
+
+src_prepare() {
+ epatch_user
+}
+
+src_configure() {
+ econf $(use_with sqlite) $(use_with doc extra-doc) \
+ $(use_with zsh-completion) \
+ $(use_enable nls) $(use_enable tools separate-tools) \
+ $(use_enable security) $(use_enable optimization) \
+ $(use_enable strong-optimization) $(use_enable debug debugging) \
+ $(use_with prefix always-accept-keywords) \
+ $(use_with dep dep-default) \
+ $(use_with clang nongnu-cxx clang++) \
+ --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
+ --with-portage-rootpath="${ROOTPATH}" \
+ --with-eprefix-default="${EPREFIX}" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+}
+
+src_install() {
+ default
+ dobashcomp bash/eix
+ keepdir "/var/cache/${PN}"
+ fowners portage:portage "/var/cache/${PN}"
+ fperms 775 "/var/cache/${PN}"
+}
+
+pkg_postinst() {
+ # fowners in src_install doesn't work for owner/group portage:
+ # merging changes this owner/group back to root.
+ use prefix || chown portage:portage "${EROOT}var/cache/${PN}"
+ local obs="${EROOT}var/cache/eix.previous"
+ ! test -f "${obs}" || ewarn "Found obsolete ${obs}, please remove it"
+}