summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2007-01-31 20:48:49 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2007-01-31 20:48:49 +0000
commitcb42dba7b1778bbfc24f010186877ed3047f7a3a (patch)
treeea453b3a12170af3da844bb6c3c71dacc532441c /app-portage
parentStable on ppc wrt bug #161193. (diff)
downloadgentoo-2-cb42dba7b1778bbfc24f010186877ed3047f7a3a.tar.gz
gentoo-2-cb42dba7b1778bbfc24f010186877ed3047f7a3a.tar.bz2
gentoo-2-cb42dba7b1778bbfc24f010186877ed3047f7a3a.zip
patch to fix compiling with gcc 4.x
(Portage version: 2.1.2-r5)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/herdstat/ChangeLog6
-rw-r--r--app-portage/herdstat/files/herdstat-1.1.91-undefined-lhp.patch22
-rw-r--r--app-portage/herdstat/herdstat-1.1.91.ebuild9
3 files changed, 35 insertions, 2 deletions
diff --git a/app-portage/herdstat/ChangeLog b/app-portage/herdstat/ChangeLog
index a1c7123b6ca8..37b07b3eb2f8 100644
--- a/app-portage/herdstat/ChangeLog
+++ b/app-portage/herdstat/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-portage/herdstat
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/herdstat/ChangeLog,v 1.71 2007/01/24 03:42:33 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/herdstat/ChangeLog,v 1.72 2007/01/31 20:48:49 compnerd Exp $
+
+ 31 Jan 2007; Saleem Abdulrasool <compnerd@gentoo.org>
+ +files/herdstat-1.1.91-undefined-lhp.patch, herdstat-1.1.91.ebuild:
+ Patch to fix compiling with gcc 4.x
24 Jan 2007; Marius Mauch <genone@gentoo.org> herdstat-1.1.1_p7.ebuild,
herdstat-1.1.2.ebuild, herdstat-1.1.91.ebuild:
diff --git a/app-portage/herdstat/files/herdstat-1.1.91-undefined-lhp.patch b/app-portage/herdstat/files/herdstat-1.1.91-undefined-lhp.patch
new file mode 100644
index 000000000000..c77a05751ad8
--- /dev/null
+++ b/app-portage/herdstat/files/herdstat-1.1.91-undefined-lhp.patch
@@ -0,0 +1,22 @@
+--- src/io/handler.hh 2007-01-31 01:55:13.000000000 -0600
++++ src/io/handler.hh 2007-01-31 01:53:51.000000000 -0600
+@@ -34,6 +34,8 @@
+ #include "handler_map.hh"
+ #include "action/handler.hh"
+
++extern HandlerMap<ActionHandler> *lhp;
++
+ /**
+ * @class IOHandler
+ * @brief Input/Output handler base class. All front-ends ultimately derive
+--- src/io/handler.cc 2007-01-31 01:55:00.000000000 -0600
++++ src/io/handler.cc 2007-01-31 01:51:09.000000000 -0600
+@@ -36,7 +36,7 @@
+
+ using namespace herdstat;
+
+-extern HandlerMap<ActionHandler> *lhp;
++HandlerMap<ActionHandler> *lhp;
+
+ IOHandler::IOHandler()
+ : _local()
diff --git a/app-portage/herdstat/herdstat-1.1.91.ebuild b/app-portage/herdstat/herdstat-1.1.91.ebuild
index 2f4fb3c40e97..a8613e9471d3 100644
--- a/app-portage/herdstat/herdstat-1.1.91.ebuild
+++ b/app-portage/herdstat/herdstat-1.1.91.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/herdstat/herdstat-1.1.91.ebuild,v 1.2 2007/01/24 03:42:33 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/herdstat/herdstat-1.1.91.ebuild,v 1.3 2007/01/31 20:48:49 compnerd Exp $
inherit bash-completion eutils
@@ -30,6 +30,13 @@ pkg_setup() {
fi
}
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${PN}-1.1.91-undefined-lhp.patch
+}
+
src_compile() {
econf \
--with-test-data=${WORKDIR}/${TEST_DATA_P} \