summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2011-01-31 20:08:53 +0000
committerJeremy Olexa <darkside@gentoo.org>2011-01-31 20:08:53 +0000
commite38a4937457bc6b20536ffbb1d267d103c7e639e (patch)
treeb72ba0f3ed34fe07a251fa19044df44e0c34bcb9 /app-portage
parentVersion bump. (diff)
downloadgentoo-2-e38a4937457bc6b20536ffbb1d267d103c7e639e.tar.gz
gentoo-2-e38a4937457bc6b20536ffbb1d267d103c7e639e.tar.bz2
gentoo-2-e38a4937457bc6b20536ffbb1d267d103c7e639e.zip
Version bump from upstream, fixed gentoo bug 350321 and other small fixes
(Portage version: 2.1.9.35/cvs/Linux i686)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/ChangeLog7
-rw-r--r--app-portage/eix/eix-0.22.7.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/app-portage/eix/ChangeLog b/app-portage/eix/ChangeLog
index 594b041de078..f462c3831b37 100644
--- a/app-portage/eix/ChangeLog
+++ b/app-portage/eix/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-portage/eix
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.360 2011/01/08 01:30:41 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/ChangeLog,v 1.361 2011/01/31 20:08:53 darkside Exp $
+
+*eix-0.22.7 (31 Jan 2011)
+
+ 31 Jan 2011; Jeremy Olexa <darkside@gentoo.org> +eix-0.22.7.ebuild:
+ Version bump from upstream, fixed gentoo bug 350321 and other small fixes
08 Jan 2011; Brent Baude <ranger@gentoo.org> eix-0.22.5.ebuild:
stable ppc, bug 347305
diff --git a/app-portage/eix/eix-0.22.7.ebuild b/app-portage/eix/eix-0.22.7.ebuild
new file mode 100644
index 000000000000..10bee94962a7
--- /dev/null
+++ b/app-portage/eix/eix-0.22.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/eix/eix-0.22.7.ebuild,v 1.1 2011/01/31 20:08:53 darkside Exp $
+
+EAPI="4"
+
+inherit multilib
+
+DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
+HOMEPAGE="http://eix.berlios.de"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE="bzip2 debug doc hardened nls optimization strong-optimization sqlite tools zsh-completion"
+
+RDEPEND="sqlite? ( >=dev-db/sqlite-3 )
+ nls? ( virtual/libintl )
+ bzip2? ( app-arch/bzip2 )
+ zsh-completion? ( !!<app-shells/zsh-completion-20091203-r1 )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ doc? ( dev-python/docutils )
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ econf $(use_with bzip2) $(use_with sqlite) $(use_with doc rst) \
+ $(use_with zsh-completion) \
+ $(use_enable nls) $(use_enable tools separate-tools) \
+ $(use_enable hardened security) $(use_enable optimization) \
+ $(use_enable strong-optimization) $(use_enable debug debugging) \
+ --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
+ --with-portage-rootpath="${ROOTPATH}" \
+ --with-eprefix-default="${EPREFIX}" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+}
+
+src_install() {
+ default_src_install
+ use doc && cd -- "${ED}" && docompress -x "usr/share/doc/${PF}/"*.html
+}