summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPieter van den Abeele <pvdabeel@gentoo.org>2004-12-31 12:35:05 +0000
committerPieter van den Abeele <pvdabeel@gentoo.org>2004-12-31 12:35:05 +0000
commitf025b515c5c3598e604869c4cf84f4cf7d2da13e (patch)
tree5aaf5460ec5d51e41fb813685912c703b0479cf6 /app-portage
parentMarked ~ppc, previous bug that forced -ppc is fixed. (Manifest recommit) (diff)
downloadgentoo-2-f025b515c5c3598e604869c4cf84f4cf7d2da13e.tar.gz
gentoo-2-f025b515c5c3598e604869c4cf84f4cf7d2da13e.tar.bz2
gentoo-2-f025b515c5c3598e604869c4cf84f4cf7d2da13e.zip
Adding new version #76123
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/basc/ChangeLog9
-rw-r--r--app-portage/basc/Manifest8
-rw-r--r--app-portage/basc/basc-1.5.2.ebuild89
-rw-r--r--app-portage/basc/files/digest-basc-1.5.21
4 files changed, 102 insertions, 5 deletions
diff --git a/app-portage/basc/ChangeLog b/app-portage/basc/ChangeLog
index 9f3af7caf98c..3db3aa540a46 100644
--- a/app-portage/basc/ChangeLog
+++ b/app-portage/basc/ChangeLog
@@ -1,8 +1,13 @@
# ChangeLog for app-portage/basc
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/basc/ChangeLog,v 1.8 2004/12/31 00:31:43 dsd Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/basc/ChangeLog,v 1.9 2004/12/31 12:35:05 pvdabeel Exp $
-*basc-1.5.1 (31 Dec 2004)
+* basc-1.5.2 (31 Dec 2004)
+
+ 31 Dec 2004; Pieter Van den Abeele <pvdabeel@gentoo.org> + basc-1.5.2.ebuild:
+ Security audited version. Security bug 76123 for details
+
+* basc-1.5.1 (31 Dec 2004)
31 Dec 2004; Daniel Drake <dsd@gentoo.org> +basc-1.5.1.ebuild:
New version, which checks for user confirmation (the first time) before
diff --git a/app-portage/basc/Manifest b/app-portage/basc/Manifest
index a1490a428292..316cd76901d6 100644
--- a/app-portage/basc/Manifest
+++ b/app-portage/basc/Manifest
@@ -1,6 +1,8 @@
-MD5 a858bbadf27bac2b9015ab26778bf5ae basc-1.5.1.ebuild 2204
-MD5 692f212cf12e9ddc6372a88ee46867bc basc-1.5.0.ebuild 1871
MD5 e1681785a50d2301de8dc4fffd4708e1 ChangeLog 1301
+MD5 a858bbadf27bac2b9015ab26778bf5ae basc-1.5.1.ebuild 2204
MD5 36441a3af28aa17a592a5c409239a278 metadata.xml 616
-MD5 2c675d7d3e70daedb76091e742fed699 files/digest-basc-1.5.0 61
+MD5 c524214ced18703e365b80b1d30b1d31 basc-1.5.2.ebuild 2240
+MD5 692f212cf12e9ddc6372a88ee46867bc basc-1.5.0.ebuild 1871
MD5 2f9f89ec54c46c4bfed7a3febf59d0b1 files/digest-basc-1.5.1 61
+MD5 fad108ecff3fcfbf2987a555420c92cc files/digest-basc-1.5.2 61
+MD5 2c675d7d3e70daedb76091e742fed699 files/digest-basc-1.5.0 61
diff --git a/app-portage/basc/basc-1.5.2.ebuild b/app-portage/basc/basc-1.5.2.ebuild
new file mode 100644
index 000000000000..2810d3c77079
--- /dev/null
+++ b/app-portage/basc/basc-1.5.2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/basc/basc-1.5.2.ebuild,v 1.1 2004/12/31 12:35:05 pvdabeel Exp $
+
+# ebuild contributed by Alexander Mieland and Daniel Herzog
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Buildtime And Statistics Client for http://www.gentoo-stats.org"
+HOMEPAGE="http://www.gentoo-stats.org"
+SRC_URI="http://www.gentoo-stats.org/download/${P}.tar.gz"
+
+KEYWORDS="x86 ~sparc ~mips ~hppa ppc ~amd64"
+SLOT="0"
+LICENSE="GPL-2"
+
+IUSE=""
+
+RDEPEND="app-portage/gentoolkit
+ dev-lang/perl
+ dev-perl/DateManip
+ net-misc/wget
+ sys-devel/gcc
+ sys-apps/sed
+ sys-apps/grep
+ app-arch/gzip
+ >=sys-apps/uhinv-0.4"
+
+pkg_setup() {
+ enewgroup stats
+ enewuser stats -1 /bin/false /tmp stats
+}
+
+src_compile() {
+ sed -i "s:/usr/local:/usr:g" client/basc client/hgenlop
+ useq x86 && $(tc-getCC) ${CFLAGS} -o client/smt-detect client/smt-detect.c >/dev/null 2>&1
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe client/basc client/hgenlop client/urandom.sh
+
+ useq x86 && doexe client/smt-detect
+
+ dodoc README ChangeLog TEAM
+ dodir /etc/basc
+ touch ${D}/etc/basc/basc.conf
+
+ fowners root:stats /etc/basc
+ fperms ug+w /etc/basc
+
+ fowners root:stats /etc/basc/basc.conf
+ fperms ug+w /etc/basc/basc.conf
+}
+
+pkg_postinst() {
+ local GU=`/usr/bin/hgenlop -nt gcc`
+ echo "GU=\"${GU}\"" >> /etc/basc/basc.conf
+
+ draw_line
+ einfo
+ einfo "The Gentoo Buildtime and Statistics client can be started by"
+ einfo "typing:"
+ einfo ""
+ einfo " \"basc -u\"."
+ einfo ""
+ einfo "Note:"
+ einfo ""
+ einfo "You have to be in the stats group to use the client!"
+ einfo "A user can be added to the stats group by executing:"
+ einfo ""
+ einfo " \"usermod -G \$(groups <ME> | sed -e 's/ /,/g'),stats <ME>\""
+ einfo ""
+ einfo "Replace <ME> with your username on the system."
+ einfo "After a login, the client is useable."
+ einfo ""
+ einfo "If you want to automatically launch the client every 24h,"
+ einfo "you must set up a cronjob for the stats user or a user in"
+ einfo "the stats group."
+ einfo ""
+ einfo "For example:"
+ einfo ""
+ einfo " \"0 0 * * * /usr/bin/basc -q >/dev/null 2>&1\""
+ einfo ""
+ einfo "will start the client every day at 00:00am"
+ einfo
+ draw_line
+ ebeep
+}
diff --git a/app-portage/basc/files/digest-basc-1.5.2 b/app-portage/basc/files/digest-basc-1.5.2
new file mode 100644
index 000000000000..713c2de8b5ae
--- /dev/null
+++ b/app-portage/basc/files/digest-basc-1.5.2
@@ -0,0 +1 @@
+MD5 312dd3af4dde225eeb621d5a32be7b73 basc-1.5.2.tar.gz 16810