summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2014-07-14 11:46:01 +0000
committerTony Vroon <chainsaw@gentoo.org>2014-07-14 11:46:01 +0000
commitf9f4ffb94cf7c87501a79d782b04391f0b4405e4 (patch)
tree9952fd9b10874ef1c8fbbdbd7667fae1efe489ed /app-portage
parentVersion bump, drop old (diff)
downloadgentoo-2-f9f4ffb94cf7c87501a79d782b04391f0b4405e4.tar.gz
gentoo-2-f9f4ffb94cf7c87501a79d782b04391f0b4405e4.tar.bz2
gentoo-2-f9f4ffb94cf7c87501a79d782b04391f0b4405e4.zip
Release incorporating fixes from bugs #420617, #424657 & #484108. With both my thanks and my apologies to Sergiy Borodych, Roberto Araneda & Petr Pisar.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB5058F9A)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/g-cpan/ChangeLog10
-rw-r--r--app-portage/g-cpan/g-cpan-0.16.5.ebuild39
2 files changed, 47 insertions, 2 deletions
diff --git a/app-portage/g-cpan/ChangeLog b/app-portage/g-cpan/ChangeLog
index 5a08eec3da5d..e1efbafdf354 100644
--- a/app-portage/g-cpan/ChangeLog
+++ b/app-portage/g-cpan/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/g-cpan
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/g-cpan/ChangeLog,v 1.77 2013/07/30 23:39:43 zlogene Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/g-cpan/ChangeLog,v 1.78 2014/07/14 11:46:01 chainsaw Exp $
+
+*g-cpan-0.16.5 (14 Jul 2014)
+
+ 14 Jul 2014; Tony Vroon <chainsaw@gentoo.org> +g-cpan-0.16.5.ebuild:
+ Release incorporating fixes from bugs #420617, #424657 & #484108. With both
+ my thanks and my apologies to Sergiy Borodych, Roberto Araneda & Petr Pisar.
30 Jul 2013; Mikle Kolyada <zlogene@gentoo.org> -g-cpan-0.13.02.ebuild,
-g-cpan-0.14.0.ebuild, -g-cpan-0.15.0-r1.ebuild, -g-cpan-0.16.2.ebuild,
diff --git a/app-portage/g-cpan/g-cpan-0.16.5.ebuild b/app-portage/g-cpan/g-cpan-0.16.5.ebuild
new file mode 100644
index 000000000000..198952ffcf3b
--- /dev/null
+++ b/app-portage/g-cpan/g-cpan-0.16.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/g-cpan/g-cpan-0.16.5.ebuild,v 1.1 2014/07/14 11:46:01 chainsaw Exp $
+
+EAPI=5
+
+inherit perl-module
+
+DESCRIPTION="g-cpan: generate and install CPAN modules using portage"
+HOMEPAGE="http://www.gentoo.org/proj/en/perl/g-cpan.xml"
+SRC_URI="mirror://gentoo/${P}.tar.gz
+ http://dev.gentoo.org/~chainsaw/distfiles/${P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ >=dev-perl/yaml-0.60
+ dev-perl/Shell-EnvImporter
+ dev-perl/Log-Agent"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ perl-module_src_install
+ diropts "-m0755"
+ dodir "/var/tmp/g-cpan"
+ keepdir "/var/tmp/g-cpan"
+ dodir "/var/log/g-cpan"
+ keepdir "/var/log/g-cpan"
+}
+
+pkg_postinst() {
+ elog "You may wish to adjust the permissions on /var/tmp/g-cpan"
+ elog "if you have users besides root expecting to use g-cpan."
+ elog "Please note that some CPAN packages need additional manual"
+ elog "parameters or tweaking, due to bugs in their build systems."
+}