summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimone Gotti <motaboy@gentoo.org>2004-10-27 21:13:43 +0000
committerSimone Gotti <motaboy@gentoo.org>2004-10-27 21:13:43 +0000
commit560a55f8716a39f8e5182a434cce28e7a2f5b591 (patch)
tree34812e269dacce74de3037935b30b2c84dfa130c /app-sci/fung-calc
parentadded ~ppc-macos. closes bug 67560 (Manifest recommit) (diff)
downloadgentoo-2-560a55f8716a39f8e5182a434cce28e7a2f5b591.tar.gz
gentoo-2-560a55f8716a39f8e5182a434cce28e7a2f5b591.tar.bz2
gentoo-2-560a55f8716a39f8e5182a434cce28e7a2f5b591.zip
Changed the ebuild to use the 'kde' eclass; Added a patch to the configure script to honor the 'arts' use flag, this fixes bug #69092.
Diffstat (limited to 'app-sci/fung-calc')
-rw-r--r--app-sci/fung-calc/ChangeLog7
-rw-r--r--app-sci/fung-calc/files/fung-calc-1.3.2b-configure.patch141
-rw-r--r--app-sci/fung-calc/fung-calc-1.3.2b.ebuild29
3 files changed, 163 insertions, 14 deletions
diff --git a/app-sci/fung-calc/ChangeLog b/app-sci/fung-calc/ChangeLog
index 07bb94cd9fbf..c9ce05eea6f5 100644
--- a/app-sci/fung-calc/ChangeLog
+++ b/app-sci/fung-calc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-sci/fung-calc
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/fung-calc/ChangeLog,v 1.9 2004/09/22 10:31:47 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/fung-calc/ChangeLog,v 1.10 2004/10/27 21:13:43 motaboy Exp $
+
+ 27 Oct 2004; Simone Gotti <motaboy@gentoo.org>
+ +files/fung-calc-1.3.2b-configure.patch, fung-calc-1.3.2b.ebuild:
+ Changed the ebuild to use the 'kde' eclass; Added a patch to the configure
+ script to honor the 'arts' use flag, this fixes bug #69092.
22 Sep 2004; Patrick Kursawe <phosphan@gentoo.org> fung-calc-1.3.2b.ebuild:
Applying fPIC patch always - makes testing easier, helps prelinking and
diff --git a/app-sci/fung-calc/files/fung-calc-1.3.2b-configure.patch b/app-sci/fung-calc/files/fung-calc-1.3.2b-configure.patch
new file mode 100644
index 000000000000..ebb514f26753
--- /dev/null
+++ b/app-sci/fung-calc/files/fung-calc-1.3.2b-configure.patch
@@ -0,0 +1,141 @@
+--- configure.orig 2004-10-27 10:24:21.005162544 +0200
++++ configure 2004-10-27 10:24:58.224504344 +0200
+@@ -23722,138 +23722,6 @@
+ fi
+
+
+- echo "$as_me:$LINENO: checking for mcopidl" >&5
+-echo $ECHO_N "checking for mcopidl... $ECHO_C" >&6
+- if test -n "$MCOPIDL"; then
+- kde_cv_path="$MCOPIDL";
+- else
+- kde_cache=`echo mcopidl | sed 'y%./+-%__p_%'`
+-
+- if eval "test \"\${kde_cv_path_$kde_cache+set}\" = set"; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+-
+- kde_cv_path="NONE"
+- dirs="$kde_default_bindirs"
+- kde_save_IFS=$IFS
+- IFS=':'
+- for dir in $PATH; do
+- dirs="$dirs $dir"
+- done
+- IFS=$kde_save_IFS
+-
+- for dir in $dirs; do
+- if test -x "$dir/mcopidl"; then
+- if test -n ""
+- then
+- evalstr="$dir/mcopidl 2>&1 "
+- if eval $evalstr; then
+- kde_cv_path="$dir/mcopidl"
+- break
+- fi
+- else
+- kde_cv_path="$dir/mcopidl"
+- break
+- fi
+- fi
+- done
+-
+- eval "kde_cv_path_$kde_cache=$kde_cv_path"
+-
+-
+-fi
+-
+-
+- eval "kde_cv_path=\"`echo '$kde_cv_path_'$kde_cache`\""
+-
+- fi
+-
+- if test -z "$kde_cv_path" || test "$kde_cv_path" = NONE; then
+- echo "$as_me:$LINENO: result: not found" >&5
+-echo "${ECHO_T}not found" >&6
+-
+- { { echo "$as_me:$LINENO: error: The important program mcopidl was not found!
+-Please check whether you installed aRts correctly.
+-" >&5
+-echo "$as_me: error: The important program mcopidl was not found!
+-Please check whether you installed aRts correctly.
+-" >&2;}
+- { (exit 1); exit 1; }; }
+-
+- else
+- echo "$as_me:$LINENO: result: $kde_cv_path" >&5
+-echo "${ECHO_T}$kde_cv_path" >&6
+- MCOPIDL=$kde_cv_path
+-
+- fi
+-
+-
+- echo "$as_me:$LINENO: checking for artsc-config" >&5
+-echo $ECHO_N "checking for artsc-config... $ECHO_C" >&6
+- if test -n "$ARTSCCONFIG"; then
+- kde_cv_path="$ARTSCCONFIG";
+- else
+- kde_cache=`echo artsc-config | sed 'y%./+-%__p_%'`
+-
+- if eval "test \"\${kde_cv_path_$kde_cache+set}\" = set"; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+-
+- kde_cv_path="NONE"
+- dirs="$kde_default_bindirs"
+- kde_save_IFS=$IFS
+- IFS=':'
+- for dir in $PATH; do
+- dirs="$dirs $dir"
+- done
+- IFS=$kde_save_IFS
+-
+- for dir in $dirs; do
+- if test -x "$dir/artsc-config"; then
+- if test -n ""
+- then
+- evalstr="$dir/artsc-config 2>&1 "
+- if eval $evalstr; then
+- kde_cv_path="$dir/artsc-config"
+- break
+- fi
+- else
+- kde_cv_path="$dir/artsc-config"
+- break
+- fi
+- fi
+- done
+-
+- eval "kde_cv_path_$kde_cache=$kde_cv_path"
+-
+-
+-fi
+-
+-
+- eval "kde_cv_path=\"`echo '$kde_cv_path_'$kde_cache`\""
+-
+- fi
+-
+- if test -z "$kde_cv_path" || test "$kde_cv_path" = NONE; then
+- echo "$as_me:$LINENO: result: not found" >&5
+-echo "${ECHO_T}not found" >&6
+-
+- { { echo "$as_me:$LINENO: error: The important program artsc-config was not found!
+-Please check whether you installed aRts correctly.
+-" >&5
+-echo "$as_me: error: The important program artsc-config was not found!
+-Please check whether you installed aRts correctly.
+-" >&2;}
+- { (exit 1); exit 1; }; }
+-
+- else
+- echo "$as_me:$LINENO: result: $kde_cv_path" >&5
+-echo "${ECHO_T}$kde_cv_path" >&6
+- ARTSCCONFIG=$kde_cv_path
+-
+- fi
+-
+-
+ echo "$as_me:$LINENO: checking for kde-config" >&5
+ echo $ECHO_N "checking for kde-config... $ECHO_C" >&6
+ if test -n "$KDECONFIG"; then
diff --git a/app-sci/fung-calc/fung-calc-1.3.2b.ebuild b/app-sci/fung-calc/fung-calc-1.3.2b.ebuild
index 7e248336bed8..aaf9644da907 100644
--- a/app-sci/fung-calc/fung-calc-1.3.2b.ebuild
+++ b/app-sci/fung-calc/fung-calc-1.3.2b.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/fung-calc/fung-calc-1.3.2b.ebuild,v 1.8 2004/09/22 10:31:47 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/fung-calc/fung-calc-1.3.2b.ebuild,v 1.9 2004/10/27 21:13:43 motaboy Exp $
+
+inherit kde eutils flag-o-matic
IUSE="opengl"
@@ -14,25 +16,26 @@ KEYWORDS="~x86 ~ppc ~amd64"
DEPEND=">=sys-libs/zlib-1
>=media-libs/libpng-1.2
>=media-libs/jpeg-6
- >=kde-base/kdelibs-3.1
- >=x11-libs/qt-3.1
virtual/libc
opengl? ( virtual/opengl )
>=kde-base/kdebase-3.1"
-inherit eutils flag-o-matic
+need-kde 3.1
+need-qt 3.1
+
+src_unpack() {
+ kde_src_unpack
+
+ epatch ${FILESDIR}/fung-calc-fPIC
+ epatch ${FILESDIR}/fung-calc-gcc34-fix
+ useq arts || epatch ${FILESDIR}/fung-calc-1.3.2b-configure.patch
+}
src_compile() {
- addwrite ${QTDIR}/etc/settings
- local myconf
+ kde_src_compile myconf
+
use opengl || myconf="${myconf} --disable-glgraph"
- epatch ${FILESDIR}/fung-calc-fPIC
# use kde || myconf="${myconf} --disable-kde-app"
- econf ${myconf} || die "configure failed"
- epatch ${FILESDIR}/fung-calc-gcc34-fix || die
- emake || die "make failed"
-}
-src_install() {
- einstall || die "install failed"
+ kde_src_compile configure make
}