summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-09-16 22:07:50 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-09-16 22:07:50 +0000
commit5bf59ac87adeb9d575b737ac973cc4a16c3df1ca (patch)
tree67f8ef11c4c70b45077447e9783a67c6ac432981 /app-sci/octave/octave-2.1.36-r1.ebuild
parentversion bump (diff)
downloadgentoo-2-5bf59ac87adeb9d575b737ac973cc4a16c3df1ca.tar.gz
gentoo-2-5bf59ac87adeb9d575b737ac973cc4a16c3df1ca.tar.bz2
gentoo-2-5bf59ac87adeb9d575b737ac973cc4a16c3df1ca.zip
filter -ffast-math
Diffstat (limited to 'app-sci/octave/octave-2.1.36-r1.ebuild')
-rw-r--r--app-sci/octave/octave-2.1.36-r1.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/app-sci/octave/octave-2.1.36-r1.ebuild b/app-sci/octave/octave-2.1.36-r1.ebuild
index 6a3fc611991f..a36e4fed584e 100644
--- a/app-sci/octave/octave-2.1.36-r1.ebuild
+++ b/app-sci/octave/octave-2.1.36-r1.ebuild
@@ -1,15 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/octave-2.1.36-r1.ebuild,v 1.7 2003/02/13 09:24:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/octave-2.1.36-r1.ebuild,v 1.8 2003/09/16 22:07:49 seemant Exp $
+
+inherit flag-o-matic eutils
+
+IUSE="tetex"
DESCRIPTION="GNU Octave is a high-level language (MatLab compatible) intended for numerical computations"
-SRC_URI="ftp://ftp.octave.org/pub/octave/bleeding-edge/${P}.tar.bz2"
HOMEPAGE="http://www.octave.org/"
+SRC_URI="ftp://ftp.octave.org/pub/octave/bleeding-edge/${P}.tar.bz2"
+SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc"
-SLOT="0"
-IUSE="tetex"
DEPEND="virtual/glibc
>=sys-libs/ncurses-5.2-r3
@@ -27,11 +30,14 @@ PROVIDE="dev-lang/octave"
src_unpack() {
unpack ${A}
cd ${WORKDIR}
- patch -p0 < ${FILESDIR}/filebuf.diff
+ epatch ${FILESDIR}/filebuf.diff
}
src_compile() {
+
+ filter-flags -ffast-math
+
# NOTE: This version actually works with gcc-3.x
./configure --prefix=/usr \
--sysconfdir=/etc \