summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2004-09-07 09:18:33 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2004-09-07 09:18:33 +0000
commit385971bbd6aaa7c4cd29c52e3b90c82f5a93561c (patch)
tree2cc7692f93cc0e46ec61eee23201f5d6d42fe62d /app-sci/orsa
parentStable on x86 and ppc. (Manifest recommit) (diff)
downloadgentoo-2-385971bbd6aaa7c4cd29c52e3b90c82f5a93561c.tar.gz
gentoo-2-385971bbd6aaa7c4cd29c52e3b90c82f5a93561c.tar.bz2
gentoo-2-385971bbd6aaa7c4cd29c52e3b90c82f5a93561c.zip
Version bump
Diffstat (limited to 'app-sci/orsa')
-rw-r--r--app-sci/orsa/ChangeLog7
-rw-r--r--app-sci/orsa/Manifest6
-rw-r--r--app-sci/orsa/files/digest-orsa-0.6.11
-rw-r--r--app-sci/orsa/orsa-0.6.1.ebuild65
4 files changed, 76 insertions, 3 deletions
diff --git a/app-sci/orsa/ChangeLog b/app-sci/orsa/ChangeLog
index adae029aa880..c2a309d97c89 100644
--- a/app-sci/orsa/ChangeLog
+++ b/app-sci/orsa/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-sci/orsa
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-sci/orsa/ChangeLog,v 1.10 2004/07/01 19:38:48 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/orsa/ChangeLog,v 1.11 2004/09/07 09:15:55 phosphan Exp $
+
+*orsa-0.6.1 (07 Sep 2004)
+
+ 07 Sep 2004; Patrick Kursawe <phosphan@gentoo.org> +orsa-0.6.1.ebuild:
+ Version bump
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org> orsa-0.3.1.ebuild,
orsa-0.5.0_rc2.ebuild:
diff --git a/app-sci/orsa/Manifest b/app-sci/orsa/Manifest
index 7ed171281cd8..3d1213872eba 100644
--- a/app-sci/orsa/Manifest
+++ b/app-sci/orsa/Manifest
@@ -1,6 +1,8 @@
+MD5 f0c3e5f22dcfd392f8391f93ed085a46 orsa-0.5.0_rc2.ebuild 1573
+MD5 7eac7205398c9f2e956ed0924614ea15 orsa-0.6.1.ebuild 1573
+MD5 608ae9359810212cf155cb88b042700f orsa-0.3.1.ebuild 750
MD5 a1b59af283fe608ddcb7f11673e2a9a9 ChangeLog 1720
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
-MD5 608ae9359810212cf155cb88b042700f orsa-0.3.1.ebuild 750
-MD5 f0c3e5f22dcfd392f8391f93ed085a46 orsa-0.5.0_rc2.ebuild 1573
MD5 38ab5f417512fb8637bffdfb874be99c files/digest-orsa-0.3.1 62
+MD5 e07b8e8024922c45167669a6089cb7a6 files/digest-orsa-0.6.1 62
MD5 d07e1ada42ab073d4c6af277c950d8d5 files/digest-orsa-0.5.0_rc2 66
diff --git a/app-sci/orsa/files/digest-orsa-0.6.1 b/app-sci/orsa/files/digest-orsa-0.6.1
new file mode 100644
index 000000000000..b7bf044a14a9
--- /dev/null
+++ b/app-sci/orsa/files/digest-orsa-0.6.1
@@ -0,0 +1 @@
+MD5 82d3919b04a076072f510b6122c06fca orsa-0.6.1.tar.gz 763872
diff --git a/app-sci/orsa/orsa-0.6.1.ebuild b/app-sci/orsa/orsa-0.6.1.ebuild
new file mode 100644
index 000000000000..353c6ab0f63c
--- /dev/null
+++ b/app-sci/orsa/orsa-0.6.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/orsa/orsa-0.6.1.ebuild,v 1.1 2004/09/07 09:15:55 phosphan Exp $
+
+inherit base flag-o-matic
+
+DESCRIPTION="Orbit Reconstruction, Simulation and Analysis"
+HOMEPAGE="http://orsa.sourceforge.net/"
+SRC_URI="mirror://sourceforge/orsa/${P/_/-}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="opengl mpi fftw ginac cln gsl qt"
+
+S="${WORKDIR}/${P/_/-}"
+
+DEPEND="virtual/libc
+ fftw? ( =dev-libs/fftw-2.1* )
+ >=dev-libs/gsl-1.3
+ qt? ( >=x11-libs/qt-3.3 )
+ >=sys-libs/readline-4.2
+ mpi? ( sys-cluster/lam-mpi )
+ ginac? ( >=app-sci/ginac-1.2.0 )
+ gsl? ( dev-libs/gsl )
+ cln? ( >=dev-libs/cln-1.1.6 )"
+
+replace-flags k6-3 i586
+replace-flags k6-2 i586
+replace-flags k6 i586
+
+src_compile() {
+ if ! use mpi; then
+ export MPICXX="g++"
+ fi
+ local myconf
+ if ! use ginac; then
+ myconf="--with-ginac-prefix=/no/such/file"
+ fi
+ if ! use gsl; then
+ myconf="${myconf} --with-gsl-prefix=/no/such/file"
+ fi
+ if ! use cln; then
+ myconf="${myconf} --with-cln-prefix=/no/such/file"
+ fi
+ if ! use fftw; then
+ sed -e 's/have_fftw=yes/have_fftw=no/' -i configure
+ fi
+ if ! use qt; then
+ myconf="${myconf} --with-qt-dir=/no/such/file"
+ fi
+ econf ${myconf} $(use_with opengl gl) || die "configure failed"
+ if use mpi; then
+ sed -e 's/\(orsa_LDADD = .*\)/\1 -llammpi++ -lmpi -llam -lpthread/' \
+ -i src/orsa/Makefile
+ fi
+
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README THANKS
+ dodoc src/test/*
+}