summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-27 08:24:24 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-27 08:24:24 +0000
commita1322487570c90a5c707f9ae7d50bc2baaa2b38a (patch)
treee49a1ac339e370f6ff3afd3cf02c02f053eb43e2 /app-sci/rasmol/rasmol-2.7.2.1.1.ebuild
parentdont access $CC (diff)
downloadgentoo-2-a1322487570c90a5c707f9ae7d50bc2baaa2b38a.tar.gz
gentoo-2-a1322487570c90a5c707f9ae7d50bc2baaa2b38a.tar.bz2
gentoo-2-a1322487570c90a5c707f9ae7d50bc2baaa2b38a.zip
dont access $CC
Diffstat (limited to 'app-sci/rasmol/rasmol-2.7.2.1.1.ebuild')
-rw-r--r--app-sci/rasmol/rasmol-2.7.2.1.1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/app-sci/rasmol/rasmol-2.7.2.1.1.ebuild b/app-sci/rasmol/rasmol-2.7.2.1.1.ebuild
index 67f89a4dc2ad..310f24b51a0e 100644
--- a/app-sci/rasmol/rasmol-2.7.2.1.1.ebuild
+++ b/app-sci/rasmol/rasmol-2.7.2.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/rasmol/rasmol-2.7.2.1.1.ebuild,v 1.3 2004/04/27 08:23:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/rasmol/rasmol-2.7.2.1.1.ebuild,v 1.4 2004/04/27 08:24:24 vapier Exp $
inherit gcc
@@ -31,17 +31,17 @@ src_unpack() {
src_compile() {
cd src
xmkmf || die "xmkmf failed"
- make DEPTHDEF=-DEIGHTBIT CC=${CC} \
+ make DEPTHDEF=-DEIGHTBIT CC="$(gcc-getCC)" \
CDEBUGFLAGS="${CFLAGS}" \
|| die "8-bit make failed"
mv rasmol rasmol.8
make clean
- make DEPTHDEF=-DSIXTEENBIT CC=${CC} \
+ make DEPTHDEF=-DSIXTEENBIT CC="$(gcc-getCC)" \
CDEBUGFLAGS="${CFLAGS}" \
|| die "16-bit make failed"
mv rasmol rasmol.16
make clean
- make DEPTHDEF=-DTHIRTYTWOBIT CC=${CC} \
+ make DEPTHDEF=-DTHIRTYTWOBIT CC="$(gcc-getCC)" \
CDEBUGFLAGS="${CFLAGS}" \
|| die "32-bit make failed"
mv rasmol rasmol.32