summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-05-07 01:57:35 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-05-07 01:57:35 +0000
commitd517eba7a9d8e497fe68d95c7bf4724375042e0f (patch)
tree6dd188c7bb4de2054397db168157c886309da0ff /app-sci/scigraphica
parentmoved gperiodic from app-misc to app-sci (diff)
downloadgentoo-2-d517eba7a9d8e497fe68d95c7bf4724375042e0f.tar.gz
gentoo-2-d517eba7a9d8e497fe68d95c7bf4724375042e0f.tar.bz2
gentoo-2-d517eba7a9d8e497fe68d95c7bf4724375042e0f.zip
moved kstars, moldy, scigraphica, units and xcirquit from app-misc to app-sci
Diffstat (limited to 'app-sci/scigraphica')
-rw-r--r--app-sci/scigraphica/ChangeLog13
-rw-r--r--app-sci/scigraphica/files/digest-scigraphica-0.8.01
-rw-r--r--app-sci/scigraphica/scigraphica-0.8.0.ebuild56
3 files changed, 70 insertions, 0 deletions
diff --git a/app-sci/scigraphica/ChangeLog b/app-sci/scigraphica/ChangeLog
new file mode 100644
index 000000000000..e1df53ecabc2
--- /dev/null
+++ b/app-sci/scigraphica/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-misc/scigraphica
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-sci/scigraphica/ChangeLog,v 1.1 2002/05/07 01:57:35 george Exp $
+
+*scigraphica-0.8.0 (1 Feb 2002)
+
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/app-sci/scigraphica/files/digest-scigraphica-0.8.0 b/app-sci/scigraphica/files/digest-scigraphica-0.8.0
new file mode 100644
index 000000000000..16631c877734
--- /dev/null
+++ b/app-sci/scigraphica/files/digest-scigraphica-0.8.0
@@ -0,0 +1 @@
+MD5 8527c80fe75bc4f72c14548c7a2b0b71 scigraphica-0.8.0.tar.gz 841199
diff --git a/app-sci/scigraphica/scigraphica-0.8.0.ebuild b/app-sci/scigraphica/scigraphica-0.8.0.ebuild
new file mode 100644
index 000000000000..5f4c2951a680
--- /dev/null
+++ b/app-sci/scigraphica/scigraphica-0.8.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Tod Neidt <tod@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-sci/scigraphica/scigraphica-0.8.0.ebuild,v 1.1 2002/05/07 01:57:35 george Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Scientific application for data analysis and technical graphics."
+
+SRC_URI="http://scigraphica.sourceforge.net/src/${P}.tar.gz"
+
+HOMEPAGE="http://scigraphica.sourceforge.net/"
+
+DEPEND=">=x11-libs/gtk+extra-0.99.17
+ >=dev-python/Numeric-20.3
+ >=dev-libs/libxml-1.8.16
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r3 >=gnome-base/ORBit-0.5.12-r1 >=gnome-base/gnome-print-0.34 )"
+ #bonobo? ( >=gnome-base/bonobo-1.0.18 )"
+
+src_compile() {
+
+#bonobo breaks compile when enabled so it is not enabled for now.
+#the result seems to be no printing under gnome.
+#also need to look into --with-lp and --with-lpr config flags
+
+ local myconf=""
+ use gnome || myconf="${myconf} --without-gnome" #default enabled
+# use bonobo && myconf="${myconf} --with-bonobo" #default disabled
+
+ #fix Exec= in sg.desktop
+ cp sg.desktop sg.desktop.orig
+ sed -e 's:\(Exec=\)sga:\1scigraphica:' sg.desktop.orig > sg.desktop
+
+ #fix termcap dependency
+ cp configure configure.orig
+ sed -e 's:-ltermcap:-lncurses:' configure.orig > configure
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} || die "Configuration Failed"
+
+ emake || die "Parallel Make Failed"
+
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die "Installation Failed"
+
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog FAQ.compile \
+ INSTALL NEWS README TODO
+
+}