summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-01-11 09:16:40 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-01-11 09:16:40 +0000
commitc0bb46066f3123e9cb9bd0ee6a8192fee8ee3a7e (patch)
tree3d02e1f22c14cccec1a51757b9a1c66e6e4c959c /app-sci
parentinitial commit, ebuild by robbat2@gentoo.org (Manifest recommit) (diff)
downloadgentoo-2-c0bb46066f3123e9cb9bd0ee6a8192fee8ee3a7e.tar.gz
gentoo-2-c0bb46066f3123e9cb9bd0ee6a8192fee8ee3a7e.tar.bz2
gentoo-2-c0bb46066f3123e9cb9bd0ee6a8192fee8ee3a7e.zip
initial commit, ebuild by robbat2@gentoo.org
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/gt-itm/ChangeLog9
-rw-r--r--app-sci/gt-itm/Manifest3
-rw-r--r--app-sci/gt-itm/files/digest-gt-itm-199610042
-rw-r--r--app-sci/gt-itm/gt-itm-19961004.ebuild54
4 files changed, 68 insertions, 0 deletions
diff --git a/app-sci/gt-itm/ChangeLog b/app-sci/gt-itm/ChangeLog
new file mode 100644
index 000000000000..68d3c411b475
--- /dev/null
+++ b/app-sci/gt-itm/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-sci/gt-itm
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/gt-itm/ChangeLog,v 1.1 2004/01/11 09:16:40 robbat2 Exp $
+
+*gt-itm-19961004 (11 Jan 2004)
+
+ 11 Jan 2004; Robin H. Johnson <robbat2@gentoo.org> gt-itm-19961004.ebuild:
+ initial commit, ebuild by robbat2@gentoo.org
+
diff --git a/app-sci/gt-itm/Manifest b/app-sci/gt-itm/Manifest
new file mode 100644
index 000000000000..45424daca92b
--- /dev/null
+++ b/app-sci/gt-itm/Manifest
@@ -0,0 +1,3 @@
+MD5 bf00cefa67d12f8e577f388ce6ca4348 gt-itm-19961004.ebuild 1414
+MD5 5c1ad0b3ff1ba798a44200ef26d120d9 files/digest-gt-itm-19961004 115
+MD5 5c1ad0b3ff1ba798a44200ef26d120d9 files/digest-gt-itm-1.0 115
diff --git a/app-sci/gt-itm/files/digest-gt-itm-19961004 b/app-sci/gt-itm/files/digest-gt-itm-19961004
new file mode 100644
index 000000000000..0da834b07b08
--- /dev/null
+++ b/app-sci/gt-itm/files/digest-gt-itm-19961004
@@ -0,0 +1,2 @@
+MD5 4d36b0b3ffa1c8c1b4d9e5b49cfa34cd gt-itm.tar.gz 623345
+MD5 4b44dc6adbeff7a9c5e13ade0b7db90d sgb2ns.tar.gz 50635
diff --git a/app-sci/gt-itm/gt-itm-19961004.ebuild b/app-sci/gt-itm/gt-itm-19961004.ebuild
new file mode 100644
index 000000000000..e9a0f4fa4659
--- /dev/null
+++ b/app-sci/gt-itm/gt-itm-19961004.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/gt-itm/gt-itm-19961004.ebuild,v 1.1 2004/01/11 09:16:40 robbat2 Exp $
+
+DESCRIPTION="This is a sample skeleton ebuild file"
+HOMEPAGE="http://www.cc.gatech.edu/fac/Ellen.Zegura/graphs.html
+ http://www.isi.edu/nsnam/ns/ns-topogen.html#gt-itm"
+SRC_URI="http://www.cc.gatech.edu/fac/Ellen.Zegura/gt-itm/gt-itm.tar.gz
+ http://www.isi.edu/nsnam/dist/sgb2ns.tar.gz"
+LICENSE="as-is BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-util/sgb"
+S=${WORKDIR}/${PN}
+S2=${WORKDIR}/sgb2ns
+
+src_unpack() {
+ unpack sgb2ns.tar.gz
+
+ mkdir ${S}
+ cd ${S}
+ unpack gt-itm.tar.gz
+
+ sed -r -e '/^[[:alnum:]]+\.o:/d' -e 's|LIBS = -lm -lgb.*|LIBS = -lm -lgb|' -i ${S}/src/Makefile
+ sed -r -e '/^SYS = -DSYSV/d' -e 's|LIBS = -lm -lgb.*|LIBS = -lm -lgb|' -i ${S2}/Makefile || die
+
+ rm -f ${S}/lib/*
+
+ find ${S}/sample-graphs/ -perm +111 -type f -name 'Run*' \
+ | xargs -r -n1 sed -re 's|(\.\./)+bin/||g' -i || die
+
+ sed -e 's|sys/types.h|sys/param.h|' -i ${S}/src/geog.c
+ sed -e '162 s/connected $/connected \\/' -i ${S}/src/eval.c
+}
+
+src_compile() {
+ cd ${S}/src
+ emake CFLAGS="${CFLAGS} -I../include" || die
+
+ cd ${S2}
+ emake CFLAGS="${CFLAGS} -I\$(IDIR) -L\$(LDIR)" || die
+}
+
+src_install() {
+ dobin ${S}/bin/*
+ dodoc ${S}/README ${S}/docs/*
+ cp -ra ${S}/sample-graphs ${D}/usr/share/doc/${PF}
+
+ cd ${S2}
+ dodoc *.tcl *.gb
+ newdoc README README.sgb2ns
+
+}