summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-03-03 00:45:14 +0000
committerJeroen Roovers <jer@gentoo.org>2014-03-03 00:45:14 +0000
commit852aab9c2aab650c372e2df0848731b547c66b74 (patch)
treec9b1afe4661201d9a140dd783c97008840fd68da /app-shells/fish/fish-2.1.0-r3.ebuild
parentfinal fix for bug 465954 (diff)
downloadgentoo-2-852aab9c2aab650c372e2df0848731b547c66b74.tar.gz
gentoo-2-852aab9c2aab650c372e2df0848731b547c66b74.tar.bz2
gentoo-2-852aab9c2aab650c372e2df0848731b547c66b74.zip
Fix building against sys-libs/ncurses[tinfo] (bug #459768).
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'app-shells/fish/fish-2.1.0-r3.ebuild')
-rw-r--r--app-shells/fish/fish-2.1.0-r3.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/app-shells/fish/fish-2.1.0-r3.ebuild b/app-shells/fish/fish-2.1.0-r3.ebuild
new file mode 100644
index 000000000000..ee998d40ab08
--- /dev/null
+++ b/app-shells/fish/fish-2.1.0-r3.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/fish-2.1.0-r3.ebuild,v 1.1 2014/03/03 00:45:14 jer Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit base autotools
+
+DESCRIPTION="fish is the Friendly Interactive SHell"
+HOMEPAGE="http://fishshell.com/"
+SRC_URI="http://fishshell.com/files/${PV}/${P}.tar.gz
+ https://github.com/fish-shell/fish-shell/commit/9a3643501607bff8b314977931916081dd39646a.patch -> ${P}-docdir.patch"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="X"
+
+DEPEND="sys-libs/ncurses
+ sys-devel/bc
+ sys-devel/gettext
+ X? ( x11-misc/xsel )"
+
+# fish can add man-page completions from lzma and xz compressed man pages
+# through a python script. That's why we depend on python here (bug #490478)
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${DISTDIR}"/${P}-docdir.patch #489934
+ epatch "${FILESDIR}"/${P}-tinfo.patch #459768
+
+ eautoreconf
+}
+
+src_configure() {
+ # Set things up for fish to be a default shell.
+ # It has to be in /bin in case /usr is unavailable.
+ # Also, all of its utilities have to be in /bin.
+ econf \
+ docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --bindir="${EPREFIX}"/bin
+}
+
+src_test() {
+ if has_version ~${CATEGORY}/${P} ; then
+ emake test
+ else
+ ewarn "The test suite only works when the package is already installed"
+ fi
+}
+
+pkg_postinst() {
+ elog "fish is now installed on your system."
+ elog "To run fish, type 'fish' in your terminal."
+ elog
+ elog "To use fish as your login shell:"
+ elog "* add the line '${EPREFIX}/bin/${PN}'"
+ elog "* to the file '${EPREFIX}/etc/shells'."
+ elog "* use the command 'chsh -s ${EPREFIX}/bin/${PN}'."
+ elog
+ elog "To set your colors, run 'fish_config'"
+ elog "To scan your man pages for completions, run 'fish_update_completions'"
+ elog "To autocomplete command suggestions press Ctrl + F or right arrow key."
+ elog
+ elog "Please add a \"BROWSER\" variable to ${PN}'s environment pointing to the"
+ elog "browser of your choice to get acces to ${PN}'s help system:"
+ elog " BROWSER=\"/usr/bin/firefox\""
+ elog
+ elog "In order to get lzma and xz support for man-page completion please"
+ elog "emerge one of the following packages:"
+ elog " dev-python/backports-lzma"
+ elog " >=dev-lang/python-3.3"
+ elog
+ elog "Have fun!"
+}