summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-03-14 21:17:14 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-03-14 21:17:14 +0000
commita771a2692648bff9ef974fe941e9ac5ad69fa88f (patch)
tree299b2f54d8784065e927d7ae632b58bfac14cb1e /app-shells/sash
parentDigest add. (diff)
downloadgentoo-2-a771a2692648bff9ef974fe941e9ac5ad69fa88f.tar.gz
gentoo-2-a771a2692648bff9ef974fe941e9ac5ad69fa88f.tar.bz2
gentoo-2-a771a2692648bff9ef974fe941e9ac5ad69fa88f.zip
sash statically links in zlib... bumping dep up to 1.1.4
Diffstat (limited to 'app-shells/sash')
-rw-r--r--app-shells/sash/ChangeLog10
-rw-r--r--app-shells/sash/files/digest-sash-3.4-r52
-rw-r--r--app-shells/sash/sash-3.4-r5.ebuild49
3 files changed, 59 insertions, 2 deletions
diff --git a/app-shells/sash/ChangeLog b/app-shells/sash/ChangeLog
index 478b2eec94cf..32be35f44345 100644
--- a/app-shells/sash/ChangeLog
+++ b/app-shells/sash/ChangeLog
@@ -1,10 +1,16 @@
# ChangeLog for app-shells/sash
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/ChangeLog,v 1.2 2002/03/08 09:26:06 blocke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/ChangeLog,v 1.3 2002/03/14 21:17:14 blocke Exp $
+*sash-3.4-r5 (14 Mar 2002)
+
+ 14 Mar 2002; Bruce A. Locke <blocke@shivan.org> sash-3.4-r5.ebuild:
+
+ bump up zlib dep from 1.1.3 to 1.1.4
+
*sash-3.4-r4 (8 Mar 2002)
- 8 Mar 2002; Bruce A. Locke <blocke@gentoo.org> sash-3.4-r4.ebuild:
+ 8 Mar 2002; Bruce A. Locke <blocke@shivan.org> sash-3.4-r4.ebuild:
sash is always static now... previous versions were only built statically
if 'static' USE keyword was set
diff --git a/app-shells/sash/files/digest-sash-3.4-r5 b/app-shells/sash/files/digest-sash-3.4-r5
new file mode 100644
index 000000000000..932680c25ee4
--- /dev/null
+++ b/app-shells/sash/files/digest-sash-3.4-r5
@@ -0,0 +1,2 @@
+MD5 9c631eb171371b69276ff6692100beb6 sash-3.4.tar.gz 49149
+MD5 43cbfb670d42e6e15b58f3b528f75ca0 sash-3.x-readline.diff.gz 3181
diff --git a/app-shells/sash/sash-3.4-r5.ebuild b/app-shells/sash/sash-3.4-r5.ebuild
new file mode 100644
index 000000000000..132ce1a2bd42
--- /dev/null
+++ b/app-shells/sash/sash-3.4-r5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.4-r5.ebuild,v 1.1 2002/03/14 21:17:14 blocke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A small static UNIX Shell with readline suppport"
+SRC_URI="http://www.canb.auug.org.au/~dbell/programs/${P}.tar.gz
+ http://dimavb.st.simbirsk.su/vlk/sash-3.x-readline.diff.gz"
+HOMEPAGE="http://www.canb.auug.org.au/~dbell/ http://dimavb.st.simbirsk.su/vlk/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/zlib-1.1.4
+ readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )"
+
+RDEPEND=""
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+
+ if [ "`use readline`" ]
+ then
+ gzip -dc ${DISTDIR}/sash-3.x-readline.diff.gz | patch -p1
+
+ cp Makefile Makefile.orig
+ sed -e "s:-O2:${CFLAGS}:" -e "s:-ltermcap:-lncurses:" Makefile.orig > Makefile
+ else
+ cp Makefile Makefile.orig
+ sed -e "s:-O3:${CFLAGS}:" Makefile.orig > Makefile
+ fi
+}
+
+src_compile() {
+
+ make || die
+
+}
+
+src_install() {
+
+ into /
+ dobin sash
+ into /usr
+ doman sash.1
+ dodoc README
+
+}
+