summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-10 00:01:36 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-10 00:01:36 +0000
commit29f1876d0534ab6ef122f7e379d2346ee32e1247 (patch)
tree41c3b47f83d02d3c703b22236ee98b3e0bb5cb14 /app-shells
parentGrab a fix from upstream cvs to fix `su -c boo` syntax #118342 by Wolfgang Fr... (diff)
downloadgentoo-2-29f1876d0534ab6ef122f7e379d2346ee32e1247.tar.gz
gentoo-2-29f1876d0534ab6ef122f7e379d2346ee32e1247.tar.bz2
gentoo-2-29f1876d0534ab6ef122f7e379d2346ee32e1247.zip
Grab some more patches from upstream.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/ChangeLog8
-rw-r--r--app-shells/bash/bash-3.1_p5.ebuild (renamed from app-shells/bash/bash-3.1-r2.ebuild)24
-rw-r--r--app-shells/bash/files/bash-3.1-ulimit.patch60
-rw-r--r--app-shells/bash/files/digest-bash-3.1-r23
-rw-r--r--app-shells/bash/files/digest-bash-3.1_p57
5 files changed, 38 insertions, 64 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index 1cde9b05c0e9..b267ca616823 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.82 2006/01/04 05:47:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.83 2006/01/10 00:01:36 vapier Exp $
+
+*bash-3.1_p5 (10 Jan 2006)
+
+ 10 Jan 2006; Mike Frysinger <vapier@gentoo.org>
+ files/bash-3.1-ulimit.patch, -bash-3.1-r2.ebuild, +bash-3.1_p5.ebuild:
+ Grab some more patches from upstream.
*bash-3.1-r2 (04 Jan 2006)
diff --git a/app-shells/bash/bash-3.1-r2.ebuild b/app-shells/bash/bash-3.1_p5.ebuild
index 585e95737cfe..795af90c9b43 100644
--- a/app-shells/bash/bash-3.1-r2.ebuild
+++ b/app-shells/bash/bash-3.1_p5.ebuild
@@ -1,25 +1,27 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.1-r2.ebuild,v 1.1 2006/01/04 05:47:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.1_p5.ebuild,v 1.1 2006/01/10 00:01:36 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
# Official patchlevel
# See ftp://ftp.cwru.edu/pub/bash/bash-3.1-patches/
-PLEVEL=1
+PLEVEL=${PV##*_p}
+MY_PV=${PV/_p*}
+MY_P=${PN}-${MY_PV}
READLINE_VER=5.1
READLINE_PLEVEL=1
DESCRIPTION="The standard GNU Bourne again shell"
HOMEPAGE="http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
# Hit the GNU mirrors before hitting Chet's site
-SRC_URI="mirror://gnu/bash/${P}.tar.gz
- ftp://ftp.cwru.edu/pub/bash/${P}.tar.gz
+SRC_URI="mirror://gnu/bash/${MY_P}.tar.gz
+ ftp://ftp.cwru.edu/pub/bash/${MY_P}.tar.gz
$(for ((i=1; i<=PLEVEL; i++)); do
printf 'ftp://ftp.cwru.edu/pub/bash/bash-%s-patches/bash%s-%03d\n' \
- ${PV} ${PV/\.} ${i}
+ ${MY_PV} ${MY_PV/\.} ${i}
printf 'mirror://gnu/bash/bash-%s-patches/bash%s-%03d\n' \
- ${PV} ${PV/\.} ${i}
+ ${MY_PV} ${MY_PV/\.} ${i}
done)
$(for ((i=1; i<=READLINE_PLEVEL; i++)); do
printf 'ftp://ftp.cwru.edu/pub/bash/readline-%s-patches/readline%s-%03d\n' \
@@ -35,15 +37,17 @@ IUSE="afs nls build bashlogger unicode"
DEPEND=">=sys-libs/ncurses-5.2-r2"
+S=${WORKDIR}/${MY_P}
+
src_unpack() {
- unpack ${P}.tar.gz
+ unpack ${MY_P}.tar.gz
cd "${S}"
epatch "${FILESDIR}"/${PN}-3.1-gentoo.patch
# Include official patches
local i
for ((i=1; i<=PLEVEL; i++)); do
- epatch "${DISTDIR}"/${PN}${PV/\.}-$(printf '%03d' ${i})
+ epatch "${DISTDIR}"/${PN}${MY_PV/\.}-$(printf '%03d' ${i})
done
cd lib/readline
for ((i=1; i<=READLINE_PLEVEL; i++)); do
@@ -51,12 +55,10 @@ src_unpack() {
done
cd ../..
- # Fixup array handling #116352
- epatch "${FILESDIR}"/${P}-arrays.patch
# Fall back to /etc/inputrc
epatch "${FILESDIR}"/${PN}-3.0-etc-inputrc.patch
# Add more ulimit options (from Fedora)
- epatch "${FILESDIR}"/${P}-ulimit.patch
+ epatch "${FILESDIR}"/${MY_P}-ulimit.patch
# Fix a memleak in read_builtin (from Fedora)
epatch "${FILESDIR}"/${PN}-3.0-read-memleak.patch
# Don't barf on handled signals in scripts
diff --git a/app-shells/bash/files/bash-3.1-ulimit.patch b/app-shells/bash/files/bash-3.1-ulimit.patch
index f7add630af0f..8137b1493df1 100644
--- a/app-shells/bash/files/bash-3.1-ulimit.patch
+++ b/app-shells/bash/files/bash-3.1-ulimit.patch
@@ -55,12 +55,12 @@ for many other options
@item ulimit
@btindex ulimit
@example
--ulimit [-acdflmnpstuvSH] [@var{limit}]
+-ulimit [-acdfilmnpqstuvxSH] [@var{limit}]
+ulimit [-acdefilmnpqrstuvxSH] [@var{limit}]
@end example
@code{ulimit} provides control over the resources available to processes
started by the shell, on systems that allow such control. If an
-@@ -3854,9 +3854,15 @@
+@@ -3854,6 +3854,9 @@
@item -d
The maximum size of a process's data segment.
@@ -70,47 +70,28 @@ for many other options
@item -f
The maximum size of files created by the shell.
-+@item -i
-+The maximum number of pending signals.
-+
- @item -l
- The maximum size that may be locked into memory.
-
-@@ -3869,6 +3875,12 @@
- @item -p
- The pipe buffer size.
+@@ -3875,6 +3878,9 @@
+ @item -q
+ The maximum number of bytes in POSIX message queues.
-+@item -q
-+The maximum number of bytes in POSIX message queues.
-+
+@item -r
+The maximum RT priority.
+
@item -s
The maximum stack size.
-@@ -3881,6 +3893,9 @@
- @item -v
- The maximum amount of virtual memory available to the process.
-
-+@item -x
-+The maximum amount of file locks.
-+
- @end table
-
- If @var{limit} is given, it is the new value of the specified resource;
--- doc/bash.1
+++ doc/bash.1
-@@ -8484,7 +8484,7 @@
+@@ -8490,7 +8490,7 @@
returns true if any of the arguments are found, false if
none are found.
.TP
--\fBulimit\fP [\fB\-SHacdflmnpstuv\fP [\fIlimit\fP]]
+-\fBulimit\fP [\fB\-SHacdfilmnpqstuvx\fP [\fIlimit\fP]]
+\fBulimit\fP [\fB\-SHacdefilmnpqrstuvx\fP [\fIlimit\fP]]
Provides control over the resources available to the shell and to
processes started by it, on systems that allow such control.
The \fB\-H\fP and \fB\-S\fP options specify that the hard or soft limit is
-@@ -8520,9 +8520,15 @@
+@@ -8526,6 +8526,9 @@
.B \-d
The maximum size of a process's data segment
.TP
@@ -120,32 +101,13 @@ for many other options
.B \-f
The maximum size of files created by the shell
.TP
-+.B \-i
-+The maximum number of pending signals
-+.TP
- .B \-l
- The maximum size that may be locked into memory
- .TP
-@@ -8536,6 +8542,12 @@
- .B \-p
- The pipe size in 512-byte blocks (this may not be set)
+@@ -8548,6 +8551,9 @@
+ .B \-q
+ The maximum number of bytes in POSIX message queues
.TP
-+.B \-q
-+The maximum number of bytes in POSIX message queues
-+.TP
+.B \-r
+The maximum rt priority
+.TP
.B \-s
The maximum stack size
.TP
-@@ -8547,6 +8559,9 @@
- .TP
- .B \-v
- The maximum amount of virtual memory available to the shell
-+.TP
-+.B \-x
-+The maximum number of file locks
- .PD
- .PP
- If
diff --git a/app-shells/bash/files/digest-bash-3.1-r2 b/app-shells/bash/files/digest-bash-3.1-r2
deleted file mode 100644
index 337b1b5cc017..000000000000
--- a/app-shells/bash/files/digest-bash-3.1-r2
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 ef5304c4b22aaa5088972c792ed45d72 bash-3.1.tar.gz 2533934
-MD5 c0d33bdfed6e4e6a9ae9200b77cd5c99 bash31-001 2708
-MD5 63faf622820ca0828131c8b5aeac1e6a readline51-001 2042
diff --git a/app-shells/bash/files/digest-bash-3.1_p5 b/app-shells/bash/files/digest-bash-3.1_p5
new file mode 100644
index 000000000000..f894d8d19a53
--- /dev/null
+++ b/app-shells/bash/files/digest-bash-3.1_p5
@@ -0,0 +1,7 @@
+MD5 ef5304c4b22aaa5088972c792ed45d72 bash-3.1.tar.gz 2533934
+MD5 c0d33bdfed6e4e6a9ae9200b77cd5c99 bash31-001 2708
+MD5 0c9be3bad344d04b79c4eac9eb39624c bash31-002 7169
+MD5 04750485f335972f7a980a1bfe048dba bash31-003 1324
+MD5 0c2856794ab16a4c224223c1964140c2 bash31-004 1470
+MD5 943233d7227071fa040c8b9eb016fa0c bash31-005 1322
+MD5 63faf622820ca0828131c8b5aeac1e6a readline51-001 2042