summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2014-10-18 11:52:06 +0000
committerJauhien Piatlicki <jauhien@gentoo.org>2014-10-18 11:52:06 +0000
commit47efc9038b4845cba292260345172f618b31b192 (patch)
treee53f146b97d5f35ecfb775cd5e0e432ed5e30412 /app-shells
parentinitial import from the rust overlay (diff)
downloadgentoo-2-47efc9038b4845cba292260345172f618b31b192.tar.gz
gentoo-2-47efc9038b4845cba292260345172f618b31b192.tar.bz2
gentoo-2-47efc9038b4845cba292260345172f618b31b192.zip
initial import from the rust overlay
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key 0xB2EFA1D4)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/rust-zshcomp/ChangeLog10
-rw-r--r--app-shells/rust-zshcomp/metadata.xml8
-rw-r--r--app-shells/rust-zshcomp/rust-zshcomp-0.11.0.ebuild36
-rw-r--r--app-shells/rust-zshcomp/rust-zshcomp-0.12.0.ebuild36
4 files changed, 90 insertions, 0 deletions
diff --git a/app-shells/rust-zshcomp/ChangeLog b/app-shells/rust-zshcomp/ChangeLog
new file mode 100644
index 000000000000..aa3f416e469a
--- /dev/null
+++ b/app-shells/rust-zshcomp/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-shells/rust-zshcomp
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/rust-zshcomp/ChangeLog,v 1.1 2014/10/18 11:52:06 jauhien Exp $
+
+*rust-zshcomp-0.11.0 (18 Oct 2014)
+*rust-zshcomp-0.12.0 (18 Oct 2014)
+
+ 18 Oct 2014; Jauhien Piatlicki <jauhien@gentoo.org> +metadata.xml,
+ +rust-zshcomp-0.11.0.ebuild, +rust-zshcomp-0.12.0.ebuild:
+ initial import from the rust overlay
diff --git a/app-shells/rust-zshcomp/metadata.xml b/app-shells/rust-zshcomp/metadata.xml
new file mode 100644
index 000000000000..0b7db932cfa4
--- /dev/null
+++ b/app-shells/rust-zshcomp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jauhien@gentoo.org</email>
+ <name>Jauhien Piatlicki</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-shells/rust-zshcomp/rust-zshcomp-0.11.0.ebuild b/app-shells/rust-zshcomp/rust-zshcomp-0.11.0.ebuild
new file mode 100644
index 000000000000..fd9a809318b5
--- /dev/null
+++ b/app-shells/rust-zshcomp/rust-zshcomp-0.11.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/rust-zshcomp/rust-zshcomp-0.11.0.ebuild,v 1.1 2014/10/18 11:52:06 jauhien Exp $
+
+EAPI="5"
+
+DESCRIPTION="Rust zsh completions"
+HOMEPAGE="http://www.rust-lang.org/"
+SRC_URI="http://static.rust-lang.org/dist/rust-${PV}.tar.gz"
+
+LICENSE="|| ( MIT Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-shells/zsh
+ !!<=app-admin/eselect-rust-0.1_pre20140820
+ !<=dev-lang/rust-0.11.0-r1:0.11
+ !<=dev-lang/rust-999:nightly
+ !<=dev-lang/rust-9999-r2:git
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/rust-${PV}"
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins src/etc/zsh/_rust
+}
diff --git a/app-shells/rust-zshcomp/rust-zshcomp-0.12.0.ebuild b/app-shells/rust-zshcomp/rust-zshcomp-0.12.0.ebuild
new file mode 100644
index 000000000000..0bfa990a9141
--- /dev/null
+++ b/app-shells/rust-zshcomp/rust-zshcomp-0.12.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/rust-zshcomp/rust-zshcomp-0.12.0.ebuild,v 1.1 2014/10/18 11:52:06 jauhien Exp $
+
+EAPI="5"
+
+DESCRIPTION="Rust zsh completions"
+HOMEPAGE="http://www.rust-lang.org/"
+SRC_URI="http://static.rust-lang.org/dist/rust-${PV}.tar.gz"
+
+LICENSE="|| ( MIT Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-shells/zsh
+ !!<=app-admin/eselect-rust-0.1_pre20140820
+ !<=dev-lang/rust-0.11.0-r1:0.11
+ !<=dev-lang/rust-999:nightly
+ !<=dev-lang/rust-9999-r2:git
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/rust-${PV}"
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins src/etc/zsh/_rust
+}