summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-07-11 08:33:20 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-07-11 08:33:20 +0000
commit9755b99bd16a48d4b0078ab603d405a8d1f06e6e (patch)
tree8f4366148cdc0894e9603996d390a211701164a8 /app-shells
parentVersion bump. Removed old (diff)
downloadgentoo-2-9755b99bd16a48d4b0078ab603d405a8d1f06e6e.tar.gz
gentoo-2-9755b99bd16a48d4b0078ab603d405a8d1f06e6e.tar.bz2
gentoo-2-9755b99bd16a48d4b0078ab603d405a8d1f06e6e.zip
Bump
(Portage version: 2.2.20/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/mksh/ChangeLog7
-rw-r--r--app-shells/mksh/mksh-51.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/app-shells/mksh/ChangeLog b/app-shells/mksh/ChangeLog
index 3a85d11a121f..30b34934b12a 100644
--- a/app-shells/mksh/ChangeLog
+++ b/app-shells/mksh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/mksh
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/mksh/ChangeLog,v 1.63 2015/04/20 02:51:01 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/mksh/ChangeLog,v 1.64 2015/07/11 08:33:20 patrick Exp $
+
+*mksh-51 (11 Jul 2015)
+
+ 11 Jul 2015; Patrick Lauer <patrick@gentoo.org> +mksh-51.ebuild:
+ Bump
*mksh-50f (20 Apr 2015)
diff --git a/app-shells/mksh/mksh-51.ebuild b/app-shells/mksh/mksh-51.ebuild
new file mode 100644
index 000000000000..fcb2e10991bf
--- /dev/null
+++ b/app-shells/mksh/mksh-51.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/mksh/mksh-51.ebuild,v 1.1 2015/07/11 08:33:20 patrick Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="MirBSD KSH Shell"
+HOMEPAGE="http://mirbsd.de/mksh"
+SRC_URI="http://www.mirbsd.org/MirOS/dist/mir/mksh/${PN}-R${PV}.tgz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static"
+DEPEND="static? ( dev-libs/klibc )"
+RDEPEND=""
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ tc-export CC
+ # we want to build static with klibc
+ if use static ; then
+ unset CC
+ export CC="/usr/bin/klcc"
+ export LDSTATIC="-static"
+ fi
+ export CPPFLAGS="${CPPFLAGS} -DMKSH_DEFAULT_PROFILEDIR=\\\"${EPREFIX}/etc\\\""
+ # we can't assume lto existing/enabled, so we add a fallback
+ sh Build.sh -r -c lto || sh Rebuild.sh || die
+}
+
+src_install() {
+ exeinto /bin
+ doexe mksh
+ doman mksh.1
+ dodoc dot.mkshrc
+}
+
+src_test() {
+ ./test.sh || die
+}
+
+pkg_postinst() {
+ ebegin "Updating /etc/shells"
+ ( grep -v "^/bin/mksh$" "${ROOT}"etc/shells; echo "/bin/mksh" ) > "${T}"/shells
+ mv -f "${T}"/shells "${ROOT}"etc/shells
+ eend $?
+}