summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-03-18 03:54:21 +0000
committerMike Gilbert <floppym@gentoo.org>2012-03-18 03:54:21 +0000
commitbe35fd6faf0dd5bd933bcd56dea8b5ef8bb1eeec (patch)
treea1429eeb3f5b35d1b293071d0d8153d926d4fc32 /app-shells
parentVersion bump. (diff)
downloadgentoo-2-be35fd6faf0dd5bd933bcd56dea8b5ef8bb1eeec.tar.gz
gentoo-2-be35fd6faf0dd5bd933bcd56dea8b5ef8bb1eeec.tar.bz2
gentoo-2-be35fd6faf0dd5bd933bcd56dea8b5ef8bb1eeec.zip
Version bump. Remove old.
(Portage version: 2.2.0_alpha91/cvs/Linux x86_64)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/ksh/ChangeLog8
-rw-r--r--app-shells/ksh/ksh-93.20071105.ebuild74
-rw-r--r--app-shells/ksh/ksh-93.20081104.ebuild74
-rw-r--r--app-shells/ksh/ksh-93.20090505.ebuild74
-rw-r--r--app-shells/ksh/ksh-93.20120229.ebuild53
5 files changed, 60 insertions, 223 deletions
diff --git a/app-shells/ksh/ChangeLog b/app-shells/ksh/ChangeLog
index fad6f0e2820b..c86aa33b1f8e 100644
--- a/app-shells/ksh/ChangeLog
+++ b/app-shells/ksh/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/ksh
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ChangeLog,v 1.45 2012/02/13 16:11:20 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ChangeLog,v 1.46 2012/03/18 03:54:21 floppym Exp $
+
+*ksh-93.20120229 (18 Mar 2012)
+
+ 18 Mar 2012; Mike Gilbert <floppym@gentoo.org> +ksh-93.20120229.ebuild,
+ -ksh-93.20071105.ebuild, -ksh-93.20081104.ebuild, -ksh-93.20090505.ebuild:
+ Version bump. Remove old.
13 Feb 2012; Mike Gilbert <floppym@gentoo.org> metadata.xml:
Add Dan Douglas as a maintainer.
diff --git a/app-shells/ksh/ksh-93.20071105.ebuild b/app-shells/ksh/ksh-93.20071105.ebuild
deleted file mode 100644
index 59f30cdf40c0..000000000000
--- a/app-shells/ksh/ksh-93.20071105.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ksh-93.20071105.ebuild,v 1.8 2010/01/24 21:51:37 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-RELEASE="2007-11-05"
-LOCALE_RELEASE="2007-11-05"
-INIT_RELEASE="${RELEASE}"
-
-DESCRIPTION="The Original Korn Shell, 1993 revision (ksh93)"
-HOMEPAGE="http://www.kornshell.com/"
-SRC_URI="nls? ( mirror://gentoo/ast-ksh-locale.${LOCALE_RELEASE}.tgz )
- mirror://gentoo/INIT.${INIT_RELEASE}.tgz
- mirror://gentoo/ast-ksh.${RELEASE}.tgz"
-
-LICENSE="CPL-1.0"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ia64 ppc ~ppc64 s390 sparc x86"
-IUSE="nls"
-
-DEPEND="!app-shells/pdksh"
-RDEPEND=""
-
-S=${WORKDIR}
-
-src_unpack() {
- # the AT&T build tools look in here for packages.
- mkdir -p "${S}"/lib/package/tgz
-
- # move the packages into place.
- cp "${DISTDIR}"/ast-ksh.${RELEASE}.tgz "${S}"/lib/package/tgz/ || die
-
- if use nls; then
- cp "${DISTDIR}"/ast-ksh-locale.${LOCALE_RELEASE}.tgz "${S}"/lib/package/tgz/ || die
- fi
-
- # INIT provides the basic tools to start building.
- unpack INIT.${INIT_RELEASE}.tgz
-
- # run through /bin/sh due to #141906
- sed -i '1i#!/bin/sh' "${S}"/bin/package || die
-
- # `package read` will unpack any tarballs put in place.
- "${S}"/bin/package read || die
-}
-
-src_compile() {
- strip-flags; export CCFLAGS="${CFLAGS}"
-
- cd "${S}"; ./bin/package only make ast-ksh CC="$(tc-getCC)" || die
-
- # install the optional locale data.
- if use nls; then
- cd "${S}"; ./bin/package only make ast-ksh-locale CC="$(tc-getCC)"
- fi
-}
-
-src_install() {
- exeinto /bin
-
- doexe "${S}"/arch/linux.*/bin/ksh || die
-
- newman "${S}"/arch/linux.*/man/man1/sh.1 ksh.1
-
- dodoc lib/package/LICENSES/ast
- dohtml lib/package/ast-ksh.html
-
- if use nls; then
- dodir /usr/share
- mv "${S}"/share/lib/locale "${D}"/usr/share
- find "${D}"/usr/share/locale -type f -name 'LC_TIME' -exec rm -rf {} \; 2>/dev/null
- fi
-}
diff --git a/app-shells/ksh/ksh-93.20081104.ebuild b/app-shells/ksh/ksh-93.20081104.ebuild
deleted file mode 100644
index 2a9bd1c3630c..000000000000
--- a/app-shells/ksh/ksh-93.20081104.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ksh-93.20081104.ebuild,v 1.4 2010/01/24 21:51:37 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-RELEASE="2008-11-04"
-LOCALE_RELEASE="2007-11-05"
-INIT_RELEASE="${RELEASE}"
-
-DESCRIPTION="The Original Korn Shell, 1993 revision (ksh93)"
-HOMEPAGE="http://www.kornshell.com/"
-SRC_URI="nls? ( mirror://gentoo/ast-ksh-locale.${LOCALE_RELEASE}.tgz )
- mirror://gentoo/INIT.${INIT_RELEASE}.tgz
- mirror://gentoo/ast-ksh.${RELEASE}.tgz"
-
-LICENSE="CPL-1.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="nls"
-
-DEPEND="!app-shells/pdksh"
-RDEPEND=""
-
-S=${WORKDIR}
-
-src_unpack() {
- # the AT&T build tools look in here for packages.
- mkdir -p "${S}"/lib/package/tgz
-
- # move the packages into place.
- cp "${DISTDIR}"/ast-ksh.${RELEASE}.tgz "${S}"/lib/package/tgz/ || die
-
- if use nls; then
- cp "${DISTDIR}"/ast-ksh-locale.${LOCALE_RELEASE}.tgz "${S}"/lib/package/tgz/ || die
- fi
-
- # INIT provides the basic tools to start building.
- unpack INIT.${INIT_RELEASE}.tgz
-
- # run through /bin/sh due to #141906
- sed -i '1i#!/bin/sh' "${S}"/bin/package || die
-
- # `package read` will unpack any tarballs put in place.
- "${S}"/bin/package read || die
-}
-
-src_compile() {
- strip-flags; export CCFLAGS="${CFLAGS}"
-
- cd "${S}"; ./bin/package only make ast-ksh CC="$(tc-getCC)" || die
-
- # install the optional locale data.
- if use nls; then
- cd "${S}"; ./bin/package only make ast-ksh-locale CC="$(tc-getCC)"
- fi
-}
-
-src_install() {
- exeinto /bin
-
- doexe "${S}"/arch/linux.*/bin/ksh || die
-
- newman "${S}"/arch/linux.*/man/man1/sh.1 ksh.1
-
- dodoc lib/package/LICENSES/ast
- dohtml lib/package/ast-ksh.html
-
- if use nls; then
- dodir /usr/share
- mv "${S}"/share/lib/locale "${D}"/usr/share
- find "${D}"/usr/share/locale -type f -name 'LC_TIME' -exec rm -rf {} \; 2>/dev/null
- fi
-}
diff --git a/app-shells/ksh/ksh-93.20090505.ebuild b/app-shells/ksh/ksh-93.20090505.ebuild
deleted file mode 100644
index ae27c940ae4a..000000000000
--- a/app-shells/ksh/ksh-93.20090505.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ksh-93.20090505.ebuild,v 1.3 2010/01/24 21:51:37 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-RELEASE="2009-05-05"
-LOCALE_RELEASE="2007-11-05"
-INIT_RELEASE="${RELEASE}"
-
-DESCRIPTION="The Original Korn Shell, 1993 revision (ksh93)"
-HOMEPAGE="http://www.kornshell.com/"
-SRC_URI="nls? ( mirror://gentoo/ast-ksh-locale.${LOCALE_RELEASE}.tgz )
- mirror://gentoo/INIT.${INIT_RELEASE}.tgz
- mirror://gentoo/ast-ksh.${RELEASE}.tgz"
-
-LICENSE="CPL-1.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="nls"
-
-DEPEND="!app-shells/pdksh"
-RDEPEND=""
-
-S=${WORKDIR}
-
-src_unpack() {
- # the AT&T build tools look in here for packages.
- mkdir -p "${S}"/lib/package/tgz
-
- # move the packages into place.
- cp "${DISTDIR}"/ast-ksh.${RELEASE}.tgz "${S}"/lib/package/tgz/ || die
-
- if use nls; then
- cp "${DISTDIR}"/ast-ksh-locale.${LOCALE_RELEASE}.tgz "${S}"/lib/package/tgz/ || die
- fi
-
- # INIT provides the basic tools to start building.
- unpack INIT.${INIT_RELEASE}.tgz
-
- # run through /bin/sh due to #141906
- sed -i '1i#!/bin/sh' "${S}"/bin/package || die
-
- # `package read` will unpack any tarballs put in place.
- "${S}"/bin/package read || die
-}
-
-src_compile() {
- strip-flags; export CCFLAGS="${CFLAGS}"
-
- cd "${S}"; ./bin/package only make ast-ksh CC="$(tc-getCC)" || die
-
- # install the optional locale data.
- if use nls; then
- cd "${S}"; ./bin/package only make ast-ksh-locale CC="$(tc-getCC)"
- fi
-}
-
-src_install() {
- exeinto /bin
-
- doexe "${S}"/arch/linux.*/bin/ksh || die
-
- newman "${S}"/arch/linux.*/man/man1/sh.1 ksh.1
-
- dodoc lib/package/LICENSES/ast
- dohtml lib/package/ast-ksh.html
-
- if use nls; then
- dodir /usr/share
- mv "${S}"/share/lib/locale "${D}"/usr/share
- find "${D}"/usr/share/locale -type f -name 'LC_TIME' -exec rm -rf {} \; 2>/dev/null
- fi
-}
diff --git a/app-shells/ksh/ksh-93.20120229.ebuild b/app-shells/ksh/ksh-93.20120229.ebuild
new file mode 100644
index 000000000000..efc704ee64be
--- /dev/null
+++ b/app-shells/ksh/ksh-93.20120229.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ksh-93.20120229.ebuild,v 1.1 2012/03/18 03:54:21 floppym Exp $
+
+EAPI=4
+
+inherit toolchain-funcs versionator
+
+DESCRIPTION="The Original Korn Shell, 1993 revision (ksh93)"
+HOMEPAGE="http://www.kornshell.com/"
+
+ksh_release() {
+ local v="$(get_version_component_range 2)"
+ echo "${v:0:4}-${v:4:2}-${v:6:2}"
+}
+
+SRC_URI="mirror://gentoo/INIT.$(ksh_release).tgz
+ http://dev.gentoo.org/~floppym/distfiles/INIT.$(ksh_release).tgz
+ mirror://gentoo/ast-base.$(ksh_release).tgz
+ http://dev.gentoo.org/~floppym/distfiles/ast-base.$(ksh_release).tgz"
+
+LICENSE="CPL-1.0 EPL-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="!app-shells/pdksh"
+
+S=${WORKDIR}
+
+src_prepare() {
+ # Bug 238906.
+ sed -i -e 's,cd /tmp,cd "${TMPDIR:-/tmp}",' \
+ bin/package src/cmd/INIT/package.sh || die
+}
+
+src_compile() {
+ tc-export AR CC LD NM
+ export CCFLAGS="${CFLAGS}"
+ sh bin/package only make ast-ksh SHELL=/bin/sh SHOPT_SYSRC=1 || die
+}
+
+src_install() {
+ dodoc lib/package/ast-base.README
+ dohtml lib/package/ast-base.html
+
+ local myhost="$(sh bin/package host)"
+ cd "arch/${myhost}" || die
+ into /
+ dobin bin/ksh
+ dosym ksh /bin/rksh
+ newman man/man1/sh.1 ksh.1
+}