summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-05-19 15:57:12 +0000
committerRoy Marples <uberlord@gentoo.org>2007-05-19 15:57:12 +0000
commitc007360f644576e3726d426ad9053a1e3e531969 (patch)
tree13b039ef6e6f91fd85837e207a639a203d59c06e /app-shells
parentMarked ppc stable for bug #179092. (diff)
downloadgentoo-2-c007360f644576e3726d426ad9053a1e3e531969.tar.gz
gentoo-2-c007360f644576e3726d426ad9053a1e3e531969.tar.bz2
gentoo-2-c007360f644576e3726d426ad9053a1e3e531969.zip
libedit and static USE flags now work together
(Portage version: 2.1.2.7)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/dash/dash-0.5.3.7-r1.ebuild16
1 files changed, 5 insertions, 11 deletions
diff --git a/app-shells/dash/dash-0.5.3.7-r1.ebuild b/app-shells/dash/dash-0.5.3.7-r1.ebuild
index 052f790278a6..d1b7a56a1e9b 100644
--- a/app-shells/dash/dash-0.5.3.7-r1.ebuild
+++ b/app-shells/dash/dash-0.5.3.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/dash-0.5.3.7-r1.ebuild,v 1.2 2007/05/19 13:42:58 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/dash-0.5.3.7-r1.ebuild,v 1.3 2007/05/19 15:57:12 uberlord Exp $
inherit autotools eutils flag-o-matic toolchain-funcs
@@ -24,13 +24,6 @@ DEPEND="libedit? ( dev-libs/libedit )"
S="${WORKDIR}/${MY_P}"
-pkg_setup() {
- if use static && use libedit ; then
- eerror "You cannot build dash with both static and libedit USE flags"
- die "You cannot build dash with both static and libedit USE flags"
- fi
-}
-
src_unpack() {
unpack ${A}
@@ -44,7 +37,9 @@ src_unpack() {
# Always statically link libedit in to ensure we always boot if it changes
# which it has done in the past.
- sed -i -e 's/-ledit/-lncurses -Wl,-Bstatic -ledit -Wl,-Bdynamic/g' configure.ac || die
+ local s="s/-ledit/-Wl,-Bstatic -ledit -Wl,-Bdynamic -lcurses/g"
+ use static && s="s/-ledit/-ledit -lcurses/g"
+ sed -i -e "${s}" configure.ac || die "Failed to sed configure.ac"
# May as well, as the debian patches force this anyway
eautoreconf
@@ -53,12 +48,11 @@ src_unpack() {
src_compile() {
local myconf=
- use libedit && myconf="${myconf} --with-libedit"
use static && append-ldflags -static
+ use libedit && myconf="${myconf} --with-libedit"
export CC="$(tc-getCC)"
econf ${myconf} || die "econf failed"
-
emake CFLAGS="${CFLAGS}" || die "emake failed"
}