summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2007-01-05 14:11:09 +0000
committerSteve Dibb <beandog@gentoo.org>2007-01-05 14:11:09 +0000
commit11cabaeac1ad02f777fbeea378c4cc1c0890470f (patch)
tree014a504fa22ede2f8e74ab0fa4f3a3e28d41275b /app-text/bibletime/bibletime-1.5.3.ebuild
parentVersion bumped. Added code to look into different dirs for finding local patc... (diff)
downloadgentoo-2-11cabaeac1ad02f777fbeea378c4cc1c0890470f.tar.gz
gentoo-2-11cabaeac1ad02f777fbeea378c4cc1c0890470f.tar.bz2
gentoo-2-11cabaeac1ad02f777fbeea378c4cc1c0890470f.zip
ebuild langs cleanup, qa bug 136953
(Portage version: 2.1.1-r2)
Diffstat (limited to 'app-text/bibletime/bibletime-1.5.3.ebuild')
-rw-r--r--app-text/bibletime/bibletime-1.5.3.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/app-text/bibletime/bibletime-1.5.3.ebuild b/app-text/bibletime/bibletime-1.5.3.ebuild
index 2ee97e30409d..2649e81ae217 100644
--- a/app-text/bibletime/bibletime-1.5.3.ebuild
+++ b/app-text/bibletime/bibletime-1.5.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/bibletime/bibletime-1.5.3.ebuild,v 1.6 2006/10/21 17:10:38 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/bibletime/bibletime-1.5.3.ebuild,v 1.7 2007/01/05 14:11:09 beandog Exp $
inherit kde eutils
@@ -16,10 +16,11 @@ IUSE=""
DEPEND="=app-text/sword-1.5.8*"
LANGS_PKG=${PN}-i18n-1.5.1
-LANGS="af bg cs da de en_GB es fi fr hu it ko nl nn_NO no pl pt_BR ro ru sk ua"
+LANGS="af bg cs da de en_GB es fi fr hu it ko nl nn_NO no pl pt_BR ro ru sk uk"
LANGS_DOC="bg cs de fi fr it ko nl pt_BR ru"
for X in ${LANGS}; do
+ IUSE="${IUSE} linguas_${X}"
SRC_URI="${SRC_URI} linguas_${X}? ( mirror://sourceforge/bibletime/${LANGS_PKG}.tar.bz2 )"
done
@@ -44,10 +45,12 @@ src_unpack() {
local MAKE_LANGS MAKE_LANGS_DOC
for X in ${LANGS}; do
- use linguas_${X} && MAKE_LANGS="${MAKE_LANGS} ${X/pt_BR/pt_br}.po"
+ use linguas_${X} && MAKE_LANGS="${MAKE_LANGS} ${X/pt_BR/pt_br}.po
+ ${X/uk/ua}.po"
done
for X in ${LANGS_DOC}; do
- use linguas_${X} && MAKE_LANGS_DOC="${MAKE_LANGS_DOC} ${X/pt_BR/pt-br}"
+ use linguas_${X} && MAKE_LANGS_DOC="${MAKE_LANGS_DOC} ${X/pt_BR/pt-br}
+ ${X/uk/ua}"
done
if [ -d "${WORKDIR}/${LANGS_PKG}" ]; then