summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-10-17 15:30:03 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-10-17 15:30:03 +0000
commit1259d8c9f33f173c5df6d92841346ed95c32cf8a (patch)
tree0fb44654bfa8ccab1666bb54a3e4a0530d21ece7 /app-text/bibletime
parentMark 3.4.1 stable on alpha (diff)
downloadgentoo-2-1259d8c9f33f173c5df6d92841346ed95c32cf8a.tar.gz
gentoo-2-1259d8c9f33f173c5df6d92841346ed95c32cf8a.tar.bz2
gentoo-2-1259d8c9f33f173c5df6d92841346ed95c32cf8a.zip
New version.
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'app-text/bibletime')
-rw-r--r--app-text/bibletime/ChangeLog7
-rw-r--r--app-text/bibletime/bibletime-1.5.2.ebuild83
-rw-r--r--app-text/bibletime/files/digest-bibletime-1.5.22
3 files changed, 91 insertions, 1 deletions
diff --git a/app-text/bibletime/ChangeLog b/app-text/bibletime/ChangeLog
index 9d9dceabfade..9faf88d9871a 100644
--- a/app-text/bibletime/ChangeLog
+++ b/app-text/bibletime/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/bibletime
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/bibletime/ChangeLog,v 1.21 2005/10/11 12:42:06 greg_g Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/bibletime/ChangeLog,v 1.22 2005/10/17 15:30:03 greg_g Exp $
+
+*bibletime-1.5.2 (17 Oct 2005)
+
+ 17 Oct 2005; Gregorio Guidi <greg_g@gentoo.org> +bibletime-1.5.2.ebuild:
+ New version.
*bibletime-1.5.1 (11 Oct 2005)
diff --git a/app-text/bibletime/bibletime-1.5.2.ebuild b/app-text/bibletime/bibletime-1.5.2.ebuild
new file mode 100644
index 000000000000..f226c37c3794
--- /dev/null
+++ b/app-text/bibletime/bibletime-1.5.2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/bibletime/bibletime-1.5.2.ebuild,v 1.1 2005/10/17 15:30:03 greg_g Exp $
+
+inherit kde eutils
+
+DESCRIPTION="KDE Bible study application using the SWORD library."
+HOMEPAGE="http://www.bibletime.info/"
+SRC_URI="mirror://sourceforge/bibletime/${P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=app-text/sword-1.5.8"
+
+LANGS_PKG=${PN}-i18n-1.5.1
+LANGS="af bg cs da de en_GB es fi fr hu it ko nl nn_NO no pl pt_BR ro ru sk ua"
+LANGS_DOC="bg cs de fi fr it ko nl pt_BR ru"
+
+for X in ${LANGS}; do
+ SRC_URI="${SRC_URI} linguas_${X}? ( mirror://sourceforge/bibletime/${LANGS_PKG}.tar.bz2 )"
+done
+
+need-kde 3
+
+pkg_setup() {
+ if ! built_with_use app-text/sword curl; then
+ echo
+ ewarn "The SWORD library may not have been compiled with curl support."
+ ewarn "If you wish to use BibleTime's ability to download modules"
+ ewarn "straight from the SWORD website, please make sure app-text/sword"
+ ewarn "was compiled with USE=\"curl\"."
+ ewarn "Press ctrl+c to abort the merge of BibleTime if you want to"
+ ewarn "recompile SWORD with curl support."
+ echo
+ ebeep 5
+ fi
+}
+
+src_unpack() {
+ kde_src_unpack
+
+ local MAKE_LANGS MAKE_LANGS_DOC
+ for X in ${LANGS}; do
+ use linguas_${X} && MAKE_LANGS="${MAKE_LANGS} ${X/pt_BR/pt_br}.po"
+ done
+ for X in ${LANGS_DOC}; do
+ use linguas_${X} && MAKE_LANGS_DOC="${MAKE_LANGS_DOC} ${X/pt_BR/pt-br}"
+ done
+
+ if [ -d "${WORKDIR}/${LANGS_PKG}" ]; then
+ cd ${WORKDIR}/${LANGS_PKG}/
+ sed -i -e "s,^POFILES.*,POFILES = ${MAKE_LANGS}," po/Makefile.am
+ sed -i -e "s,^SUBDIRS.*,SUBDIRS = ${MAKE_LANGS_DOC}," docs/Makefile.am
+ make -f admin/Makefile.common || die
+ fi
+}
+
+src_compile() {
+ kde_src_compile
+
+ local _S="${S}"
+ if [ -d "${WORKDIR}/${LANGS_PKG}" ]; then
+ S="${WORKDIR}/${LANGS_PKG}"
+ cd "${S}"
+ kde_src_compile
+ fi
+ S="${_S}"
+}
+
+src_install() {
+ kde_src_install
+
+ local _S="${S}"
+ if [ -d "${WORKDIR}/${LANGS_PKG}" ]; then
+ S="${WORKDIR}/${LANGS_PKG}"
+ cd "${S}"
+ kde_src_install
+ fi
+ S="${_S}"
+}
diff --git a/app-text/bibletime/files/digest-bibletime-1.5.2 b/app-text/bibletime/files/digest-bibletime-1.5.2
new file mode 100644
index 000000000000..cbedc1f70845
--- /dev/null
+++ b/app-text/bibletime/files/digest-bibletime-1.5.2
@@ -0,0 +1,2 @@
+MD5 c51967122970e4d8348c482e6ffd35b7 bibletime-1.5.2.tar.bz2 1172884
+MD5 e6e5e1865e1eaf01f3da0c48417ae18b bibletime-i18n-1.5.1.tar.bz2 1007666