summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-03-20 05:53:12 +0000
committerAchim Gottinger <achim@gentoo.org>2001-03-20 05:53:12 +0000
commit4415b4ee260378e5157a93df32c252270308b7e1 (patch)
tree605a3792db7d2a65fc908c9d29442a8dc5ce76d8 /app-text/docbook-sgml-dtd
parent*** empty log message *** (diff)
downloadgentoo-2-4415b4ee260378e5157a93df32c252270308b7e1.tar.gz
gentoo-2-4415b4ee260378e5157a93df32c252270308b7e1.tar.bz2
gentoo-2-4415b4ee260378e5157a93df32c252270308b7e1.zip
*** empty log message ***
Diffstat (limited to 'app-text/docbook-sgml-dtd')
-rw-r--r--app-text/docbook-sgml-dtd/docbook-sgml-dtd-3.0.ebuild37
-rw-r--r--app-text/docbook-sgml-dtd/docbook-sgml-dtd-3.1.ebuild38
-rw-r--r--app-text/docbook-sgml-dtd/docbook-sgml-dtd-4.0.ebuild37
-rw-r--r--app-text/docbook-sgml-dtd/docbook-sgml-dtd-4.1.ebuild37
-rw-r--r--app-text/docbook-sgml-dtd/files/digest-docbook-sgml-dtd-3.01
-rw-r--r--app-text/docbook-sgml-dtd/files/digest-docbook-sgml-dtd-3.11
-rw-r--r--app-text/docbook-sgml-dtd/files/digest-docbook-sgml-dtd-4.01
-rw-r--r--app-text/docbook-sgml-dtd/files/digest-docbook-sgml-dtd-4.11
-rw-r--r--app-text/docbook-sgml-dtd/files/docbook-sgml-dtd-3.0-catalog.diff41
-rw-r--r--app-text/docbook-sgml-dtd/files/docbook-sgml-dtd-3.0.Makefile10
-rw-r--r--app-text/docbook-sgml-dtd/files/docbook-sgml-dtd-3.1-catalog.diff41
-rw-r--r--app-text/docbook-sgml-dtd/files/docbook-sgml-dtd-3.1.Makefile10
-rw-r--r--app-text/docbook-sgml-dtd/files/docbook-sgml-dtd-4.0-catalog.diff41
-rw-r--r--app-text/docbook-sgml-dtd/files/docbook-sgml-dtd-4.0.Makefile10
-rw-r--r--app-text/docbook-sgml-dtd/files/docbook-sgml-dtd-4.1-catalog.diff41
-rw-r--r--app-text/docbook-sgml-dtd/files/docbook-sgml-dtd-4.1.Makefile10
16 files changed, 357 insertions, 0 deletions
diff --git a/app-text/docbook-sgml-dtd/docbook-sgml-dtd-3.0.ebuild b/app-text/docbook-sgml-dtd/docbook-sgml-dtd-3.0.ebuild
new file mode 100644
index 000000000000..5a6cec95119d
--- /dev/null
+++ b/app-text/docbook-sgml-dtd/docbook-sgml-dtd-3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/docbook-sgml-dtd/docbook-sgml-dtd-3.0.ebuild,v 1.1 2001/03/20 05:53:12 achim Exp $
+
+A="docbk30.zip"
+S=${WORKDIR}/${P}
+DESCRIPTION="Docbook SGML DTD 3.0"
+SRC_URI="http://www.oasis-open.org/docbook/sgml/${PV}/${A}"
+
+HOMEPAGE="http://www.oasis-open.org/docbook/sgml/${PV}/index.html"
+
+DEPEND=">=app-arch/unzip-5.41
+ app-text/sgml-common"
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ unpack ${A}
+ cp ${FILESDIR}/${P}.Makefile Makefile
+ patch -b docbook.cat ${FILESDIR}/${P}-catalog.diff
+}
+
+src_install () {
+
+ try make DESTDIR=${D}/usr/share/sgml/docbook/sgml-dtd-${PV} install
+ dodoc *.txt
+}
+
+pkg_postinst() {
+ install-catalog --add /etc/sgml/sgml-docbook-${PV}.cat /usr/share/sgml/docbook/sgml-dtd-${PV}/catalog
+ install-catalog --add /etc/sgml/sgml-docbook-${PV}.cat /etc/sgml/sgml-docbook.cat
+}
+pkg_prerm() {
+ install-catalog --remove /etc/sgml/sgml-docbook-${PV}.cat /usr/share/sgml/docbook/sgml-dtd-${PV}/catalog
+ install-catalog --remove /etc/sgml/sgml-docbook-${PV}.cat /etc/sgml/sgml-docbook.cat
+}
diff --git a/app-text/docbook-sgml-dtd/docbook-sgml-dtd-3.1.ebuild b/app-text/docbook-sgml-dtd/docbook-sgml-dtd-3.1.ebuild
new file mode 100644
index 000000000000..c04b1d169b73
--- /dev/null
+++ b/app-text/docbook-sgml-dtd/docbook-sgml-dtd-3.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/docbook-sgml-dtd/docbook-sgml-dtd-3.1.ebuild,v 1.1 2001/03/20 05:53:12 achim Exp $
+
+A="docbk31.zip"
+S=${WORKDIR}/${P}
+DESCRIPTION="Docbook SGML DTD 3.1"
+SRC_URI="http://www.oasis-open.org/docbook/sgml/${PV}/${A}"
+
+HOMEPAGE="http://www.oasis-open.org/docbook/sgml/${PV}/index.html"
+
+DEPEND=">=app-arch/unzip-5.41
+ app-text/sgml-common"
+
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ unpack ${A}
+ cp ${FILESDIR}/${P}.Makefile Makefile
+ patch -b docbook.cat ${FILESDIR}/${P}-catalog.diff
+}
+
+src_install () {
+
+ try make DESTDIR=${D}/usr/share/sgml/docbook/sgml-dtd-${PV} install
+ dodoc *.txt
+}
+
+pkg_postinst() {
+ install-catalog --add /etc/sgml/sgml-docbook-${PV}.cat /usr/share/sgml/docbook/sgml-dtd-${PV}/catalog
+ install-catalog --add /etc/sgml/sgml-docbook-${PV}.cat /etc/sgml/sgml-docbook.cat
+}
+pkg_prerm() {
+ install-catalog --remove /etc/sgml/sgml-docbook-${PV}.cat /usr/share/sgml/docbooke/sgml-dtd-${PV}/catalog
+ install-catalog --remove /etc/sgml/sgml-docbook-${PV}.cat /etc/sgml/sgml-docbook.cat
+}
diff --git a/app-text/docbook-sgml-dtd/docbook-sgml-dtd-4.0.ebuild b/app-text/docbook-sgml-dtd/docbook-sgml-dtd-4.0.ebuild
new file mode 100644
index 000000000000..2d8f7db97465
--- /dev/null
+++ b/app-text/docbook-sgml-dtd/docbook-sgml-dtd-4.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/docbook-sgml-dtd/docbook-sgml-dtd-4.0.ebuild,v 1.1 2001/03/20 05:53:12 achim Exp $
+
+A="docbk40.zip"
+S=${WORKDIR}/${P}
+DESCRIPTION="Docbook SGML DTD 4.0"
+SRC_URI="http://www.oasis-open.org/docbook/sgml/${PV}/${A}"
+
+HOMEPAGE="http://www.oasis-open.org/docbook/sgml/${PV}/index.html"
+
+DEPEND=">=app-arch/unzip-5.41
+ app-text/sgml-common"
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ unpack ${A}
+ cp ${FILESDIR}/${P}.Makefile Makefile
+ patch -b docbook.cat ${FILESDIR}/${P}-catalog.diff
+}
+
+src_install () {
+
+ try make DESTDIR=${D}/usr/share/sgml/docbook/sgml-dtd-${PV} install
+ dodoc *.txt
+}
+
+pkg_postinst() {
+ install-catalog --add /etc/sgml/sgml-docbook-${PV}.cat /usr/share/sgml/docbook/sgml-dtd-${PV}/catalog
+ install-catalog --add /etc/sgml/sgml-docbook-${PV}.cat /etc/sgml/sgml-docbook.cat
+}
+pkg_prerm() {
+ install-catalog --remove /etc/sgml/sgml-docbook-${PV}.cat /usr/share/sgml/docbook/sgml-dtd-${PV}/catalog
+ install-catalog --remove /etc/sgml/sgml-docbook-${PV}.cat /etc/sgml/sgml-docbook.cat
+}
diff --git a/app-text/docbook-sgml-dtd/docbook-sgml-dtd-4.1.ebuild b/app-text/docbook-sgml-dtd/docbook-sgml-dtd-4.1.ebuild
new file mode 100644
index 000000000000..4ce7eba10ed2
--- /dev/null
+++ b/app-text/docbook-sgml-dtd/docbook-sgml-dtd-4.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/docbook-sgml-dtd/docbook-sgml-dtd-4.1.ebuild,v 1.1 2001/03/20 05:53:12 achim Exp $
+
+A="docbk41.zip"
+S=${WORKDIR}/${P}
+DESCRIPTION="Docbook SGML DTD 4.1"
+SRC_URI="http://www.oasis-open.org/docbook/sgml/${PV}/${A}"
+
+HOMEPAGE="http://www.oasis-open.org/docbook/sgml/${PV}/index.html"
+
+DEPEND=">=app-arch/unzip-5.41
+ app-text/sgml-common"
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ unpack ${A}
+ cp ${FILESDIR}/${P}.Makefile Makefile
+ patch -b docbook.cat ${FILESDIR}/${P}-catalog.diff
+}
+
+src_install () {
+
+ try make DESTDIR=${D}/usr/share/sgml/docbook/sgml-dtd-${PV} install
+ dodoc *.txt
+}
+
+pkg_postinst() {
+ install-catalog --add /etc/sgml/sgml-docbook-${PV}.cat /usr/share/sgml/docbook/sgml-dtd-${PV}/catalog
+ install-catalog --add /etc/sgml/sgml-docbook-${PV}.cat /etc/sgml/sgml-docbook.cat
+}
+pkg_prerm() {
+ install-catalog --remove /etc/sgml/sgml-docbook-${PV}.cat /usr/share/sgml/docbook/sgml-dtd-${PV}/catalog
+ install-catalog --remove /etc/sgml/sgml-docbook-${PV}.cat /etc/sgml/sgml-docbook.cat
+}
diff --git a/app-text/docbook-sgml-dtd/files/digest-docbook-sgml-dtd-3.0 b/app-text/docbook-sgml-dtd/files/digest-docbook-sgml-dtd-3.0
new file mode 100644
index 000000000000..825aef411fc9
--- /dev/null
+++ b/app-text/docbook-sgml-dtd/files/digest-docbook-sgml-dtd-3.0
@@ -0,0 +1 @@
+MD5 9a7f5b1b7dd52d0ca4fb080619f0459c docbk30.zip
diff --git a/app-text/docbook-sgml-dtd/files/digest-docbook-sgml-dtd-3.1 b/app-text/docbook-sgml-dtd/files/digest-docbook-sgml-dtd-3.1
new file mode 100644
index 000000000000..b5de823af703
--- /dev/null
+++ b/app-text/docbook-sgml-dtd/files/digest-docbook-sgml-dtd-3.1
@@ -0,0 +1 @@
+MD5 432749c0c806dbae81c8bcb70da3b5d3 docbk31.zip
diff --git a/app-text/docbook-sgml-dtd/files/digest-docbook-sgml-dtd-4.0 b/app-text/docbook-sgml-dtd/files/digest-docbook-sgml-dtd-4.0
new file mode 100644
index 000000000000..5add463f404a
--- /dev/null
+++ b/app-text/docbook-sgml-dtd/files/digest-docbook-sgml-dtd-4.0
@@ -0,0 +1 @@
+MD5 fabcf7dd1d88b94797b7e5344389eab9 docbk40.zip
diff --git a/app-text/docbook-sgml-dtd/files/digest-docbook-sgml-dtd-4.1 b/app-text/docbook-sgml-dtd/files/digest-docbook-sgml-dtd-4.1
new file mode 100644
index 000000000000..34bcfead3fc5
--- /dev/null
+++ b/app-text/docbook-sgml-dtd/files/digest-docbook-sgml-dtd-4.1
@@ -0,0 +1 @@
+MD5 489f6ff2a2173eb1e14216c10533ede2 docbk41.zip
diff --git a/app-text/docbook-sgml-dtd/files/docbook-sgml-dtd-3.0-catalog.diff b/app-text/docbook-sgml-dtd/files/docbook-sgml-dtd-3.0-catalog.diff
new file mode 100644
index 000000000000..6319fecfc9a3
--- /dev/null
+++ b/app-text/docbook-sgml-dtd/files/docbook-sgml-dtd-3.0-catalog.diff
@@ -0,0 +1,41 @@
+--- docbook.cat Tue Dec 10 16:35:22 1996
++++ catalog Mon Jun 5 11:08:34 2000
+@@ -27,7 +27,7 @@
+ -- ...................................................................... --
+ -- SGML declaration associated with DocBook ............................. --
+
+-DTDDECL "-//Davenport//DTD DocBook V3.0//EN" "docbook.dcl"
++SGMLDECL "docbook.dcl"
+
+ -- ...................................................................... --
+ -- DocBook driver file .................................................. --
+@@ -41,29 +41,6 @@
+ PUBLIC "-//Davenport//ELEMENTS DocBook Information Pool V3.0//EN" "dbpool.mod"
+ PUBLIC "-//Davenport//ELEMENTS DocBook Document Hierarchy V3.0//EN" "dbhier.mod"
+ PUBLIC "-//Davenport//ENTITIES DocBook Additional General Entities V3.0//EN" "dbgenent.mod"
+-
+- -- ...................................................................... --
+- -- ISO entity sets ...................................................... --
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Diacritical Marks//EN" "iso-dia.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Numeric and Special Graphic//EN" "iso-num.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Publishing//EN" "iso-pub.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES General Technical//EN" "iso-tech.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Added Latin 1//EN" "iso-lat1.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Added Latin 2//EN" "iso-lat2.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Greek Letters//EN" "iso-grk1.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Monotoniko Greek//EN" "iso-grk2.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Greek Symbols//EN" "iso-grk3.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Alternative Greek Symbols//EN" "iso-grk4.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Arrow Relations//EN" "iso-amsa.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Binary Operators//EN" "iso-amsb.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Delimiters//EN" "iso-amsc.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Negated Relations//EN" "iso-amsn.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Ordinary//EN" "iso-amso.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Relations//EN" "iso-amsr.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Box and Line Drawing//EN" "iso-box.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Russian Cyrillic//EN" "iso-cyr1.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Non-Russian Cyrillic//EN" "iso-cyr2.gml"
+
+ -- End of catalog data for DocBook V3.0 ................................. --
+ -- ...................................................................... --
diff --git a/app-text/docbook-sgml-dtd/files/docbook-sgml-dtd-3.0.Makefile b/app-text/docbook-sgml-dtd/files/docbook-sgml-dtd-3.0.Makefile
new file mode 100644
index 000000000000..7de1fbedf768
--- /dev/null
+++ b/app-text/docbook-sgml-dtd/files/docbook-sgml-dtd-3.0.Makefile
@@ -0,0 +1,10 @@
+DESTDIR = /usr/share/sgml/docbook/sgml/dtd/3.0
+
+all: install
+
+install:
+ mkdir -p $(DESTDIR)
+ install *.dcl $(DESTDIR)
+ install docbook.cat $(DESTDIR)/catalog
+ install *.dtd $(DESTDIR)
+ install *.mod $(DESTDIR)
diff --git a/app-text/docbook-sgml-dtd/files/docbook-sgml-dtd-3.1-catalog.diff b/app-text/docbook-sgml-dtd/files/docbook-sgml-dtd-3.1-catalog.diff
new file mode 100644
index 000000000000..7e52e89a9386
--- /dev/null
+++ b/app-text/docbook-sgml-dtd/files/docbook-sgml-dtd-3.1-catalog.diff
@@ -0,0 +1,41 @@
+--- docbook.cat Tue Feb 2 06:53:32 1999
++++ catalog Thu May 25 11:45:01 2000
+@@ -19,7 +19,7 @@
+ -- ...................................................................... --
+ -- SGML declaration associated with DocBook ............................. --
+
+-DTDDECL "-//OASIS//DTD DocBook V3.1//EN" "docbook.dcl"
++SGMLDECL "docbook.dcl"
+
+ -- ...................................................................... --
+ -- DocBook driver file .................................................. --
+@@ -35,29 +35,6 @@
+ PUBLIC "-//OASIS//ENTITIES DocBook Additional General Entities V3.1//EN" "dbgenent.mod"
+ PUBLIC "-//OASIS//ENTITIES DocBook Notations V3.1//EN" "dbnotn.mod"
+ PUBLIC "-//OASIS//ENTITIES DocBook Character Entities V3.1//EN" "dbcent.mod"
+-
+- -- ...................................................................... --
+- -- ISO entity sets ...................................................... --
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Diacritical Marks//EN" "iso-dia.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Numeric and Special Graphic//EN" "iso-num.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Publishing//EN" "iso-pub.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES General Technical//EN" "iso-tech.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Added Latin 1//EN" "iso-lat1.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Added Latin 2//EN" "iso-lat2.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Greek Letters//EN" "iso-grk1.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Monotoniko Greek//EN" "iso-grk2.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Greek Symbols//EN" "iso-grk3.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Alternative Greek Symbols//EN" "iso-grk4.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Arrow Relations//EN" "iso-amsa.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Binary Operators//EN" "iso-amsb.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Delimiters//EN" "iso-amsc.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Negated Relations//EN" "iso-amsn.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Ordinary//EN" "iso-amso.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Relations//EN" "iso-amsr.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Box and Line Drawing//EN" "iso-box.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Russian Cyrillic//EN" "iso-cyr1.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Non-Russian Cyrillic//EN" "iso-cyr2.gml"
+
+ -- End of catalog data for DocBook V3.1 ................................. --
+ -- ...................................................................... --
diff --git a/app-text/docbook-sgml-dtd/files/docbook-sgml-dtd-3.1.Makefile b/app-text/docbook-sgml-dtd/files/docbook-sgml-dtd-3.1.Makefile
new file mode 100644
index 000000000000..3b610d8a5a4b
--- /dev/null
+++ b/app-text/docbook-sgml-dtd/files/docbook-sgml-dtd-3.1.Makefile
@@ -0,0 +1,10 @@
+DESTDIR = /usr/share/sgml/docbook/sgml/dtd/3.1
+
+all: install
+
+install:
+ mkdir -p $(DESTDIR)
+ install *.dcl $(DESTDIR)
+ install docbook.cat $(DESTDIR)/catalog
+ install *.dtd $(DESTDIR)
+ install *.mod $(DESTDIR)
diff --git a/app-text/docbook-sgml-dtd/files/docbook-sgml-dtd-4.0-catalog.diff b/app-text/docbook-sgml-dtd/files/docbook-sgml-dtd-4.0-catalog.diff
new file mode 100644
index 000000000000..d8125b752c6d
--- /dev/null
+++ b/app-text/docbook-sgml-dtd/files/docbook-sgml-dtd-4.0-catalog.diff
@@ -0,0 +1,41 @@
+--- docbook.cat Mon May 22 22:38:05 2000
++++ catalog Mon May 22 22:12:36 2000
+@@ -19,7 +19,7 @@
+ -- ...................................................................... --
+ -- SGML declaration associated with DocBook ............................. --
+
+-DTDDECL "-//OASIS//DTD DocBook V4.0//EN" "docbook.dcl"
++SGMLDECL "docbook.dcl"
+
+ -- ...................................................................... --
+ -- DocBook driver file .................................................. --
+@@ -35,29 +35,6 @@
+ PUBLIC "-//OASIS//ENTITIES DocBook Additional General Entities V4.0//EN" "dbgenent.mod"
+ PUBLIC "-//OASIS//ENTITIES DocBook Notations V4.0//EN" "dbnotn.mod"
+ PUBLIC "-//OASIS//ENTITIES DocBook Character Entities V4.0//EN" "dbcent.mod"
+-
+- -- ...................................................................... --
+- -- ISO entity sets ...................................................... --
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Diacritical Marks//EN" "iso-dia.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Numeric and Special Graphic//EN" "iso-num.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Publishing//EN" "iso-pub.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES General Technical//EN" "iso-tech.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Added Latin 1//EN" "iso-lat1.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Added Latin 2//EN" "iso-lat2.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Greek Letters//EN" "iso-grk1.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Monotoniko Greek//EN" "iso-grk2.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Greek Symbols//EN" "iso-grk3.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Alternative Greek Symbols//EN" "iso-grk4.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Arrow Relations//EN" "iso-amsa.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Binary Operators//EN" "iso-amsb.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Delimiters//EN" "iso-amsc.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Negated Relations//EN" "iso-amsn.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Ordinary//EN" "iso-amso.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Relations//EN" "iso-amsr.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Box and Line Drawing//EN" "iso-box.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Russian Cyrillic//EN" "iso-cyr1.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Non-Russian Cyrillic//EN" "iso-cyr2.gml"
+
+ -- End of catalog data for DocBook V4.0 ................................. --
+ -- ...................................................................... --
diff --git a/app-text/docbook-sgml-dtd/files/docbook-sgml-dtd-4.0.Makefile b/app-text/docbook-sgml-dtd/files/docbook-sgml-dtd-4.0.Makefile
new file mode 100644
index 000000000000..a04686c72cc9
--- /dev/null
+++ b/app-text/docbook-sgml-dtd/files/docbook-sgml-dtd-4.0.Makefile
@@ -0,0 +1,10 @@
+DESTDIR = /usr/share/sgml/docbook/sgml/dtd/4.0
+
+all: install
+
+install:
+ mkdir -p $(DESTDIR)
+ install *.dcl $(DESTDIR)
+ install docbook.cat $(DESTDIR)/catalog
+ install *.dtd $(DESTDIR)
+ install *.mod $(DESTDIR)
diff --git a/app-text/docbook-sgml-dtd/files/docbook-sgml-dtd-4.1-catalog.diff b/app-text/docbook-sgml-dtd/files/docbook-sgml-dtd-4.1-catalog.diff
new file mode 100644
index 000000000000..c08243a574fd
--- /dev/null
+++ b/app-text/docbook-sgml-dtd/files/docbook-sgml-dtd-4.1-catalog.diff
@@ -0,0 +1,41 @@
+--- docbook.cat Mon May 22 22:38:05 2000
++++ catalog Mon May 22 22:12:36 2000
+@@ -19,7 +19,7 @@
+ -- ...................................................................... --
+ -- SGML declaration associated with DocBook ............................. --
+
+-DTDDECL "-//OASIS//DTD DocBook V4.1//EN" "docbook.dcl"
++SGMLDECL "docbook.dcl"
+
+ -- ...................................................................... --
+ -- DocBook driver file .................................................. --
+@@ -35,29 +35,6 @@
+ PUBLIC "-//OASIS//ENTITIES DocBook Additional General Entities V4.1//EN" "dbgenent.mod"
+ PUBLIC "-//OASIS//ENTITIES DocBook Notations V4.1//EN" "dbnotn.mod"
+ PUBLIC "-//OASIS//ENTITIES DocBook Character Entities V4.1//EN" "dbcent.mod"
+-
+- -- ...................................................................... --
+- -- ISO entity sets ...................................................... --
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Diacritical Marks//EN" "iso-dia.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Numeric and Special Graphic//EN" "iso-num.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Publishing//EN" "iso-pub.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES General Technical//EN" "iso-tech.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Added Latin 1//EN" "iso-lat1.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Added Latin 2//EN" "iso-lat2.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Greek Letters//EN" "iso-grk1.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Monotoniko Greek//EN" "iso-grk2.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Greek Symbols//EN" "iso-grk3.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Alternative Greek Symbols//EN" "iso-grk4.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Arrow Relations//EN" "iso-amsa.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Binary Operators//EN" "iso-amsb.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Delimiters//EN" "iso-amsc.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Negated Relations//EN" "iso-amsn.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Ordinary//EN" "iso-amso.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Relations//EN" "iso-amsr.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Box and Line Drawing//EN" "iso-box.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Russian Cyrillic//EN" "iso-cyr1.gml"
+-PUBLIC "ISO 8879:1986//ENTITIES Non-Russian Cyrillic//EN" "iso-cyr2.gml"
+
+ -- End of catalog data for DocBook V4.1 ................................. --
+ -- ...................................................................... --
diff --git a/app-text/docbook-sgml-dtd/files/docbook-sgml-dtd-4.1.Makefile b/app-text/docbook-sgml-dtd/files/docbook-sgml-dtd-4.1.Makefile
new file mode 100644
index 000000000000..02e461b787d2
--- /dev/null
+++ b/app-text/docbook-sgml-dtd/files/docbook-sgml-dtd-4.1.Makefile
@@ -0,0 +1,10 @@
+DESTDIR = /usr/share/sgml/docbook/sgml/dtd/4.1
+
+all: install
+
+install:
+ mkdir -p $(DESTDIR)
+ install *.dcl $(DESTDIR)
+ install docbook.cat $(DESTDIR)/catalog
+ install *.dtd $(DESTDIR)
+ install *.mod $(DESTDIR)