summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-07-07 15:19:51 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-07-07 15:19:51 +0000
commit15436d5129cd1776bd94181f0be589f2ee45cfe3 (patch)
tree4f0cc680e554760990697c55b1ca402163b68a85 /app-text/dvipdfm/dvipdfm-0.13.2d-r2.ebuild
parentStable for ia64, wrt bug #475744 (diff)
downloadgentoo-2-15436d5129cd1776bd94181f0be589f2ee45cfe3.tar.gz
gentoo-2-15436d5129cd1776bd94181f0be589f2ee45cfe3.tar.bz2
gentoo-2-15436d5129cd1776bd94181f0be589f2ee45cfe3.zip
install in texmf-site
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'app-text/dvipdfm/dvipdfm-0.13.2d-r2.ebuild')
-rw-r--r--app-text/dvipdfm/dvipdfm-0.13.2d-r2.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/app-text/dvipdfm/dvipdfm-0.13.2d-r2.ebuild b/app-text/dvipdfm/dvipdfm-0.13.2d-r2.ebuild
new file mode 100644
index 000000000000..ca4523d0effe
--- /dev/null
+++ b/app-text/dvipdfm/dvipdfm-0.13.2d-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/dvipdfm/dvipdfm-0.13.2d-r2.ebuild,v 1.1 2013/07/07 15:19:51 aballier Exp $
+
+EAPI=3
+inherit eutils
+
+DESCRIPTION="DVI to PDF translator"
+SRC_URI="http://gaspra.kettering.edu/dvipdfm/${P}.tar.gz"
+HOMEPAGE="http://gaspra.kettering.edu/dvipdfm/"
+LICENSE="GPL-2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+DEPEND="!>=app-text/tetex-2
+ >=media-libs/libpng-1.2.1
+ >=sys-libs/zlib-1.1.4
+ !app-text/ptex
+ virtual/latex-base"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libpng14.patch
+}
+
+src_install () {
+ einstall texmf="${ED}usr/share/texmf-site" || die "einstall failed!"
+
+ # Install .map and .enc files to correct locations, bug #200956
+ dodir /usr/share/texmf-site/fonts/map/dvipdfm/base
+
+ for i in cmr.map psbase14.map lw35urw.map lw35urwa.map t1fonts.map; do
+ mv "${ED}usr/share/texmf-site/dvipdfm/config/${i}" "${ED}usr/share/texmf-site/fonts/map/dvipdfm/base" || die "moving .map file failed"
+ done
+
+ dodir /usr/share/texmf-site/fonts/enc/dvipdfm
+
+ mv "${ED}usr/share/texmf-site/dvipdfm/base" "${ED}usr/share/texmf-site/fonts/enc/dvipdfm/base" || die "moving .enc file failed"
+
+ dodoc AUTHORS ChangeLog Credits NEWS OBTAINING README* TODO
+
+ docinto doc
+ dodoc doc/*
+
+ docinto latex-support
+ dodoc latex-support/*
+
+ insinto /usr/share/texmf-site/tex/latex/dvipdfm/
+ doins latex-support/dvipdfm.def
+}
+
+pkg_postinst() {
+ if [ "$ROOT" = "/" ] ; then
+ "${EPREFIX}"/usr/sbin/texmf-update
+ fi
+}