summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-18 21:14:47 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-18 21:14:47 +0000
commite6784f76545a65780afab125a055960bced13897 (patch)
tree23939a3e96aa2e08885e6875f9a9ed04f4cc436c /app-text/expander/files
parentRespect CFLAGS (bug #336026). (diff)
downloadgentoo-2-e6784f76545a65780afab125a055960bced13897.tar.gz
gentoo-2-e6784f76545a65780afab125a055960bced13897.tar.bz2
gentoo-2-e6784f76545a65780afab125a055960bced13897.zip
Respect LDFLAGS (bug #336155, and do not duplicate in the emake call what the patch was already trying to do). Do not set empty DEPEND. Merge cd into emake call.
(Portage version: 2.2_rc83/cvs/Linux i686)
Diffstat (limited to 'app-text/expander/files')
-rw-r--r--app-text/expander/files/expander-2.0.5-gentoo.patch17
1 files changed, 8 insertions, 9 deletions
diff --git a/app-text/expander/files/expander-2.0.5-gentoo.patch b/app-text/expander/files/expander-2.0.5-gentoo.patch
index e6c023834939..460a8164cee5 100644
--- a/app-text/expander/files/expander-2.0.5-gentoo.patch
+++ b/app-text/expander/files/expander-2.0.5-gentoo.patch
@@ -1,13 +1,12 @@
-diff -ur expander/src/Makefile expander-gentoo/src/Makefile
---- expander/src/Makefile 2003-10-30 14:52:00.000000000 +1300
-+++ expander-gentoo/src/Makefile 2003-10-30 15:50:02.000000000 +1300
+--- a/src/Makefile
++++ b/src/Makefile
@@ -3,15 +3,14 @@
bindir = $(BINDIR)/
copy = ln -fs
-CFLAGS += -v -g # -DNEED_GETOPT_PROTO_TYPE
-compiler = cc $(CFLAGS)
-+compiler = gcc $(CFLAGS)
++compiler = $(CC) $(CFLAGS)
executables = expander boxcomment align_columns align_comments where_is
@@ -24,7 +23,7 @@ diff -ur expander/src/Makefile expander-gentoo/src/Makefile
#-----------------------------------------------------------------------
expander: expander.c
- $(compiler) -o $(bindir)$@ $?
-+ $(compiler) -o $@ $?
++ $(compiler) $(LDFLAGS) -o $@ $?
#--------------------------------------------------------------------------
# Surround given text with open ended box. (with NEdit, language sensitive)
@@ -32,28 +31,28 @@ diff -ur expander/src/Makefile expander-gentoo/src/Makefile
boxcomment: boxcomment.c
- $(compiler) -o $(bindir)$@ $?
- @if [ ! -f $(bindir)un$@ ]; then $(copy) $(bindir)$@ $(bindir)un$@; fi
-+ $(compiler) -o $@ $?
++ $(compiler) $(LDFLAGS) -o $@ $?
#-------------------------------------------------------------------------------
# Align ragged looking 'C' style comments (good substitute for align_equals too)
#-------------------------------------------------------------------------------
align_comments: align_comments.c
- $(compiler) -o $(bindir)$@ $?
-+ $(compiler) -o $@ $?
++ $(compiler) $(LDFLAGS) -o $@ $?
#----------------------------
# Align given text in columns
#----------------------------
align_columns: align_columns.c
- $(compiler) -o $(bindir)$@ $?
-+ $(compiler) -o $@ $?
++ $(compiler) $(LDFLAGS) -o $@ $?
#----------------------------------------------
# File locator (substitute for which, where...)
#----------------------------------------------
where_is: where_is.c
- $(compiler) -o $(bindir)$@ $?
-+ $(compiler) -o $@ $?
++ $(compiler) $(LDFLAGS) -o $@ $?
#------------------------------------------------
# Here is how to uninstall the executables built.