summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gardiner <obz@gentoo.org>2005-01-20 09:02:59 +0000
committerMike Gardiner <obz@gentoo.org>2005-01-20 09:02:59 +0000
commitc8478154b11215e69620451df6137d718f870560 (patch)
treeed4f93bb0e989e01d95c0d826ff7924b01a366a5 /app-text/gpdf/gpdf-2.8.2.ebuild
parentmark stable (diff)
downloadgentoo-2-c8478154b11215e69620451df6137d718f870560.tar.gz
gentoo-2-c8478154b11215e69620451df6137d718f870560.tar.bz2
gentoo-2-c8478154b11215e69620451df6137d718f870560.zip
New version 2.8.2, including fix for security vulnerability, see bug #78128
Diffstat (limited to 'app-text/gpdf/gpdf-2.8.2.ebuild')
-rw-r--r--app-text/gpdf/gpdf-2.8.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-text/gpdf/gpdf-2.8.2.ebuild b/app-text/gpdf/gpdf-2.8.2.ebuild
new file mode 100644
index 000000000000..4ac2e41dea21
--- /dev/null
+++ b/app-text/gpdf/gpdf-2.8.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gpdf/gpdf-2.8.2.ebuild,v 1.1 2005/01/20 09:02:59 obz Exp $
+
+inherit gnome2 flag-o-matic
+
+DESCRIPTION="Viewer for Portable Document Format (PDF) files"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc ~alpha ~sparc ~hppa ~amd64 ~ia64 ~mips"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.3
+ >=gnome-base/gconf-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libbonobo-2.2.1
+ >=gnome-base/libbonoboui-2
+ >=gnome-base/gnome-vfs-2
+ >=gnome-base/libgnomeprint-2.6
+ >=gnome-base/libgnomeprintui-2.2
+ >=gnome-base/libglade-2"
+
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=dev-util/intltool-0.29
+ >=dev-util/pkgconfig-0.12.0"
+
+PROVIDE="virtual/pdfviewer"
+
+DOCS="AUTHORS CHANGES ChangeLog NEWS README*"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ # fix sec vuln (#69662)
+ epatch ${FILESDIR}/${PN}-xpdf_goo_sizet.patch
+ # disable the tests, see bug #73882
+ sed -i -e "s:test-files::" Makefile.in
+ cd ${S}/xpdf
+ # fix sec vuln (#78128)
+ epatch ${FILESDIR}/${PN}-xpdf-3.00pl3.patch
+
+}
+